No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between Routing and Ethernet Interface Backup in Active/Standby Mode

Example for Configuring Association Between Routing and Ethernet Interface Backup in Active/Standby Mode

Networking Requirements

As shown in Figure 2-19, the link RouterA->RouterB->RouterD is the primary link and the link RouterA->RouterC->RouterD is the backup link.

Devices are required to monitor the route status of the primary interface to detect connectivity of the primary link. When the routing entry of the primary link is deleted or becomes inactive, a backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-19  Networking of association between interface backup and routing

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure interface IP addresses according to Figure 2-19.

  2. Configure IS-IS on the primary link (RouterA->RouterB->RouterD) so that the route from the primary link to the Router is reachable.

  3. Configure default routes RouterA, RouterC, and RouterD for the backup link so that the route from the backup link to the Router is reachable.
  4. Configure association between interface backup and routing on backup interface GE2/0/0 of RouterA. When the routing entry of the primary link is deleted or becomes inactive, a backup link is started to transmit services.

Procedure

  1. Configure interface IP addresses.

    # Assign an IP address to each interface. Use RouterA as an example.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit

  2. Configure IS-IS.

    # Set the IS-IS NET of RouterA to 10.0000.0000.0001.00, and set the IS-IS level to 1.

    [RouterA] isis 1
    [RouterA-isis-1] is-level level-1 
    [RouterA-isis-1] network-entity 10.0000.0000.0001.00
    [RouterA-isis-1] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] isis enable 1

    # Set the IS-IS NET of RouterB to 10.0000.0000.0002.00.

    [RouterB] isis 1
    [RouterB-isis-1] network-entity 10.0000.0000.0002.00
    [RouterB-isis-1] quit
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] isis enable 1
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] isis enable 1

    # Set the IS-IS NET of RouterD to 10.0000.0000.0003.00.

    [RouterD] isis 1
    [RouterD-isis-1] network-entity 10.0000.0000.0003.00
    [RouterD-isis-1] quit
    [RouterD] interface gigabitethernet 1/0/0
    [RouterD-GigabitEthernet1/0/0] isis enable 1

    After the configuration is complete, run the display isis lsdb command on RouterA to view the IS-IS LSDB.

    [RouterA] display isis lsdb
    
                            Database information for ISIS(1)
                            --------------------------------
    
                              Level-1 Link State Database
    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL
    -------------------------------------------------------------------------------
    0000.0000.0001.00-00* 0x0000000d   0x61b6        797           96      0/0/0
    0000.0000.0001.02-00* 0x00000003   0xaadf        797           55      0/0/0
    0000.0000.0002.00-00  0x0000000e   0xa507        1124          84      0/0/0
    0000.0000.0003.00-00  0x00000005   0xb274        250           68      0/0/0
    0000.0000.0003.01-00  0x00000002   0xc5c2        250           55      0/0/0
    
    Total LSP(s): 5
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),
               ATT-Attached, P-Partition, OL-Overload  

    Run the display isis route command to view the routing information on RouterA.

    [RouterA] display isis route
    
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-1 Forwarding Table
                            --------------------------------
    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------------
    10.1.2.0/24           10         NULL    GE1/0/0         Direct          D/-/L/-
    10.1.4.0/24           20         NULL    GE1/0/0         10.1.2.2         A/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set
    

  3. Configure static routes for the link RouterA->RouterC->RouterD.

    # On RouterA, configure a static route to RouterD.

    [RouterA] ip route-static 10.1.5.0 255.255.255.0 10.1.3.2

    # On RouterD, configure a static route to RouterA.

    [RouterD] ip route-static 10.1.3.0 255.255.255.0 10.1.5.1

  4. Configure association between interface backup and routing on backup interface GE2/0/0 of RouterA.

    [RouterA] interface gigabitethernet2/0/0
    [RouterA-GigabitEthernet2/0/0] standby track ip route 10.1.4.0 255.255.255.0

  5. Verify the configuration.

    After the configuration is complete, RouterA can ping the destination IP address 10.1.4.2/24.

    <RouterA> ping 10.1.4.2
      PING 10.1.4.2: 56 data bytes, press CTRL_C to break                            
        Reply from 10.1.4.2: bytes=56 Sequence=1 ttl=255 time=1 ms                   
        Reply from 10.1.4.2: bytes=56 Sequence=2 ttl=255 time=5 ms                   
        Reply from 10.1.4.2: bytes=56 Sequence=3 ttl=255 time=1 ms                   
        Reply from 10.1.4.2: bytes=56 Sequence=4 ttl=255 time=2 ms                   
        Reply from 10.1.4.2: bytes=56 Sequence=5 ttl=255 time=1 ms                   
                                                                                    
      --- 10.1.4.2 ping statistics ---                                               
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/2/5 ms                                           
                                                                                    

    # Check the status of the backup interface and associated route on RouterA. You can see that the route to 10.1.4.0/24 is in OK state, and GE2/0/0 is in STANDBY state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    10.1.4.0/24                OK           GigabitEthernet2/0/0       STANDBY       
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

    Run the shutdown command on GE2/0/0 of RouterB to simulate a link fault.

    Run the display standby state command on RouterA. The command output shows that the route status is ERR, and the status of GigabitEthernet2/0/0 is UP, indicating that the backup interface has started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    10.1.4.0/24                ERR          GigabitEthernet2/0/0       UP            
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
                                                                                    

    Run the undo shutdown command on GigabitEthernet2/0/0 of RouterB to make the interface Up. Run the display standby state command on RouterA. The command output shows that the route status is OK and backup interface GigabitEthernet2/0/0 has switched to the standby state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    10.1.4.0/24                OK           GigabitEthernet2/0/0       STANDBY       
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #           
    isis 1                
     is-level level-1                        
     network-entity 10.0000.0000.0001.00     
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.1 255.255.255.0
     isis enable 1                         
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.3.1 255.255.255.0
     standby track ip route 10.1.4.0 255.255.255.0      
    #
     ip route-static 10.1.5.0 255.255.255.0 10.1.3.2   
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #           
    isis 1                
     network-entity 10.0000.0000.0002.00    
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.2 255.255.255.0
     isis enable 1                         
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.4.1 255.255.255.0
     isis enable 1                         
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.3.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.1 255.255.255.0
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    isis 1                
     network-entity 10.0000.0000.0003.00                          
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.4.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.2 255.255.255.0
    #
     ip route-static 10.1.3.0 255.255.255.0 10.1.5.1   
    #
    return
Translation
Download
Updated: 2019-08-12

Document ID: EDOC1100034076

Views: 56951

Downloads: 107

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next