No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Associating Interface Backup with BFD to Configure an ADSL Interface as the Backup of an Ethernet Interface

Example for Associating Interface Backup with BFD to Configure an ADSL Interface as the Backup of an Ethernet Interface

Networking Requirements

As shown in Figure 2-24, the egress gateway RouterA in the headquarters of company connects to the Internet through GE1/0/0. The link between GE1/0/0 and the Internet is used as the primary link, and the link between ATM0/0/0 (ADSL interface) and the Internet is used as the backup link.

Devices are required to monitor the primary link status within 50 ms. When the primary link is faulty, the backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-24  Networking diagram of association between interface backup and BFD

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on routes along the primary link and static routes to ensure connectivity at the network layer.

  2. Configure RS-DCC on RouterA so that the backup link transmits services when the primary link is faulty.

  3. Configure BFD sessions on RouterA and RouterB to monitor the primary link status.

  4. Associate interface backup with BFD on backup interface ATM0/0/0 of RouterA. When the BFD session detects a fault on the primary link, traffic can be rapidly switched to the backup interface.

Procedure

  1. Implement connectivity at the network layer.

    # Assign an IP address to the interface of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface GigabitEthernet1/0/0
    RouterA-GigabitEthernet1/0/0] ip address 2.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    

    # Assign an IP address to the interface of RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface GigabitEthernet1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 4.1.1.2 255.255.255.0
    [RouterB-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterC.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 2.1.1.2 255.255.255.0
    [RouterC-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterD.

    [RouterD] interface gigabitethernet1/0/0
    [RouterD-GigabitEthernet1/0/0] ip address 4.1.1.1 255.255.255.0
    [RouterD-GigabitEthernet1/0/0] quit

    # On RouterA, configure a static route to 4.1.1.0/24 of RouterB.

    [RouterA] ip route-static 4.1.1.0 255.255.255.0 2.1.1.2 preference 80

    # On RouterB, configure a static route to 2.1.1.0/24 of RouterA.

    [RouterB] ip route-static 2.1.1.0 255.255.255.0 4.1.1.1 preference 80

  2. Configure RS-DCC on RouterA.

    # Configure a dialer interface.

    [RouterA] dialer-rule
    [RouterA-dialer-rule] dialer-rule 10 ip permit
    [RouterA-dialer-rule] quit
    [RouterA] interface dialer 1
    [RouterA-Dialer1] dialer user u1
    [RouterA-Dialer1] dialer-group 10
    [RouterA-Dialer1] dialer bundle 10
    [RouterA-Dialer1] ip address 3.1.1.1 255.255.255.0    
    [RouterA-Dialer1] dialer number 666
    [RouterA-Dialer1] quit
    

    # Configure the ATM interface.

    [RouterA] interface atm 0/0/0
    [RouterA-Atm0/0/0] pvc pppoa 2/40
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] map ppp dialer 1
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] quit
    [RouterA-Atm0/0/0] quit
    # Configure a static route for the backup link.
    [RouterA] ip route-static 5.1.1.0 255.255.255.0 dialer1 preference 60
    

  3. Configure the DSLAM.

    See the DSLAM documentation.

  4. Configure the PPPoA server.

    Assign IP address 3.1.1.2 to the PPPoA server.

  5. Configure BFD sessions between RouterA and RouterB.

    # On RouterA, configure a BFD session bound to the destination address 4.1.1.2/24.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd test bind peer-ip 4.1.1.2
    [RouterA-bfd-session-test] discriminator local 10
    [RouterA-bfd-session-test] discriminator remote 100
    [RouterA-bfd-session-test] commit
    [RouterA-bfd-session-test] quit

    # On RouterB, configure a BFD session bound to the destination address 2.1.1.1/24.

    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] bfd test bind peer-ip 2.1.1.1
    [RouterB-bfd-session-test] discriminator local 100
    [RouterB-bfd-session-test] discriminator remote 10
    [RouterB-bfd-session-test] commit
    [RouterB-bfd-session-test] quit

  6. Configure association between interface backup and BFD on backup interface ATM0/0/0.

    [RouterA] interface atm 0/0/0
    [RouterA-Atm0/0/0] standby track bfd-session session-name test

  7. Verify the configuration.

    Run the display bfd session all verbose command on RouterA. The command output shows that the BFD session status is Up.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Up        Name : test
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 100
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 4.1.1.2
      Bind Interface         : -
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

    # Run the display standby state command on RouterA to view the BFD session status and backup interface status. The command output shows that the BFD session status is UP and the status of ATM0/0/0 is STANDBY.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  UP         Atm0/0/0                   STANDBY             
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             
                                                                                    
                                                                                    
                                                                                    

    Run the shutdown command on GE1/0/0 of RouterB to simulate a link fault. Run the display bfd session all verbose command on RouterA. The command output shows that the BFD session status is Down.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Down        Name : test
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 100
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 4.1.1.2
      Bind Interface         : -
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 0/1

    Run the display standby state command on RouterA. The command output shows that the BFD session status is ERR, and the status of backup interface ATM0/0/0 is Up, indicating that the backup interface has started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  ERR        Atm0/0/0                    UP             
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             
                                                                                    
                                                                                    
                                                                                    

    Run the undo shutdown command on GE1/0/0 of RouterB to make GigabitEthernet0/0/1 UP. Run the display standby state command on RouterA. The command output shows that the BFD session status is UP and backup interface ATM0/0/0 has switched to the standby state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  UP         Atm0/0/0                   STANDBY             
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             
                                                                                    
                                                                                    
                                                                                    

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #                                                                               
    interface Dialer1                                                               
     link-protocol ppp                                                              
     ip address 3.1.1.1 255.255.255.0                                              
     dialer user u1                                                                 
     dialer bundle 10                                                               
     dialer number 666                                                              
     dialer-group 10                                                                
    #             
    interface GE1/0/0
      ip address 2.1.1.1 255.255.255.0
    #
    interface Atm0/0/0                                                              
     pvc pppoa 2/40                                                                 
      map ppp Dialer1                                                               
     standby track bfd-session session-name test
    #                                                                               
    dialer-rule                                                                     
     dialer-rule 10 ip permit                                                       
    #
     ip route-static 4.1.1.0 255.255.255.0 2.1.1.2 preference 80
     ip route-static 5.1.1.0 255.255.255.0 Dialer1
    #
     bfd
    #
    bfd test bind peer-ip 4.1.1.2
     discriminator local 10
     discriminator remote 100
     commit
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GE1/0/0
      ip address 4.1.1.2 255.255.255.0
    #
     ip route-static 2.1.1.0 255.255.255.0 4.1.1.1 preference 80
     ip route-static 3.1.1.0 255.255.255.0 Dialer1
    #
     bfd
    #
    bfd test bind peer-ip 2.1.1.1
     discriminator local 100
     discriminator remote 10
     commit
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
      ip address 2.1.1.2 255.255.255.0
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
      ip address 4.1.1.1 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-08-12

Document ID: EDOC1100034076

Views: 57800

Downloads: 107

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next