No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R010

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between BFD and Ethernet Interface Backup in Active/Standby Mode

Example for Configuring Association Between BFD and Ethernet Interface Backup in Active/Standby Mode

Networking Requirements

As shown in Figure 2-18, the link RouterA->RouterB->RouterD is the primary link and the link RouterA->RouterC->RouterD is the backup link.

Devices are required to monitor the primary link status within 50 ms. When the primary link is faulty, the backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-18  Networking of association between interface backup and BFD

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a static route to ensure connectivity at the network layer.

  2. Configure a BFD session on RouterA and RouterD to monitor the primary link status.

  3. Configure association between interface backup and BFD on backup interface GE2/0/0 of RouterA. When the BFD session detects a fault on the primary link, traffic can be rapidly switched to the backup interface.

  4. Configure association between interface backup and BFD on GE2/0/0 of the RouterD. When the BFD session detects the primary link fault, traffic can be rapidly switched to the backup link. This ensures that traffic sent from RouterA to RouterD and traffic sent from RouterD to RouterA use the same route.

Procedure

  1. Configure connectivity at the network layer.

    # Assign an IP address to each interface. Use RouterA as an example.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit

    # On RouterA, configure static routes to 10.1.4.0/24 and 10.1.5.0/24 of RouterD.

    [RouterA] ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 80
    [RouterA] ip route-static 10.1.5.0 255.255.255.0 10.1.3.2 preference 60

    # On RouterD, configure static routes to RouterA's interfaces on 10.1.2.0/24 and 10.1.3.0/24.

    [RouterD] ip route-static 10.1.2.0 255.255.255.0 10.1.4.1 preference 80
    [RouterD] ip route-static 10.1.3.0 255.255.255.0 10.1.5.1 preference 60

  2. Create a BFD session between RouterA and RouterD.

    # On RouterA, create a BFD session between RouterA and RouterD.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd test bind peer-ip 10.1.4.2
    [RouterA-bfd-session-test] discriminator local 10
    [RouterA-bfd-session-test] discriminator remote 100
    [RouterA-bfd-session-test] commit
    [RouterA-bfd-session-test] quit

    # On RouterD, create a BFD session between RouterD and RouterA.

    [RouterD] bfd
    [RouterD-bfd] quit
    [RouterD] bfd test bind peer-ip 10.1.2.1
    [RouterD-bfd-session-test] discriminator local 100
    [RouterD-bfd-session-test] discriminator remote 10
    [RouterD-bfd-session-test] commit
    [RouterD-bfd-session-test] quit

  3. Configure association between interface backup and BFD on backup interface GE2/0/0 of RouterA.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] standby track bfd-session session-name test

  4. Configure association between interface backup and BFD on GE2/0/0 of RouterD.

    [RouterD] interface gigabitethernet 2/0/0
    [RouterD-GigabitEthernet2/0/0] standby track bfd-session session-name test

  5. Verify the configuration.

    Run the display bfd session all verbose command on RouterA. The command output shows that the BFD session status is Up.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Up        Name : test
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 100
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 10.1.4.2
      Bind Interface         : -
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

    # View the BFD session status and backup interface status on RouterA. The command output shows that the BFD session status is UP and the status of GigabitEthernet2/0/0 is STANDBY.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  UP    GigabitEthernet2/0/0         STANDBY            
                                                                                      
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
    
    

    Run the shutdown command on GigabitEthernet2/0/0 of RouterB to simulate a link fault. Run the display bfd session all verbose command on RouterA. The command output shows that the BFD session status is Down.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Down        Name : test
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 100
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 10.1.4.2
      Bind Interface         : -
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 0/1

    Run the display standby state command on RouterA. The command output shows that the BFD session status is ERR, and the status of backup interface GigabitEthernet2/0/0 is UP, indicating that the backup interface is started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  ERR   GigabitEthernet2/0/0            UP             
                                                                                       
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
    

    Run the undo shutdown command on GigabitEthernet2/0/0 of RouterB. After GE2/0/0 goes to Up, and run the display standby state command on RouterA. The command output shows that the BFD session status is UP and backup interface GigabitEthernet2/0/0 switches to the standby state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    --------------------------------------------------------------------------------
    Below is track BFD Information:                                                       
    Bfd-Name              Bfd-State  BackupInterface            State               
    test                  UP    GigabitEthernet2/0/0         STANDBY           
                                                                                     
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                       
    Instance Name                    BackupInterface              State             
                                                                                    

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.3.1 255.255.255.0
     standby track bfd-session session-name test
    #
     ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 80
     ip route-static 10.1.5.0 255.255.255.0 10.1.3.2
    #
     bfd
    #
    bfd test bind peer-ip 10.1.4.2
     discriminator local 10
     discriminator remote 100
     commit
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.4.1 255.255.255.0
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.3.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.1 255.255.255.0
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.4.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.5.2 255.255.255.0
     standby track bfd-session session-name test
    #
     ip route-static 10.1.2.0 255.255.255.0 10.1.4.1 preference 80
     ip route-static 10.1.3.0 255.255.255.0 10.1.5.1
    #
     bfd
    #
    bfd test bind peer-ip 10.1.2.1
     discriminator local 100
     discriminator remote 10
     commit
    #
    return
Translation
Download
Updated: 2019-08-12

Document ID: EDOC1100034076

Views: 57761

Downloads: 107

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next