No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Service

AR500, AR510, AR531, AR550, AR1500, and AR2500 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a DHCP Server in a Super-VLAN

Example for Configuring a DHCP Server in a Super-VLAN

Networking Requirements

As shown in Figure 3-14, an enterprise has two departments that are allocated the same network segment to save IP address resources. Users in departments A and B belong to different VLANs. For unified manaEthment, the enterprise administrator requires that a DHCP server be deployed to dynamically allocate IP addresses to terminals in the departments. Layer 3 communication is required between users in different departments to meet service requirements.

Figure 3-14  Networking diagram for configuring a DHCP server in a super-VLAN

Configuration Roadmap

  1. Configure sub-VLANs on the Router to implement Layer 2 isolation between users in different sub-VLANs. The sub-VLANs are on the same network segment, which reduces the amount of required IP address resources.

  2. Configure proxy ARP on the VLANIF interface of the super-VLAN to implement Layer 3 communication among sub-VLANs.

  3. Configure a DHCP server in the super-VLAN to dynamically allocate IP addresses to terminals in departments A and B.

Procedure

  1. Create VLAN 2, and add Eth0/0/1 and Eth0/0/2 to VLAN 2. Create VLAN 3, and add Eth0/0/3 and Eth0/0/4 to VLAN 3.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 2 to 4
    [Router] interface ethernet 0/0/1
    [Router-Ethernet0/0/1] port link-type access
    [Router-Ethernet0/0/1] port default vlan 2
    [Router-Ethernet0/0/1] quit
    [Router] interface ethernet 0/0/2
    [Router-Ethernet0/0/2] port link-type access
    [Router-Ethernet0/0/2] port default vlan 2
    [Router-Ethernet0/0/2] quit
    [Router] interface ethernet 0/0/3
    [Router-Ethernet0/0/3] port link-type access
    [Router-Ethernet0/0/3] port default vlan 3
    [Router-Ethernet0/0/3] quit
    [Router] interface ethernet 0/0/4
    [Router-Ethernet0/0/4] port link-type access
    [Router-Ethernet0/0/4] port default vlan 3
    [Router-Ethernet0/0/4] quit

  2. Configure a super-VLAN to implement VLAN aggregation.

    # Configure the super-VLAN.

    [Router] vlan 4
    [Router-vlan4] aggregate-vlan
    [Router-vlan4] access-vlan 2 to 3
    [Router-vlan4] quit
    

    # Configure the VLANIF interface.

    [Router] interface vlanif 4
    [Router-Vlanif4] ip address 10.1.1.12 255.255.255.0
    

  3. Configure proxy ARP.

    [Router-Vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [Router-Vlanif4] quit
    

  4. Configure a DHCP server based on the interface address pool on VLANIF 4 to dynamically allocate IP addresses to terminals in sub-VLANs.

    [Router] dhcp enable 
    [Router] interface vlanif 4 
    [Router-Vlanif4] dhcp select interface
    [Router-Vlanif4] quit
    

  5. Verify the configuration.

    # After the configuration is complete, run the display ip pool interface vlanif4 command on the Router to view IP address allocation in the address pool. The Used field displays the number of used IP addresses in an address pool.

    [Router] display ip pool interface vlanif4
      Pool-name        : Vlanif4
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : huawei.com
      DNS-server0      : 10.1.1.2
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface       Status           : Unlocked
      Gateway-0        : 10.1.1.12
      Network          : 10.1.2.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable                                                    
      Conflicted address recycle interval: --                 
      Address Statistic: Total       :253       Used        :4                      
                         Idle        :249       Expired     :0                      
                         Conflict    :0         Disable     :0                      
                                                                                    
     -------------------------------------------------------------------------------
      Network section                                                               
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.2.1      10.1.2.254     253       4        249(0)       0     0    
     -------------------------------------------------------------------------------

Configuration Files

Router configuration file

#
 sysname Router
#
vlan batch 2 to 4
#                                                                                                                                   
dhcp enable  
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.1.1.12 255.255.255.0
 arp-proxy inter-sub-vlan-proxy enable
 dhcp select interface 
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 3
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 3
#
return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034231

Views: 82369

Downloads: 54

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next