No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Service

AR500, AR510, AR531, AR550, AR1500, and AR2500 V200R010

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-VLAN Proxy ARP

Example for Configuring Inter-VLAN Proxy ARP

Networking Requirements

In Figure 2-15, VLAN2 and VLAN3 belong to super-VLAN4. Hosts in VLAN2 and VLAN3 cannot ping each other. To implement communication between hosts in VLAN2 and VLAN3, configure inter-VLAN proxy ARP.

Figure 2-15  Networking diagram for configuring inter-VLAN proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a super-VLAN and sub-VLANs.
  2. Add interfaces to the sub-VLANs.
  3. Create a VLANIF interface corresponding to the super-VLAN and configure an IP address for the VLANIF interface.
  4. Enable inter-VLAN proxy ARP.

Procedure

  1. Configure a super-VLAN and sub-VLANs.

    # Configure sub-VLAN2.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan 2
    [Router-vlan2] quit
    # Add Ethernet2/0/0 and Ethernet2/0/1 to sub-VLAN2.
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 2
    [Router-Ethernet2/0/0] quit
    [Router] interface ethernet 2/0/1
    [Router-Ethernet2/0/1] port link-type access
    [Router-Ethernet2/0/1] port default vlan 2
    [Router-Ethernet2/0/1] quit
    # Configure sub-VLAN3.
    [Router] vlan 3
    [Router-vlan3] quit
    # Add Ethernet2/0/2 and Ethernet2/0/3 to sub-VLAN3.
    [Router] interface ethernet 2/0/2
    [Router-Ethernet2/0/2] port link-type access
    [Router-Ethernet2/0/2] port default vlan 3
    [Router-Ethernet2/0/2] quit
    [Router] interface ethernet 2/0/3
    [Router-Ethernet2/0/3] port link-type access
    [Router-Ethernet2/0/3] port default vlan 3
    [Router-Ethernet2/0/3] quit
    # Create super-VLAN 4 and add sub-VLAN2 and sub-VLAN3 to super-VLAN4.
    [Router] vlan 4
    [Router-vlan4] aggregate-vlan
    [Router-vlan4] access-vlan 2
    [Router-vlan4] access-vlan 3
    [Router-vlan4] quit
    

  2. Create and configure VLANIF4.

    # Create VLANIF4.

    [Router] interface vlanif 4
    

    # Configure an IP address for VLANIF4.

    [Router-Vlanif4] ip address 10.10.10.1 24
    

  3. Enable inter-VLAN proxy ARP on VLANIF4.

    [Router-Vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [Router-Vlanif4] quit

  4. Verify the configuration.

    # Run the display current-configuration command to check configurations of the super-VLAN, sub-VLANs, and VLANIF interface. The output of the command is displayed in the following configuration file.

    # Run the display arp command to view all the ARP entries.

    <Router> display arp
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE
                                              VLAN/CEVLAN
    ------------------------------------------------------------------------------
    10.10.10.1      0018-2000-0083            I -         Vlanif4
    10.10.10.2      00e0-fc00-0002  19        D-0         Ethernet2/0/0
                                              2/-
    10.10.10.3      00e0-fc00-0003  19        D-0         Ethernet2/0/1
                                              2/-
    10.10.10.4      00e0-fc00-0004  19        D-0         Ethernet2/0/2
                                              3/-
    10.10.10.5      00e0-fc00-0005  19        D-0         Ethernet2/0/3
                                              3/-
    ------------------------------------------------------------------------------
    Total:5         Dynamic:4       Static:0    Interface:1
    

Configuration Files

Only the configuration file of the router is provided.

#
 sysname Router
#
vlan batch 2 to 4 
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
 #
interface Vlanif4
 ip address 10.10.10.1 255.255.255.0
 arp-proxy inter-sub-vlan-proxy enable
#
interface Ethernet2/0/0
 port link-type access
 port default vlan 2
#
interface Ethernet2/0/1
 port link-type access
 port default vlan 2
#
interface Ethernet2/0/2
 port link-type access
 port default vlan 3
#
interface Ethernet2/0/3
 port link-type access
 port default vlan 3
#
return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034231

Views: 80351

Downloads: 51

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next