No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Security

AR500, AR510, AR531, AR550, AR1500, and AR2500 V200R010

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Using Advanced ACL6s to Filter Certain Types of IPv6 Packets

Example for Using Advanced ACL6s to Filter Certain Types of IPv6 Packets

Networking Requirements

As shown in Figure 4-22, users are connected to the Router through Eth0/0/1. The Router needs to block the certain types of IPv6 packets from users in which the source IPv6 address is host address 2001:db8::2/32 and destination IPv6 address is 2001:db8::1/32.

Figure 4-22  Using advanced ACL6s to filter certain types of IPv6 packets

Configuration Roadmap

The following configurations are performed on the Router. The configuration roadmap is as follows:

  1. Configure an advanced ACL6 and ACL6-based traffic classifier to filter the IPv6 packets in which the source IPv6 address is host address 2001:db8::2/32 and destination IPv6 address is 2001:db8::2/32.
  2. Configure a traffic behavior to discard the packets matching the ACL6.
  3. Configure and apply a traffic policy to make the ACL6 and traffic behavior take effect.

Procedure

  1. Enable the IPv6 forwarding capability, add an interface to a VLAN, and assign an IPv6 address to the VLANIF interface.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] ipv6
    [Router] vlan batch 10
    [Router] interface ethernet 0/0/1
    [Router-Ethernet0/0/1] port link-type trunk
    [Router-Ethernet0/0/1] port trunk allow-pass vlan 10
    [Router-Ethernet0/0/1] quit
    [Router] interface vlanif 10
    [Router-Vlanif10] ipv6 enable
    [Router-Vlanif10] ipv6 address 2001:db8::1 32
    [Router-Vlanif10] quit

  2. Configure an advanced ACL6 and ACL6-based traffic classifier. Configure a traffic behavior and traffic policy, and apply the traffic policy to the inbound direction of Eth0/0/1 to reject the IPv6 packets with source IPv6 address 2001:db8::2/32 and destination IPv6 address 2001:db8::1/32.

    [Router] acl ipv6 number 3001
    [Router-acl6-adv-3001] rule deny ipv6 source 2001:db8::2/32 destination 2001:db8::1/32
    [Router-acl6-adv-3001] quit
    [Router] traffic classifier class1
    [Router-classifier-class1] if-match ipv6 acl 3001
    [Router-classifier-class1] quit
    [Router] traffic behavior behav1
    [Router-behavior-behav1] deny
    [Router-behavior-behav1] quit
    [Router] traffic policy policy1
    [Router-trafficpolicy-policy1] classifier class1 behavior behav1
    [Router-trafficpolicy-policy1] quit
    [Router] interface ethernet 0/0/1
    [Router-Ethernet0/0/1] traffic-policy policy1 inbound
    [Router-Ethernet0/0/1] quit

  3. Verify the configuration.

    # Check the ACL6 configuration.

    [Router] display acl ipv6 3001
                                                                                    
    Advanced IPv6 ACL 3001, 1 rule                                                  
    Acl's step is 5                                                                 
     rule 5 deny ipv6 source 2001:db8::2/32 destination 2001:db8::1/32                     

    # Check the configuration of the traffic classifier.

    [Router] display traffic classifier user-defined
      User Defined Classifier Information:                                          
       Classifier: class1                                                           
        Operator: OR                                                                
        Rule(s) :                                                                   
         if-match ipv6 acl 3001  

    # Check the configuration of the traffic policy.

    [Router] display traffic policy user-defined
      User Defined Traffic Policy Information:                                      
      Policy: policy1                                                               
       Classifier: class1                                                           
        Operator: OR                                                                
         Behavior: behav1                                                           
          Deny                                                                      
     

Configuration Files

Router configuration file

#
 sysname Router
#
acl ipv6 number 3001                                                            
 rule 5 deny ipv6 source 2001:db8::2/32 destination 2001:db8::1/32 
#                                                                               
ipv6                                                                            
#                                                                               
vlan batch 10                                                                   
#           
traffic classifier class1 operator or                                           
 if-match ipv6 acl 3001                                                         
#                                                                               
traffic behavior behav1                                                         
 deny                                                                           
#                                                                               
traffic policy policy1                                                          
 classifier class1 behavior behav1
#                                                                               
interface Vlanif10                                                              
 ipv6 enable                                                                    
 ipv6 address 2001:db8::1/32  
#                                                                               
interface Ethernet0/0/1                                                         
 port link-type trunk                                                           
 port trunk allow-pass vlan 10                                                  
 traffic-policy policy1 inbound  
#
return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034236

Views: 95215

Downloads: 53

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next