No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Security

AR500, AR510, AR531, AR550, AR1500, and AR2500 V200R010

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Applying the Keychain to RIP

Example for Applying the Keychain to RIP

Networking Requirements

As shown in Figure 18-8, RouterA and RouterB are connected using RIP-2.

The RIP connection needs to be retained during data transmission.

Figure 18-8  Networking diagram of applying the keychain to RIP

Configuration Roadmap

To ensure stable RIP connections, RIP protocol packets must be correctly transmitted. You are advised to authenticate and encrypt the packets to ensure transmission security. In addition, to prevent unauthorized users from forging algorithms and key strings used in authentication and encryption, you are advised to dynamically change algorithms and key strings to ensure secure RIP packet transmission. Therefore, the keychain protocol is used to ensure stability of RIP connections.

The configuration roadmap is as follows:

  1. Configure basic RIP functions.

  2. Configure a keychain.

  3. Apply the keychain to RIP.

Procedure

  1. Configure basic RIP functions.

    # Configure Router A.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] rip 1
    [RouterA-rip-1] version 2
    [RouterA-rip-1] network 192.168.1.0
    [RouterA-rip-1] quit

    # Configure Router B.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] rip 1
    [RouterB-rip-1] version 2
    [RouterB-rip-1] network 192.168.1.0
    [RouterB-rip-1] quit

  2. Configure a keychain.

    # Configure Router A.

    [RouterA] keychain huawei mode absolute
    [RouterA-keychain-huawei] receive-tolerance 100
    [RouterA-keychain-huawei] key-id 1
    [RouterA-keychain-huawei-keyid-1] algorithm sha-256
    [RouterA-keychain-huawei-keyid-1] key-string cipher Huawei@1234
    [RouterA-keychain-huawei-keyid-1] send-time 0:00 2012-3-12 to 23:59 2012-3-12
    [RouterA-keychain-huawei-keyid-1] receive-time 0:00 2012-3-12 to 23:59 2012-3-12
    [RouterA-keychain-huawei-keyid-1] default send-key-id
    [RouterA-keychain-huawei-keyid-1] quit
    [RouterA-keychain-huawei] quit
    

    # Configure Router B.

    [RouterB] keychain huawei mode absolute
    [RouterB-keychain-huawei] receive-tolerance 100
    [RouterB-keychain-huawei] key-id 1
    [RouterB-keychain-huawei-keyid-1] algorithm sha-256
    [RouterB-keychain-huawei-keyid-1] key-string cipher Huawei@1234
    [RouterA-keychain-huawei-keyid-1] send-time 0:00 2012-3-12 to 23:59 2012-3-12
    [RouterA-keychain-huawei-keyid-1] receive-time 0:00 2012-3-12 to 23:59 2012-3-12
    [RouterB-keychain-huawei-keyid-1] default send-key-id
    [RouterB-keychain-huawei-keyid-1] quit
    [RouterB-keychain-huawei] quit
    

  3. Apply the keychain to RIP.

    # Configure Router A.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] undo portswitch
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet1/0/0] rip authentication-mode keychain huawei
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] quit
    

    # Configure Router B.

    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] undo portswitch
    [RouterB-GigabitEthernet1/0/0] ip address 192.168.1.2 24
    [RouterB-GigabitEthernet1/0/0] rip authentication-mode keychain huawei
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] quit

  4. Verify the configuration.

    # Run the display keychain keychain-name command to check the key-id status of the keychain.

    <RouterA> display keychain huawei
     Keychain Information:
     ----------------------
     Keychain Name             : huawei
       Timer Mode              : Absolute
       Receive Tolerance(min)  : 100
       TCP Kind                : 254
       TCP Algorithm IDs       :
         HMAC-MD5              : 5
         HMAC-SHA1-12          : 2
         HMAC-SHA1-20          : 6
         HMAC-SHA-256          : 7
         SHA-256               : 8
         MD5                   : 3
         SHA1                  : 4
     Number of Key IDs         : 1
     Active Send Key ID        : 1
     Active Receive Key IDs    : 01
     Default send Key ID       : Not configured
    
     Key ID Information:
     ----------------------
     Key ID                    : 1
       Key string              : ******
       Algorithm               : SHA-256
       SEND TIMER              :
         Start time            : 2012-03-12 00:00
         End time              : 2012-03-12 23:59
         Status                : Active
       RECEIVE TIMER           :
         Start time            : 2012-03-12 00:00
         End time              : 2012-03-12 23:59
         Status                : Active
                                       

    # After the keychain is applied to RIP, run the display rip process-id interface verbose command to check the authentication mode of RIP packets. The display on Router A is used as an example.

    <RouterA> display rip 1 interface verbose
     GigabitEthernet1/0/0(192.168.1.1)
      State           : UP          MTU    : 500
      Metricin        : 0
      Metricout       : 1
      Input           : Enabled     Output : Enabled
      Protocol        : RIPv2 Multicast
      Send version    : RIPv2 Multicast Packets
      Receive version : RIPv2 Multicast and Broadcast Packets
      Poison-reverse                : Disabled
      Split-Horizon                 : Enabled
      Authentication type           : MD5 (Non-standard - Keychain: huawei)
         Last Sequence Number Sent  : 0x0
      Replay Protection             : Disabled 
    

Configuration Files

  • Router A configuration file

    #
     sysname RouterA
    #
    keychain huawei mode absolute
     receive-tolerance 100
     key-id 1
      algorithm sha-256
      key-string cipher %#%#e7,_2i0MfN6W5@Fb6Q3WU.\e)ju5"Jr&&())JmZ2%#%# 
      send-time 00:00 2012-03-12 to 23:59 2012-03-12
      receive-time 00:00 2012-03-12 to 23:59 2012-03-12
      default send-key-id 
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
     rip authentication-mode keychain huawei
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    keychain huawei mode absolute
     receive-tolerance 100
     key-id 1
      algorithm sha-256
      key-string cipher %#%#e7,_2i0MfN6W5@Fb6Q3WU.\e)ju5"Jr&&())JmZ2%#%#
      send-time 00:00 2012-03-12 to 23:59 2012-03-12
      receive-time 00:00 2012-03-12 to 23:59 2012-03-12
      default send-key-id
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
     rip authentication-mode keychain huawei
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
Translation
Download
Updated: 2019-05-20

Document ID: EDOC1100034236

Views: 95658

Downloads: 58

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next