No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IGMP Snooping Proxy

Example for Configuring IGMP Snooping Proxy

Networking Requirements

As shown in Figure 1-10, the router runs IGMPv3 and connects to user hosts through a Layer 2 switch. There are multiple receiver hosts on the network. The administrator wants to mitigate the IGMP message processing load of the router.

Figure 1-10  Network diagram for IGMP snooping proxy configuration

Configuration Roadmap

To meet the preceding requirements, configure IGMP snooping proxy on the switch. The configuration roadmap is as follows:

  1. Create a VLAN and add interfaces to the VLAN.

  2. Enable IGMP snooping globally and in the VLAN.

  3. Configure IGMP snooping proxy on the switch to reduce packet exchange between the switch and router.

  4. Disable the switch from sending IGMP Query messages to the upstream router to prevent election of the IGMP querier.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [Switch] igmp-snooping enable

    # Enable IGMP snooping in VLAN 10.

    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    

    # Configure IGMPv3 snooping to enable the Switch to process IGMP messages of all versions.

    [Switch-vlan10] igmp-snooping version 3
    

  3. Enable IGMP snooping proxy.

    [Switch-vlan10] igmp-snooping proxy
    [Switch-vlan10] quit

  4. Disable the switch from sending IGMP Query messages to the upstream router.

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] igmp-snooping proxy-uplink-port vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  5. Verify the configuration.

    # Check IGMP message statistics on the switch.

    [Switch] display igmp-snooping statistics vlan 10
     IGMP Snooping Packets Counter
       Statistics for VLAN 10
         Recv V1 Report   0
         Recv V2 Report   121
         Recv V3 Report   0
         Recv V1 Query    0
         Recv V2 Query    0
         Recv V3 Query    20
         Recv Leave       82
         Recv Pim Hello   0
         Send Query(S=0)  0
         Send Query(S!=0) 0
         Suppress Report         0
         Suppress Leave          0
         Proxy Send General Query          135
         Proxy Send Group-Specific Query        95
         Proxy Send Group-Source-Specific Query 0

    The command output shows that the IGMP snooping proxy has taken effect, and the switch functions as a proxy to send IGMP General Query messages.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
     igmp-snooping version 3
     igmp-snooping proxy
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     igmp-snooping proxy-uplink-port vlan 10 
    #
    return
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 13203

Downloads: 5

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next