No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MLD Snooping Proxy

Example for Configuring MLD Snooping Proxy

Networking Requirements

In Figure 2-9, the router is connected to the user network through the Layer 2 switch on an IPv6 network. MLDv1 runs on the router. There are many receiver hosts in the network. The administrator requires that the router should not be overloaded by too many MLD packets.

Figure 2-9  Network diagram for MLD snooping proxy configuration

Configuration Roadmap

Enabling MLD snooping proxy on the switch meets the requirement.

  1. Create a VLAN and add interfaces to the VLAN.

  2. Enable MLD snooping globally and in the VLAN so that users can receive multicast data.

  3. Configure MLD snooping proxy to reduce packet exchange between the switch and the router.

Procedure

  1. Create a VLAN and add the interface to the VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. Enable MLD snooping.

    # Enable MLD snooping globally.

    [Switch] mld-snooping enable

    # Enable MLD snooping in VLAN 10.

    [Switch] vlan 10
    [Switch-vlan10] mld-snooping enable
    

    # Set the MLD snooping version to v2 to enable the switch to process MLD protocol packets of all versions.

    [Switch-vlan10] mld-snooping version 2
    

  3. Enable MLD snooping proxy.

    [Switch-vlan10] mld-snooping proxy
    [Switch-vlan10] quit

  4. Verify the configuration.

    # Check MLD packet statistics on the switch.

    [Switch] display mld-snooping statistics vlan 10
     MLD Snooping Packets Counter                                                   
       Statistics for VLAN 10                                                        
         Recv V1 Report  376                                                        
         Recv V2 Report  0                                                          
         Recv V1 Query   0                                                          
         Recv V2 Query   0                                                          
         Recv Done       2                                                          
         Recv Pim Hello  0                                                          
         Send Query(S=0) 1                                                          
         Send Query(S!=0)0                                                          
         Send General Query          398                                       
         Send Group-Specific Query        0                                         
         Send Group-Source-Specific Query 0                                         

    The command output shows that the switch functions as the proxy and sends General Query messages. The MLD snooping proxy function has taken effect.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     mld-snooping enable
     mld-snooping version 2
     mld-snooping proxy
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 9616

Downloads: 4

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next