No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Fast Leave for Interfaces

Example for Configuring Fast Leave for Interfaces

Networking Requirements

In Figure 2-10, the router is connected to the user network through the Layer 2 switch on an IPv6 network. GE0/0/1 and GE0/0/2 on the switch connect to only one receiver host. Therefore, when receiving MLD Done messages from the two interfaces, the switch can delete the forwarding entries of the multicast group that the hosts have left, without waiting the aging timer to time out. This saves the bandwidth and system resources.

Figure 2-10  Network diagram for fast leave configuration

Configuration Roadmap

Enabling MLD snooping and configuring prompt leave for interfaces on the switch can meet the requirements.
  • Create a VLAN and add interfaces to the VLAN.
  • Enable MLD snooping globally and in the VLAN.
  • Enable prompt leave for interfaces in the VLAN.

Procedure

  1. Create VLAN 10 and add interfaces to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. Enable MLD snooping globally and in VLAN 10.

    # Enable MLD snooping globally.

    [Switch] mld-snooping enable

    # Enable MLD snooping in VLAN 10.

    [Switch] vlan 10
    [Switch-vlan10] mld-snooping enable
    

  3. Configure fast leave for interfaces in VLAN 10.

    [Switch-vlan10] mld-snooping prompt-leave
    [Switch-vlan10] quit

  4. Verify the configuration.

    # Run the display mld-snooping command on the Switch to check VLAN 10 configuration.

    [Switch] display mld-snooping vlan 10
    MLD Snooping Vlan Information for VLAN 10
       MLD Snooping is Enabled
       MLD Version is Set to default 1
       MLD Query Interval is Set to default 125s
       MLD Max Response Interval is Set to default 10s
       MLD Robustness is Set to default 2
       MLD Last Member Query Interval is Set to default 1s
       MLD Router Port Aging Interval is Set to 180s or holdtime in hello
       MLD Filter Group-Policy is not set
       MLD Prompt Leave Enable
       MLD Router Alert is Not Required
       MLD Send Router Alert Enable
       MLD Snooping proxy is disabled
       MLD Snooping report-suppress is disabled
       MLD Snooping Querier is disabled
    

    MLD Prompt Leave Enable in the command output indicates that the fast leave configuration in VLAN 10 is successful.

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10
#
mld-snooping enable
#
vlan 10
 mld-snooping enable
 mld-snooping prompt-leave
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/3
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
return
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 13332

Downloads: 5

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next