No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Static Multicast MAC Addresses

Example for Configuring Static Multicast MAC Addresses

Networking Requirements

As shown in Figure 3-4, the router connects to a user network through the switch. There are three receivers on the network: HostA, HostB, and HostC. HostA and HostC are allowed to receive packets with destination address 0x0100-5A0A-0A0A, but HostB is not.

Figure 3-4  Network diagram for static multicast MAC address configuration

Configuration Roadmap

To meet the preceding requirement, configure static multicast MAC addresses on the Layer 2 switch. The configuration roadmap is as follows:

  1. Create a VLAN and add interfaces to the VLAN.
  2. Configure the static multicast MAC address 0x0100-5A0A-0A0A on GE0/0/1 and GE0/0/2.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type hybrid
    [Switch-GigabitEthernet0/0/4] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/4] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/4] quit
    

  2. Configure the static multicast MAC address on the interfaces connected to HostA and HostC.

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] mac-address multicast 0100-5a0a-0a0a vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] mac-address multicast 0100-5a0a-0a0a vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    

  3. Verify the configuration.

    # Display configured MAC address entries.

    [Switch] display mac-address multicast 
    --------------------------------------------------------------------------------
     MAC Address         VLANID         Out-Interface              Status
    --------------------------------------------------------------------------------
     0100-5a0a-0a0a      10             GigabitEthernet0/0/1       Active
                                        GigabitEthernet0/0/2       Active
                                                 2 port(s)                
    --------------------------------------------------------------------------------
     Total Group(s) : 1
    

    The command output shows that static multicast MAC address entries are configured on GE0/0/1 and GE0/0/2.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     mac-address multicast 0100-5a0a-0a0a vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     mac-address multicast 0100-5a0a-0a0a vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/4
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 13299

Downloads: 5

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next