No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring 1-to-N Multicast Replication Based on User VLANs

Example for Configuring 1-to-N Multicast Replication Based on User VLANs

Networking Requirements

In Figure 4-4, service VLAN 10 is used to transmit multicast data between RouterA and SwitchA. HostA, HostB, and HostC belong to VLAN 100, VLAN 200, and VLAN 300, respectively. All of them want to receive multicast data from Source.

You can configure 1-to-N multicast replication based on user VLANs, so that RouterA only needs to copy and send multicast data to VLAN 10 in response to the same multicast data request from different user hosts. This reduces bandwidth consumption between RouterA and SwitchA.

Figure 4-4  Configuring 1-to-N multicast replication based on user VLANs

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable Internet Group Management Protocol (IGMP) snooping in the system view.
  2. Create user VLANs and enable IGMP snooping in the user VLANs.
  3. Create a multicast VLAN and enable IGMP snooping in the multicast VLAN.
  4. Bind the user VLANs to the multicast VLAN.
  5. Add the network-side interface and user-side interfaces to the VLANs as hybrid interfaces.

Procedure

  1. Enable IGMP snooping in the system view.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] igmp-snooping enable
    

  2. Create user VLANs and enable IGMP snooping in the user VLANs.

    [SwitchA] vlan 100
    [SwitchA-vlan100] igmp-snooping enable
    [SwitchA-vlan100] quit
    [SwitchA] vlan 200
    [SwitchA-vlan200] igmp-snooping enable
    [SwitchA-vlan200] quit
    [SwitchA] vlan 300
    [SwitchA-vlan300] igmp-snooping enable
    [SwitchA-vlan300] quit
    

  3. Create a multicast VLAN and enable the IGMP snooping and IGMP snooping querier functions in the multicast VLAN.

    NOTE:
    It is recommended that you configure igmp-snooping querier enable in the multicast VLAN view. If RouterA is the gateway with IGMP enabled, you do not need to perform this configuration.
    [SwitchA] vlan 10
    [SwitchA-vlan10] igmp-snooping enable
    [SwitchA-vlan10] igmp-snooping querier enable
    [SwitchA-vlan10] multicast-vlan enable
    

  4. Bind user VLANs 100, 200, and 300 to multicast VLAN 10.

    [SwitchA-vlan10] multicast-vlan user-vlan 100 200 300
    [SwitchA-vlan10] quit

  5. Add interfaces to the VLANs as hybrid interfaces.

    # Add GE0/0/1 to multicast VLAN 10.

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/1] quit

    # Add GE0/0/2, GE0/0/3, and GE0/0/4 to user VLANs 100, 200, and 300 respectively.

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 200
    [SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet0/0/3] quit
    [SwitchA] interface gigabitethernet 0/0/4
    [SwitchA-GigabitEthernet0/0/4] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/4] port hybrid pvid vlan 300
    [SwitchA-GigabitEthernet0/0/4] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet0/0/4] quit

  6. Verify the configuration. View information about the multicast VLAN and user VLANs on SwitchA.

    [SwitchA] display multicast-vlan vlan
    Total multicast vlan   1                                                       
     multicast-vlan     user-vlan number     snooping-state                         
     ----------------------------------------------------------------               
     10                 3                    IGMP Enable/MLD Disable 
    [SwitchA] display user-vlan vlan                                       
     Total user vlan   3                                                            
     user-vlan  snooping-state            multicast-vlan  snooping-state            
     -----------------------------------------------------------------------------  
     100        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable
     200        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable
     300        IGMP Enable/MLD Disable  10               IGMP Enable/MLD Disable

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 100 200 300
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
     multicast-vlan enable
     igmp-snooping querier enable
     multicast-vlan user-vlan 100 200 300 
    vlan 100
     igmp-snooping enable
    vlan 200
     igmp-snooping enable
    vlan 300
     igmp-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet0/0/4
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    return
    
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 8526

Downloads: 4

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next