No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R012C00 Configuration Guide - IP Multicast

This document describes the configurations of IP multicast, including IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, controllable multicast, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface-based Multicast VLAN Replication

Example for Configuring Interface-based Multicast VLAN Replication

Networking Requirements

In Figure 4-6, GE0/0/1 on SwitchA is connected to the Router. GE0/0/2 provides services for ISP1, and GE0/0/3 provides services for ISP2. ISP1 and ISP2 use multicast VLAN 2 and VLAN 3 respectively to provide multicast services for users. GE0/0/2 and GE0/0/3 have the same user VLAN (VLAN 10).

To ensure that multicast packets of each ISP are sent only to users of the ISP, interface-based multicast VLAN replication is required. After the configuration is complete, multicast data of an ISP will be sent only to the interface connected to the ISP.

Figure 4-6  Configuring interface-based multicast VLAN replication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable Internet Group Management Protocol (IGMP) snooping in the system view.
  2. Create user VLAN 10.
  3. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.
  4. Bind user VLAN 10 to multicast VLANs on GE0/0/2 and GE0/0/3 respectively.
  5. Add the network-side interface and user-side interfaces to the VLANs as hybrid interfaces.

Procedure

  1. Create user VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10

  2. Create multicast VLANs 2 and 3, and enable the IGMP snooping and IGMP snooping querier functions in the multicast VLANs.

    NOTE:
    It is recommended that you configure igmp-snooping querier enable in the multicast VLAN view. If the Router is the gateway with IGMP enabled, you do not need to perform this configuration.
    [SwitchA] igmp-snooping enable
    [SwitchA] vlan 2
    [SwitchA-vlan2] igmp-snooping enable
    [SwitchA-vlan2] igmp-snooping querier enable
    [SwitchA-vlan2] quit
    [SwitchA] vlan 3
    [SwitchA-vlan3] igmp-snooping enable
    [SwitchA-vlan3] igmp-snooping querier enable
    [SwitchA-vlan3] quit

  3. Bind user VLAN 10 to multicast VLANs on GE0/0/2 and GE0/0/3 respectively.

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] l2-multicast-bind vlan 10 mvlan 2
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] l2-multicast-bind vlan 10 mvlan 3
    [SwitchA-GigabitEthernet0/0/3] quit

  4. Add GE0/0/1 to the multicast VLANs. Add GE0/0/2 and GE0/0/3 to the user VLAN.

    # Add GE0/0/1 to multicast VLANs 2 and 3 as a trunk interface.

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3 
    [SwitchA-GigabitEthernet0/0/1] quit

    # Add GE0/0/2 and GE0/0/3 respectively to user VLAN 10 as hybrid interfaces.

    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet0/0/3] quit

  5. Verify the configuration.

    Run the display l2-multicast-bind command on SwitchA to view binding between the user VLAN and multicast VLANs.

    [SwitchA] display l2-multicast-bind
     -------------------------------------------------------------------            
     Port                          Startvlan        Endvlan        Mvlan            
     -------------------------------------------------------------------            
     GigabitEthernet0/0/2                 10             --            2            
     GigabitEthernet0/0/3                 10             --            3            
     -------------------------------------------------------------------            
     Total Table(s) : 2

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 2 to 3 10
    #
    igmp-snooping enable
    #
    vlan 2
     igmp-snooping enable
     igmp-snooping querier enable
    vlan 3
     igmp-snooping enable
     igmp-snooping querier enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 2
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 3
    #
    return
    
Translation
Download
Updated: 2018-09-01

Document ID: EDOC1100037948

Views: 12253

Downloads: 5

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next