No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN ID-based 1:1 VLAN Mapping

Example for Configuring VLAN ID-based 1:1 VLAN Mapping

Networking Requirements

Users in different communities use the same services, such as the web, IPTV, and VoIP services. To facilitate management, the network administrator of each community adds different services to different VLANs. For communities in different VLANs to use the same services, communication between VLANs must be implemented.

In Figure 11-5, community 1 and community 2 have the same services, but belong to different VLANs. Communication between them needs to be implemented with low costs.

Figure 11-5  Networking diagram for configuring 1:1 VLAN mapping

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add the switch port connecting to community 1 to VLAN6 and add the switch port connecting to community 2 to VLAN5.

  2. Configure VLAN mapping on GE1/0/1 of PE1 and PE2 and map C-VLAN IDs to S-VLAN IDs so that users in different VLANs can communicate with each other.

Procedure

  1. Add downlink interfaces on switches to specified VLANs.

    # Configure CE1.

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] vlan 6
    [CE1-vlan6] quit
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type access
    [CE1-GigabitEthernet1/0/1] port default vlan 6
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] interface gigabitethernet 1/0/2
    [CE1-GigabitEthernet1/0/2] port link-type access
    [CE1-GigabitEthernet1/0/2] port default vlan 6
    [CE1-GigabitEthernet1/0/2] quit
    [CE1] interface gigabitethernet 1/0/3
    [CE1-GigabitEthernet1/0/3] port link-type trunk
    [CE1-GigabitEthernet1/0/3] port trunk allow-pass vlan 6
    [CE1-GigabitEthernet1/0/3] quit

    # Configure CE2.

    <HUAWEI> system-view
    [HUAWEI] sysname CE2
    [CE2] vlan 5
    [CE2-vlan5] quit
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type access
    [CE2-GigabitEthernet1/0/1] port default vlan 5
    [CE2-GigabitEthernet1/0/1] quit
    [CE2] interface gigabitethernet 1/0/2
    [CE2-GigabitEthernet1/0/2] port link-type access
    [CE2-GigabitEthernet1/0/2] port default vlan 5
    [CE2-GigabitEthernet1/0/2] quit
    [CE2] interface gigabitethernet 1/0/3
    [CE2-GigabitEthernet1/0/3] port link-type trunk
    [CE2-GigabitEthernet1/0/3] port trunk allow-pass vlan 5
    [CE2-GigabitEthernet1/0/3] quit

  2. Configure VLAN mapping on the GE1/0/1 of PE1 and PE2.

    # Configure PE1.

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan 10
    [PE1-vlan10] quit
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/1] port vlan-mapping vlan 6 map-vlan 10
    [PE1-GigabitEthernet1/0/1] quit

    # Configure PE2.

    <HUAWEI> system-view
    [HUAWEI] sysname PE2
    [PE2] vlan 10
    [PE2-vlan10] quit
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [PE2-GigabitEthernet1/0/1] port vlan-mapping vlan 5 map-vlan 10
    [PE2-GigabitEthernet1/0/1] quit

  3. Verify the configurations.

    Verify that users in community 1 and community 2 can communicate with each other.

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 6
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 6
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 6
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 6
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 5
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 5
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 5
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 5
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     port vlan-mapping vlan 6 map-vlan 10
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     port vlan-mapping vlan 5 map-vlan 10
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038103

Views: 116272

Downloads: 52

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next