No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Implementing Inter-VLAN Communication Using VLAN Switch

Example for Implementing Inter-VLAN Communication Using VLAN Switch

Networking Requirements

On the network shown in Figure 6-2, GE1/0/1 and GE1/0/2 of the Switch are connected to the uplink interfaces of SwitchA and SwitchB, respectively.

The downlink interfaces of SwitchA and SwitchB are added to VLAN 10 and VLAN 20 respectively.

PCs in VLAN 10 and VLAN 20 need to communicate with each other.

Figure 6-2  Inter-VLAN communication using VLAN Switch

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add the uplink and downlink interfaces of Switch A and Switch B to the VLANs.

  2. Configure the VLAN Switch feature on the Switch.

NOTE:
Ensure that VLAN 10 and VLAN 20 have not been created in the system view of the Switch, and GE1/0/1 and GE1/0/2 on the Switch have not been added to VLAN 10 and VLAN 20 respectively. Otherwise, the VLAN Switch feature cannot be configured.

Procedure

  1. Create VLAN 10 on SwitchA, add GE1/0/1 to VLAN 10 in tagged mode, and add GE1/0/2 and GE1/0/3 to VLAN 10 in access mode. The configuration of SwitchB is similar to that of SwitchA, and is not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type access
    [SwitchA-GigabitEthernet1/0/3] port default vlan 10
    [SwitchA-GigabitEthernet1/0/3] quit
    

  2. Configure the Switch.

    # Configure the VLAN Switch feature on the Switch.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] vlan-switch name1 interface gigabitethernet 1/0/1 vlan 10 interface gigabitethernet 1/0/2 switch-vlan 20
    

  3. Verify the configuration.

    When the configuration is complete, PCs in VLAN 10 and VLAN 20 can communicate with each other.

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 10
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 10
#
return

SwitchB configuration file

#
sysname SwitchB
#
vlan batch 20
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 20
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 20
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 20
#
return

Switch configuration file

#
sysname Switch
#
vlan-switch name1 interface GigabitEthernet1/0/1 vlan 10 interface GigabitEthernet1/0/2 switch-vlan 20
#
interface GigabitEthernet1/0/1
 port link-type hybrid
#
interface GigabitEthernet1/0/2
 port link-type hybrid
#
return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038103

Views: 117752

Downloads: 52

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next