No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intersecting RRPP Rings with Multiple Instances When Huawei Devices and Third-Party Devices Are Used

Example for Configuring Intersecting RRPP Rings with Multiple Instances When Huawei Devices and Third-Party Devices Are Used

Networking Requirements

As shown in Figure 18-40, on a ring network, idle links are required to forward data. In this way, data in different VLANs are forwarded along different paths, improving network efficiency and implementing load balancing. To enable devices from different vendors to communicate with each other on the network, you can use the RRPP version defined by the national standard of China.

Figure 18-40  Networking diagram of intersecting RRPP rings with multiple instances

Data Plan

Table 18-8 shows the mapping between protected VLANs and instances in Domain 1 and Domain 2.

Table 18-8  Mapping between the protected VLAN and instance

Domain ID

Control VLAN ID

Data VLAN ID

Instance ID

Domain 1

VLANs 5 and 6

VLANs 100 to 200

Instance 1

Domain 2

VLANs 10 and 11

VLANs 201 to 300

Instance 2

Table 18-9 shows the master node on each ring and the primary and secondary interfaces on each master node.

Table 18-9  Master node and its primary and secondary interfaces

Ring ID

Master Node

Primary Port

Secondary Port

Ring Type

Ring 1 in Domain 1

PEAGG

GE1/0/0

GE2/0/0

Major ring

Ring 1 in Domain 2

PEAGG

GE2/0/0

GE1/0/0

Major ring

Ring 2 in Domain 1

CE1

GE1/0/0

GE2/0/0

Sub-ring

Ring 2 in Domain 2

CE1

GE2/0/0

GE1/0/0

Sub-ring

Ring 3 in Domain 1

CE2

GE1/0/0

GE2/0/0

Sub-ring

Ring 3 in Domain 2

CE2

GE2/0/0

GE1/0/0

Sub-ring

Table 18-10 shows the edge transit nodes and edge nodes on the sub-rings.

Table 18-10  Edge transit nodes and edge nodes on the sub-rings

Ring ID

Edge-Transit Node

Edge Port

Edge-Transit Node

Edge Port

Ring 2 in Domain 1

UPEB

GE3/0/0

UPEC

GE3/0/0

Ring 3 in Domain 1

UPEB

GE3/0/1

UPEC

GE3/0/1

Ring 2 in Domain 2

UPEB

GE3/0/0

UPEC

GE3/0/0

Ring 3 in Domain 2

UPEB

GE3/0/1

UPEC

GE3/0/1

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create different RRPP domains and control VLANs.

  2. Map the VLANs that need to pass through Domain 1 to Instance 1, including data VLANs and control VLANs.

    Map the VLANs that need to pass through Domain 2 to Instance 2, including data VLANs and control VLANs.

  3. Configure interfaces to be added to the RRPP domain on the devices so that data can pass through the interfaces. Disable protocols that conflict with RRPP, such as STP.

  4. Configure the devices to use the RRPP version defined by the national standard of China.

  5. Configure protected VLANs and create RRPP rings in RRPP domains.
    1. Add UPEA, UPEB, UPEC, UPED, and PEAGG to Ring 1 in Domain 1 and Ring 1 in Domain 2.

    2. Add CE1, UPEB, and UPEC to Ring 2 in Domain 1 and Ring 2 in Domain 2.

    3. Add CE2, UPEB, and UPEC to Ring 3 in Domain 1 and Ring 3 in Domain 2.

    4. Configure PEAGG as the master node and configure UPEA, UPEB, UPEC, and UPED as transit nodes on Ring 1 in Domain 1 and Ring 1 in Domain 2.

    5. Configure CE1 as the master node and configure UPEB and UPEC as edge transit nodes on Ring 2 in Domain 1 and Ring 2 in Domain 2.

    6. Configure CE2 as the master node and configure UPEB and UPEC as edge transit nodes on Ring 3 in Domain 1 and Ring 3 in Domain 2.

  6. To prevent topology flapping, set the LinkUp timer on the master nodes.

  7. Enable the RRPP ring and RRPP protocol on devices to make RRPP take effect.

Procedure

  1. Configure instances, and map it to the data VLANs and control VLANs allowed by the RRPP interface.

    # Configure CE1. The configurations on CE2, UPEA, UPEB, UPEC, UPED, and PEAGG are the same as that of CE1 and not mentioned here. For details, see the configuration files.

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] stp region-configuration 
    [CE1-mst-region] instance 1 vlan 5 6 100 to 200
    [CE1-mst-region] instance 2 vlan 10 11 201 to 300
    [CE1-mst-region] active region-configuration
    [CE1-mst-region] quit

  2. Configure the interfaces to be added into the RRPP rings.

    # Configure CE1. The configurations on CE2, UPEA, UPEB, UPEC, UPED, and PEAGG are the same as that of CE1 and not mentioned here. For details, see the configuration files.

    [CE1] vlan batch 100 to 300
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type trunk
    [CE1-GigabitEthernet1/0/0] undo port trunk allow-pass vlan 1
    [CE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100 to 300
    [CE1-GigabitEthernet1/0/0] stp disable
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] port link-type trunk
    [CE1-GigabitEthernet2/0/0] undo port trunk allow-pass vlan 1
    [CE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 100 to 300
    [CE1-GigabitEthernet2/0/0] stp disable
    [CE1-GigabitEthernet2/0/0] quit

  3. Create RRPP domains, configure the device to use the RRPP version defined by the national standard of China, and configure protected VLANs and control VLANs.

    # Configure CE1. The configurations on CE2, UPEA, UPEB, UPEC, UPED, and PEAGG are the same as that of CE1 and not mentioned here. For details, see the configuration files.

    [CE1] rrpp working-mode gb
    [CE1] rrpp domain 1
    [CE1-rrpp-domain-region1] protected-vlan reference-instance 1
    [CE1-rrpp-domain-region1] control-vlan 5
    [CE1-rrpp-domain-region1] quit
    [CE1] rrpp domain 2
    [CE1-rrpp-domain-region2] protected-vlan reference-instance 2
    [CE1-rrpp-domain-region2] control-vlan 10
    [CE1-rrpp-domain-region2] quit

  4. Create RRPP rings.

    # Configure CE1 as the master node on Ring 2 in Domain 1. Configure GE1/0/0 as the primary interface and GE2/0/0 as the secondary interface.

    [CE1] rrpp domain 1
    [CE1-rrpp-domain-region1] ring 2 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 1
    [CE1-rrpp-domain-region1] ring 2 enable
    [CE1-rrpp-domain-region1] quit

    # Configure CE1 as the master node on Ring 2 in Domain 2. Configure GE2/0/0 as the primary interface and GE1/0/0 as the secondary interface.

    [CE1] rrpp domain 2
    [CE1-rrpp-domain-region2] ring 2 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 1
    [CE1-rrpp-domain-region2] ring 2 enable
    [CE1-rrpp-domain-region2] quit

    # Configure CE2 as the master node on Ring 3 in Domain 1. Configure GE1/0/0 as the primary interface and GE2/0/0 as the secondary interface.

    [CE2] rrpp domain 1
    [CE2-rrpp-domain-region1] ring 3 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 1
    [CE2-rrpp-domain-region1] ring 3 enable
    [CE2-rrpp-domain-region1] quit

    # Configure CE2 as the master node on Ring 3 in Domain 2. Configure GE2/0/0 as the primary interface and GE1/0/0 as the secondary interface.

    [CE2] rrpp domain 2
    [CE2-rrpp-domain-region2] ring 3 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 1
    [CE2-rrpp-domain-region2] ring 3 enable
    [CE2-rrpp-domain-region2] quit

    # Configure UPEA as a transit node on Ring 1 in Domain 1 and specify primary and secondary interfaces on UPEA.

    [UPEA] rrpp domain 1
    [UPEA-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region1] ring 1 enable
    [UPEA-rrpp-domain-region1] quit

    # Configure UPEA as a transit node on Ring 1 in Domain 2 and specify primary and secondary interfaces on UPEA.

    [UPEA] rrpp domain 2
    [UPEA-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region2] ring 1 enable
    [UPEA-rrpp-domain-region2] quit

    # Configure UPEB as a transit node on Ring 1 in Domain 1 and specify primary and secondary interfaces on UPEB.

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region1] ring 1 enable
    [UPEB-rrpp-domain-region1] quit

    # Configure UPEB as a transit node on Ring 1 in Domain 2 and specify primary and secondary interfaces on UPEB.

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region2] ring 1 enable
    [UPEB-rrpp-domain-region2] quit

    # Configure UPEB as an edge transit node on Ring 2 in Domain 1 and configure GE3/0/0 as the edge interface.

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 2 node-mode transit secondary-port gigabitethernet 3/0/0
    [UPEB-rrpp-domain-region1] ring 2 enable
    [UPEB-rrpp-domain-region1] quit

    # Configure UPEB as an edge transit node on Ring 2 in Domain 2 and configure GE3/0/0 as the edge interface.

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 2 node-mode transit secondary-port gigabitethernet 3/0/0
    [UPEB-rrpp-domain-region2] ring 2 enable
    [UPEB-rrpp-domain-region2] quit

    # Configure UPEB as an edge transit node on Ring 3 in Domain 1 and configure GE3/0/1 as the edge interface.

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 3 node-mode transit secondary-port gigabitethernet 3/0/1
    [UPEB-rrpp-domain-region1] ring 3 enable
    [UPEB-rrpp-domain-region1] quit

    # Configure UPEB as an edge transit node on Ring 3 in Domain 2 and configure GE3/0/1 as the edge interface.

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 3 node-mode transit secondary-port gigabitethernet 3/0/1
    [UPEB-rrpp-domain-region2] ring 3 enable
    [UPEB-rrpp-domain-region2] quit

    # Configure UPEC as a transit node on Ring 1 in Domain 1 and specify primary and secondary interfaces on UPEC.

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region1] ring 1 enable
    [UPEC-rrpp-domain-region1] quit

    # Configure UPEC as a transit node on Ring 1 in Domain 2 and specify primary and secondary interfaces on UPEC.

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region2] ring 1 enable
    [UPEC-rrpp-domain-region2] quit

    # Configure UPEC as an edge transit node on Ring 2 in Domain 1 and configure GE3/0/0 as the edge interface.

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 2 node-mode transit secondary-port gigabitethernet 3/0/0
    [UPEC-rrpp-domain-region1] ring 2 enable
    [UPEC-rrpp-domain-region1] quit

    # Configure UPEC as an edge transit node on Ring 2 in Domain 2 and configure GE3/0/0 as the edge interface.

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 2 node-mode transit secondary-port gigabitethernet 3/0/0
    [UPEC-rrpp-domain-region2] ring 2 enable
    [UPEC-rrpp-domain-region2] quit

    # Configure UPEC as an edge transit node on Ring 3 in Domain 1 and configure GE3/0/1 as the edge interface.

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 3 node-mode transit secondary-port gigabitethernet 3/0/1
    [UPEC-rrpp-domain-region1] ring 3 enable
    [UPEC-rrpp-domain-region1] quit

    # Configure UPEC as an edge transit node on Ring 3 in Domain 2 and configure GE3/0/1 as the edge interface.

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 3 node-mode transit secondary-port gigabitethernet 3/0/1
    [UPEC-rrpp-domain-region2] ring 3 enable
    [UPEC-rrpp-domain-region2] quit

    # Configure UPED as a transit node on Ring 1 in Domain 1 and specify primary and secondary interfaces on UPED.

    [UPED] rrpp domain 1
    [UPED-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPED-rrpp-domain-region1] ring 1 enable
    [UPED-rrpp-domain-region1] quit

    # Configure UPED as a transit node of Ring 1 in Domain 2 and specify primary and secondary interfaces on UPED.

    [UPED] rrpp domain 2
    [UPED-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPED-rrpp-domain-region2] ring 1 enable
    [UPED-rrpp-domain-region2] quit

    # Configure PEAGG as the master node on Ring 1 in Domain 1, with GE1/0/0 as the primary interface and GE2/0/0 as the secondary interface.

    [PEAGG] rrpp domain 1
    [PEAGG-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [PEAGG-rrpp-domain-region1] ring 1 enable
    [PEAGG-rrpp-domain-region1] quit

    # Configure PEAGG as the master node on Ring 1 in Domain 2, with GE2/0/0 as the primary interface and GE1/0/0 as the secondary interface.

    [PEAGG] rrpp domain 2
    [PEAGG-rrpp-domain-region2] ring 1 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 0
    [PEAGG-rrpp-domain-region2] ring 1 enable
    [PEAGG-rrpp-domain-region2] quit

  5. Enable RRPP.

    # Configure CE1. The configurations on CE2, UPEA, UPEB, UPEC, UPED, and PEAGG are the same as that of CE1 and not mentioned here. For details, see the configuration files.

    [CE1] rrpp enable

  6. Set the LinkUp timer.

    # Set the LinkUp timer to 1 second. CE1 is used as an example. The configurations on CE2 and PEAGG are the same as that of CE1 and not mentioned here. For details, see the configuration files.

    [CE1] rrpp linkup-delay-timer 1

  7. Verify the configuration.

    After the preceding configurations are complete and the network becomes stable, run the following commands to verify the configuration. UPEB and PEAGG are used as examples.

    # Run the display rrpp brief command on UPEB. The command output is as follows:

    [UPEB] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary                  Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1     0      T     GigabitEthernet1/0/0     GigabitEthernet2/0/0     Yes
     2     1      ET    GigabitEthernet1/0/0     GigabitEthernet3/0/0     Yes
                        GigabitEthernet2/0/0
     3     1      ET    GigabitEthernet1/0/0     GigabitEthernet3/0/1     Yes
                        GigabitEthernet2/0/0
    
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary                  Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1     0      T     GigabitEthernet1/0/0     GigabitEthernet2/0/0     Yes
     2     1      ET    GigabitEthernet1/0/0     GigabitEthernet3/0/0     Yes
                        GigabitEthernet2/0/0
     3     1      ET    GigabitEthernet1/0/0     GigabitEthernet3/0/1     Yes
                        GigabitEthernet2/0/0
    
    

    The command output shows that RRPP is enabled on UPEB.

    In Domain 1:

    The major control VLAN is VLAN 5, and the protected VLANs are the VLANs mapped to Instance 1.

    UPEB is a transit node on Ring 1. GigabitEthernet1/0/0 is the primary interface and GE2/0/0 is the secondary interface.

    UPEB is an edge transit node on Ring 2. The edge interface is GigabitEthernet3/0/0.

    UPEB is an edge transit node on Ring 3. The edge interface is GigabitEthernet3/0/1.

    In Domain 2:

    The major control VLAN is VLAN 10, and the protected VLANs are the VLANs mapped to Instance 2.

    UPEB is a transit node on Ring 1. GigabitEthernet1/0/0 is the primary interface and GigabitEthernet2/0/0 is the secondary interface.

    UPEB is an edge transit node on Ring 2. The edge interface is GigabitEthernet3/0/0.

    UPEB is an edge transit node on Ring 3. The edge interface is GigabitEthernet3/0/1.

    # Run the display rrpp brief command on PEAGG. The command output is as follows:

    [PEAGG]display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 1 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index    : 1
    Control VLAN    : major 5    sub 6
    Protected VLAN  : Reference Instance 1
    Hello Timer     : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring   Ring    Node     Primary                  Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     1      0       M        GigabitEthernet1/0/0     GigabitEthernet2/0/0    Yes
    
    Domain Index    : 2
    Control VLAN    : major 10    sub 11
    Protected VLAN  : Reference Instance 2
    Hello Timer     : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring   Ring    Node     Primary                  Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     1      0        M       GigabitEthernet2/0/0     GigabitEthernet1/0/0    Yes

    The command output shows that RRPP is enabled on PEAGG, and the LinkUp timer is 1 second.

    In Domain 1, the major control VLAN is VLAN 5, the protected VLAN is the VLAN mapped to Instance 1, and the master node on Ring 1 is PEAGG. GigabitEthernet1/0/0 is the primary interface and GigabitEthernet2/0/0 is the secondary interface.

    In Domain 2, the major control VLAN is VLAN 10, the protected VLAN is the VLAN mapped to Instance 2, and the master node on Ring 1 is PEAGG. GigabitEthernet2/0/0 is the primary interface and GigabitEthernet1/0/0 is the secondary interface.

    Run the display rrpp verbose domain command on UPEB. The command output is as follows:

    # Check detailed information about UPEB in Domain 1.

    [UPEB] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
    Secondary port : GigabitEthernet2/0/0               Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
                     GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet3/0/0               Port status: UP
    
    RRPP Ring      : 3
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
                     GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet3/0/1               Port status: UP
    
    

    The command output shows that the control VLAN in Domain 1 is VLAN 5, and the protected VLANs are the VLANs mapping Instance 1.

    UPEB is a transit node on Ring 1 in Domain 1 and is in LinkUp state.

    UPEB is an edge transit node on Ring 2 in Domain 1 and is in LinkUp state. GE3/0/0 is the edge interface.

    UPEB is an edge transit node of Ring 3 in Domain 1 and is in LinkUp state. GE3/0/1 is the edge interface.

    # Check detailed information about UPEB in Domain 2.

    [UPEB] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
    Secondary port : GigabitEthernet2/0/0               Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
                     GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet3/0/0               Port status: UP
    
    RRPP Ring      : 3
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
                     GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet3/0/1               Port status: UP
    
    

    The command output shows that, in Domain 2, the control VLAN is VLAN 10, and the protected VLAN is the VLAN mapped to Instance 2.

    UPEB is a transit node on Ring 1 in Domain 2 and is in LinkUp state.

    UPEB is an edge transit node of Ring 2 in Domain 2 and is in LinkUp state. GE3/0/0 is the edge interface.

    UPEB is an edge transit node of Ring 3 in Domain 2 and is in LinkUp state. GE3/0/1 is the edge interface.

    Run the display rrpp verbose domain command on PEAGG. The command output is as follows:

    # Check detailed information about PEAGG in Domain 1.

    [PEAGG] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet1/0/0               Port status: UP
    Secondary port : GigabitEthernet2/0/0               Port status: BLOCKED
    
    

    The command output shows that the control VLAN in Domain 1 is VLAN 5, and the protected VLANs are the VLANs mapping Instance 1.

    PEAGG is the master node in Domain 1 and is in Complete state.

    GigabitEthernet1/0/0 is the primary interface and GigabitEthernet2/0/0 is the secondary interface.

    # Check detailed information about PEAGG in Domain 2.

    [PEAGG] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                             Is Active: Yes
    Primary port   : GigabitEthernet2/0/0               Port status: UP
    Secondary port : GigabitEthernet1/0/0               Port status: BLOCKED
    
    

    The command output shows that, in Domain 2, the control VLAN is VLAN 10, and the protected VLAN is the VLAN mapped to Instance 2.

    PEAGG is the master node in Domain 2 and is in Complete state.

    GigabitEthernet2/0/0 is the primary interface and GigabitEthernet1/0/0 is the secondary interface.

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 2 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 1
     ring 2 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 2 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 1
     ring 2 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 3 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 3 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 1
     ring 3 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
  • UPEA configuration file

    #
    sysname UPEA
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
  • UPEB configuration file

    #
    sysname UPEB
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode transit secondary-port GigabitEthernet3/0/1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode transit secondary-port GigabitEthernet3/0/1
     ring 3 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
  • UPEC configuration file

    #
    sysname UPEC
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode transit secondary-port GigabitEthernet3/0/1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode transit secondary-port GigabitEthernet3/0/1
     ring 3 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
  • UPED configuration file

    #
    sysname UPED
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
  • PEAGG configuration file

    #
    sysname PEAGG
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp working-mode GB 
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038103

Views: 126463

Downloads: 52

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next