No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intersecting RRPP Rings with a Single Instance When Huawei Devices and Third-Party Devices Are Used

Example for Configuring Intersecting RRPP Rings with a Single Instance When Huawei Devices and Third-Party Devices Are Used

Networking Requirements

Ethernet network uses two-layer rings: one is the aggregation layer between aggregation devices PE-AGGs and the other is the access layer between PE-AGGs and UPEs.

Figure 18-33  Networking diagram of intersecting RRPP rings with a single instance

As shown in Figure 18-33, the network is required to prevent loops when the ring is complete and implement fast convergence to rapidly restore communication between nodes on the ring when the ring fails. RRPP can meet this requirement. RRPP supports multiple rings. You can configure the aggregation layer as the major ring and the access layer as the sub-ring, simplifying the network configuration. To enable devices from different vendors to communicate with each other on the network, you can use the RRPP version defined by the national standard of China.

As shown in Figure 18-34, SwitchB, SwitchA, SwitchD, and SwitchC map PE-AGG1, PE-AGG2, PE-AGG3, and UPE1 in Figure 18-33 respectively. Figure 18-34 is used as an example to describe how to configure intersecting RRPP rings with a single instance in the RRPP version defined by national standard of China.

Figure 18-34  Networking diagram of intersecting RRPP rings with a single instance (RRPP defined by the national standard of China)

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure interfaces to be added to the RRPP domain on the devices so that data can pass through the interfaces. Disable protocols that conflict with RRPP, such as STP.

  2. Create an RRPP domain and its control VLAN.

  3. Map the VLANs that needs to pass through the RRPP ring to Instance 1, including data VLANs 2 to 9 and control VLANs 10 and 11 (VLAN 11 is the sub-control VLAN generated by the device).

  4. Configure the devices to use the RRPP version defined by the national standard of China.

  5. Configure a protected VLAN and create an RRPP ring in the RRPP domain.
    1. Configure Ring 1 (major ring) in RRPP Domain 1 on SwitchA, SwitchB, and SwitchD.

    2. Configure Ring 2 (sub-ring) in RRPP Domain 1 on SwitchA, SwitchC, and SwitchD.

    3. Configure SwitchB as the master node on the major ring and configure SwitchA and SwitchD as transit nodes on the major ring.

    4. Configure SwitchC as the master node on the sub-ring and configure SwitchA and SwitchD as edge transit nodes on the sub-ring.

  6. Enable the RRPP ring and RRPP protocol on devices to make RRPP take effect.

Procedure

  1. Configure SwitchB as the master node on the major ring.

    # Create data VLANs 2 to 9 on SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 2 to 9

    # Configure Instance 1, and map it to the data VLANs and control VLANs allowed by the RRPP interface.

    [SwitchB] stp region-configuration
    [SwitchB-mst-region] instance 1 vlan 2 to 11
    [SwitchB-mst-region] active region-configuration
    [SwitchB-mst-region] quit

    # Configure Domain 1 on SwitchB. Configure VLAN 10 as the major control VLAN and bind Instance 1 to the protected VLAN in Domain 1.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] control-vlan 10
    [SwitchB-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchB-rrpp-domain-region1] quit

    # Disable STP on the interface to be added to the RRPP ring and configure the RRPP interface as a trunk interface to allow data from VLANs 2 to 9 to pass through.

    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] port link-type trunk
    [SwitchB-GigabitEthernet2/0/1] undo port trunk allow-pass vlan 1
    [SwitchB-GigabitEthernet2/0/1] port trunk allow-pass vlan 2 to 9
    [SwitchB-GigabitEthernet2/0/1] stp disable
    [SwitchB-GigabitEthernet2/0/1] quit
    [SwitchB] interface gigabitethernet 2/0/2
    [SwitchB-GigabitEthernet2/0/2] port link-type trunk
    [SwitchB-GigabitEthernet2/0/2] undo port trunk allow-pass vlan 1
    [SwitchB-GigabitEthernet2/0/2] port trunk allow-pass vlan 2 to 9
    [SwitchB-GigabitEthernet2/0/2] stp disable
    [SwitchB-GigabitEthernet2/0/2] quit

    # Configure SwitchB to use the RRPP version defined by the national standard of China.

    [SwitchB] rrpp working-mode gb

    # Configure the primary interface and secondary interface on the master node of the major ring.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchB-rrpp-domain-region1] ring 1 enable
    [SwitchB-rrpp-domain-region1] quit

  2. Configure SwitchC as the master node on the sub-ring.

    # Create data VLANs 2 to 9 on SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 2 to 9

    # Configure Instance 1, and map it to the data VLANs and control VLANs allowed by the RRPP interface.

    [SwitchC] stp region-configuration
    [SwitchC-mst-region] instance 1 vlan 2 to 11
    [SwitchC-mst-region] active region-configuration
    [SwitchC-mst-region] quit

    # Configure Domain 1 on SwitchC. Configure VLAN 10 as the major control VLAN and bind Instance 1 to the protected VLAN in Domain 1.

    [SwitchC] rrpp domain 1
    [SwitchC-rrpp-domain-region1] control-vlan 10
    [SwitchC-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchC-rrpp-domain-region1] quit

    # Disable STP on the interface to be added to the RRPP ring and configure the RRPP interface as a trunk interface to allow data from VLANs 2 to 9 to pass through.

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type trunk
    [SwitchC-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 9
    [SwitchC-GigabitEthernet1/0/1] stp disable
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] port link-type trunk
    [SwitchC-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 9
    [SwitchC-GigabitEthernet1/0/2] stp disable
    [SwitchC-GigabitEthernet1/0/2] quit

    # Configure SwitchC to use the RRPP version defined by the national standard of China.

    [SwitchC] rrpp working-mode gb

    # Configure the primary interface and secondary interface on the master node of the sub-ring.

    [SwitchC] rrpp domain 1
    [SwitchC-rrpp-domain-region1] ring 2 node-mode master primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 1
    [SwitchC-rrpp-domain-region1] ring 2 enable
    [SwitchC-rrpp-domain-region1] quit

  3. Configure SwitchA as the transit node on the major ring and the edge node on the sub-ring.

    # Create data VLANs 2 to 9 on SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 2 to 9

    # Configure Instance 1, and map it to the data VLANs and control VLANs allowed by the RRPP interface.

    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 1 vlan 2 to 11
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

    # Configure Domain 1 on SwitchA. Then configure VLAN 10 as the major control VLAN and bind Instance 1 to protected VLANs in Domain 1.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] control-vlan 10
    [SwitchA-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchA-rrpp-domain-region1] quit

    # Disable STP on the interface to be added to the RRPP ring and configure the RRPP interface as a trunk interface to allow data from VLANs 2 to 9 to pass through.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 9
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 9
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 9
    [SwitchA-GigabitEthernet1/0/3] stp disable
    [SwitchA-GigabitEthernet1/0/3] quit

    # Configure SwitchA to use the RRPP version defined by the national standard of China.

    [SwitchA] rrpp working-mode gb

    # Configure the primary interface and secondary interface on the transit node of the major ring.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/2 secondary-port gigabitethernet 1/0/1 level 0
    [SwitchA-rrpp-domain-region1] ring 1 enable
    [SwitchA-rrpp-domain-region1] quit

    # Configure the edge interface of the edge transit node on the sub-ring.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] ring 2 node-mode transit secondary-port gigabitethernet 1/0/3
    [SwitchA-rrpp-domain-region1] ring 2 enable
    [SwitchA-rrpp-domain-region1] quit

  4. Configure SwitchD as the transit node on the major ring and the edge node on the sub-ring.

    # Create data VLANs 2 to 9 on SwitchD.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchD
    [SwitchD] vlan batch 2 to 9

    # Configure Instance 1, and map it to the data VLANs and control VLANs allowed by the RRPP interface.

    [SwitchD] stp region-configuration
    [SwitchD-mst-region] instance 1 vlan 2 to 11
    [SwitchD-mst-region] active region-configuration
    [SwitchD-mst-region] quit

    # On SwitchD, configure Domain 1. Configure VLAN 10 as the major control VLAN and bind Instance 1 to the protected VLAN in Domain 1.

    [SwitchD] rrpp domain 1
    [SwitchD-rrpp-domain-region1] control-vlan 10
    [SwitchD-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchD-rrpp-domain-region1] quit

    # Disable STP on the interface to be added to the RRPP ring and configure the RRPP interface as a trunk interface.

    [SwitchD] interface gigabitethernet 1/0/1
    [SwitchD-GigabitEthernet1/0/1] port link-type trunk
    [SwitchD-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [SwitchD-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 9
    [SwitchD-GigabitEthernet1/0/1] stp disable
    [SwitchD-GigabitEthernet1/0/1] quit
    [SwitchD] interface gigabitethernet 1/0/2
    [SwitchD-GigabitEthernet1/0/2] port link-type trunk
    [SwitchD-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [SwitchD-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 9
    [SwitchD-GigabitEthernet1/0/2] stp disable
    [SwitchD-GigabitEthernet1/0/2] quit
    [SwitchD] interface gigabitethernet 1/0/3
    [SwitchD-GigabitEthernet1/0/3] port link-type trunk
    [SwitchD-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
    [SwitchD-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 9
    [SwitchD-GigabitEthernet1/0/3] stp disable
    [SwitchD-GigabitEthernet1/0/3] quit

    # Configure SwitchD to use the RRPP version defined by the national standard of China.

    [SwitchD] rrpp working-mode gb

    # Configure the primary interface and secondary interface on the transit node of the major ring.

    [SwitchD] rrpp domain 1
    [SwitchD-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/2 secondary-port gigabitethernet 1/0/1 level 0
    [SwitchD-rrpp-domain-region1] ring 1 enable
    [SwitchD-rrpp-domain-region1] quit

    # Configure the edge interface of the edge transit node on the sub-ring.

    [SwitchD] rrpp domain 1
    [SwitchD-rrpp-domain-region1] ring 2 node-mode transit secondary-port gigabitethernet 1/0/3
    [SwitchD-rrpp-domain-region1] ring 2 enable
    [SwitchD-rrpp-domain-region1] quit

  5. Enable RRPP.

    # Configure SwitchA. The configurations on SwitchB, SwitchC, and SwitchD are the same as that of SwitchA and not mentioned here. For details, see the configuration files.

    [SwitchA] rrpp enable

  6. Verify the configuration.

    After the preceding configurations are complete and the network becomes stable, run the following commands to verify the configuration.

    # Run the display rrpp brief command on SwitchB. The command output is as follows:

    [SwitchB] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary                  Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    1     1      M     GigabitEthernet2/0/1     GigabitEthernet2/0/2     Yes

    The command output shows that RRPP is enabled on SwitchB. The major control VLAN is VLAN 10, and the sub-control VLAN is VLAN 11; SwitchB is the master node on the major ring, with GE2/0/1 as the primary interface and GE2/0/2 as the secondary interface.

    # Run the display rrpp verbose domain command on SwitchB. The command output is as follows:

    [SwitchB] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1  
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/1         Port status: UP
    Secondary port : GigabitEthernet2/0/2         Port status: BLOCKED

    The command output shows that the ring is in Complete state, and the secondary interface on the master node is blocked.

    # Run the display rrpp brief command on SwitchC. The command output is as follows:

    [SwitchC] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary                  Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    2     1      M     GigabitEthernet1/0/1     GigabitEthernet1/0/2     Yes

    The command output shows that RRPP is enabled on SwitchC. The major control VLAN is VLAN 10, and the sub-control VLAN is VLAN 11. SwitchC is the master node on the sub-ring, with GE1/0/1 as the primary interface and GE1/0/2 as the secondary interface.

    # Run the display rrpp verbose domain command on SwitchC. The command output is as follows:

    [SwitchC] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1  
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/1         Port status: UP
    Secondary port : GigabitEthernet1/0/2         Port status: BLOCKED

    You can find that the sub-ring is in Complete state, and the secondary interface of the master node on the sub-ring is blocked.

    # Run the display rrpp brief command on SwitchA. The command output is as follows:

    [SwitchA] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary                  Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    1     0      T     GigabitEthernet1/0/2     GigabitEthernet1/0/1     Yes
    2     1      ET    GigabitEthernet1/0/2     GigabitEthernet1/0/3     Yes
                       GigabitEthernet1/0/1

    The command output shows that RRPP is enabled on SwitchA. The major control VLAN is VLAN 10, and the sub-control VLAN is VLAN 11. SwitchA is the master node on the major ring, with GE1/0/2 as the primary interface and GE1/0/1 as the secondary interface.

    SwitchA is also the edge transit node on the sub-ring, with GE1/0/3 as the edge interface.

    # Run the display rrpp verbose domain command on SwitchA. The command output is as follows:

    [SwitchA] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1  
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/2         Port status: UP
    Secondary port : GigabitEthernet1/0/1         Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/2         Port status: UP     
                    GigabitEthernet1/0/1         Port status: UP
    Secondary port : GigabitEthernet1/0/3         Port status: UP

    # Run the display rrpp brief command on SwitchD. The command output is as follows:

    [SwitchD] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , EM - Edge Master, ET - Edge Transit
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: GB
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary                  Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    1     0      T     GigabitEthernet1/0/2     GigabitEthernet1/0/1     Yes
    2     1      ET    GigabitEthernet1/0/2     GigabitEthernet1/0/3     Yes
                       GigabitEthernet1/0/1

    The command output shows that RRPP is enabled on SwitchD. The major control VLAN is VLAN 10, and the sub-control VLAN is VLAN 11. SwitchD is the transit node on the major ring, with GE1/0/2 as the primary interface and GE1/0/1 as the secondary interface. SwitchD is also the edge transit node on the sub-ring, with GE1/0/3 as the edge interface.

    # Run the display rrpp verbose domain command on SwitchD. The command output is as follows:

    [SwitchD] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1  
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/2         Port status: UP
    Secondary port : GigabitEthernet1/0/1         Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/2         Port status: UP
                    GigabitEthernet1/0/1         Port status: UP
    Secondary port : GigabitEthernet1/0/3         Port status: UP

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 2 to 11
    #
    rrpp enable
    rrpp working-mode GB
    #                                                                               
    stp region-configuration                                                       
     instance 1 vlan 2 to 11                                                      
     active region-configuration                                                   
    #
    rrpp domain 1 
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port Gigabitethernet1/0/2 secondary-port Gigabitethernet1/0/1 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port Gigabitethernet1/0/3
     ring 2 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 9 11
     stp disable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 2 to 11
    #
    rrpp enable
    rrpp working-mode GB
    #                                                                               
    stp region-configuration                                                       
     instance 1 vlan 2 to 11                                                      
     active region-configuration                                                   
    #
    rrpp domain 1 
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port Gigabitethernet2/0/1 secondary-port Gigabitethernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 2 to 11
    #
    rrpp enable
    rrpp working-mode GB 
    #                                                                               
    stp region-configuration                                                       
     instance 1 vlan 2 to 11                                                      
     active region-configuration                                                   
    #
    rrpp domain 1 
     control-vlan 10
     protected-vlan reference-instance 1
     ring 2 node-mode master primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 1
     ring 2 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 9 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 9 11
     stp disable
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 2 to 11
    #
    rrpp enable
    rrpp working-mode GB 
    #                                                                               
    stp region-configuration                                                       
     instance 1 vlan 2 to 11                                                      
     active region-configuration                                                   
    #
    rrpp domain 1 
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/2 secondary-port GigabitEthernet1/0/1 level 0
     ring 1 enable
     ring 2 node-mode transit secondary-port GigabitEthernet1/0/3
     ring 2 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 11
     stp disable
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 9 11
     stp disable
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038103

Views: 124879

Downloads: 52

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next