No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S9300, S9300E, and S9300X V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Link Aggregation in Manual Mode

Example for Configuring Link Aggregation in Manual Mode

Networking Requirements

In Figure 3-25, SwitchA and SwitchB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between SwitchA and SwitchB.

SwitchA and SwitchB can provide higher link bandwidth to implement inter-VLAN communication. Data transmission and link reliability need to be ensured.

Figure 3-25  Link aggregation in manual mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.

  2. Create VLANs and add interfaces to the VLANs.

  3. Configure a load balancing mode to ensure that traffic is load balanced among Eth-Trunk member interfaces.

Procedure

  1. Create an Eth-Trunk on SwitchA and SwitchB, and add member interfaces to the Eth-Trunk.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3
    [SwitchA-Eth-Trunk1] quit
    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] interface eth-trunk 1
    [SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3
    [SwitchB-Eth-Trunk1] quit

  2. Create VLANs and add interfaces to the VLANs.

    # Create VLAN 10 and VLAN 20, and add interfaces to them. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type trunk
    [SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/4] quit
    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] port link-type trunk
    [SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/5] quit
    

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] port link-type trunk
    [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [SwitchA-Eth-Trunk1] quit

  3. Configure a load balancing mode for Eth-Trunk 1. The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] load-balance src-dst-mac
    [SwitchA-Eth-Trunk1] quit
    

  4. Verify the configuration.

    Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.

    [SwitchA] display eth-trunk 1
    Eth-Trunk1's state information is: 
    WorkingMode: NORMAL           Hash arithmetic: According to SA-XOR-DA
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8
    Operate status: up             Number Of Up Port In Trunk: 3 
    --------------------------------------------------------------------------------
    PortName                           Status       Weight
    GigabitEthernet1/0/1               Up           1
    GigabitEthernet1/0/2               Up           1
    GigabitEthernet1/0/3               Up           1
    

    The preceding command output shows that Eth-Trunk 1 has three member interfaces: GigabitEthernet1/0/1, GigabitEthernet1/0/2, and GigabitEthernet1/0/3. The member interfaces are all in Up state. The Operate status of Eth-Trunk 1 is Up.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface GigabitEthernet1/0/1 
     eth-trunk 1
    # 
    interface GigabitEthernet1/0/2 
     eth-trunk 1
    # 
    interface GigabitEthernet1/0/3 
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface GigabitEthernet1/0/1 
     eth-trunk 1
    # 
    interface GigabitEthernet1/0/2 
     eth-trunk 1
    # 
    interface GigabitEthernet1/0/3 
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4 
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5 
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038290

Views: 101277

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next