No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S9300, S9300E, and S9300X V200R012C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Connecting CEs to the VPLS in Dual-Homing Mode Through MSTP

Example for Connecting CEs to the VPLS in Dual-Homing Mode Through MSTP

Networking Requirements

In Figure 14-20, each CE is dual-homed to PEs. The PEs establish a VPLS full mesh. The CEs and PEs run MSTP. Generally, traffic is forwarded through the primary link. If the primary link fails, traffic is switched to the secondary link.

Figure 14-20  Network diagram for connecting CEs to the VPLS in dual-homing mode

Switch

Interface

VLANIF Interface

IP Address

PE1

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

-

GigabitEthernet2/0/0

VLANIF 10

172.16.1.1/24

GigabitEthernet3/0/0

VLANIF 40

172.19.1.2/24

Loopback1

-

1.1.1.1/32

PE2

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

-

GigabitEthernet2/0/0

VLANIF 10

172.16.1.2/24

GigabitEthernet3/0/0

VLANIF 20

172.17.1.1/24

Loopback1

-

2.2.2.2/32

PE3

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

-

GigabitEthernet2/0/0

VLANIF 20

172.17.1.2/24

GigabitEthernet3/0/0

VLANIF 30

172.18.1.1/24

Loopback1

-

3.3.3.3/32

PE4

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

-

GigabitEthernet2/0/0

VLANIF 30

172.18.1.2/24

GigabitEthernet3/0/0

VLANIF 40

172.19.1.1/24

Loopback1

-

4.4.4.4/32

CE1

GigabitEthernet1/0/0

-

-

GigabitEthernet1/0/1

-

-

GigabitEthernet2/0/0

-

-

CE2

GigabitEthernet1/0/0

-

-

GigabitEthernet1/0/1

-

-

GigabitEthernet2/0/0

-

-

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the routing protocol on the backbone network to implement interworking.

  2. Set up a remote LDP session between the PEs.

  3. Establish a VPLS full mesh between PEs.

  4. Configure MSTP. Configure PE1 and PE2 as the primary roots, and configure PE3 and PE4 as the secondary roots.

Procedure

  1. Specify the VLANs that device interfaces belong to and set the IP addresses of the corresponding VLANIF interfaces according to Figure 14-20.

    NOTE:
    • The AC-side and PW-side physical interfaces of a PE cannot be added to the same VLAN; otherwise, a loop may occur.

    • Packets sent from CEs to PEs must contain VLAN tags.

    # Configure CE1.
    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 100
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type trunk
    [CE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] port link-type access
    [CE1-GigabitEthernet2/0/0] port default vlan 100
    [CE1-GigabitEthernet2/0/0] quit
    
    # Configure CE2.
    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] vlan batch 100
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] port link-type trunk
    [CE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [CE2-GigabitEthernet1/0/1] quit
    [CE2] interface gigabitethernet 2/0/0
    [CE2-GigabitEthernet2/0/0] port link-type access
    [CE2-GigabitEthernet2/0/0] port default vlan 100
    [CE2-GigabitEthernet2/0/0] quit
    
    # Configure PE1.
    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] vlan batch 10 40
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port link-type trunk
    [PE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] port link-type trunk
    [PE1-GigabitEthernet3/0/0] port trunk allow-pass vlan 40
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip address 172.16.1.1 24
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] ip address 172.19.1.2 24
    [PE1-Vlanif40] quit
    # Configure PE2.
    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] vlan batch 10 20
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] port link-type trunk
    [PE2-GigabitEthernet2/0/0] port trunk allow-pass vlan 10
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface gigabitethernet 3/0/0
    [PE2-GigabitEthernet3/0/0] port link-type trunk
    [PE2-GigabitEthernet3/0/0] port trunk allow-pass vlan 20
    [PE2-GigabitEthernet3/0/0] quit
    [PE2] interface vlanif 10
    [PE2-Vlanif10] ip address 172.16.1.2 24
    [PE2-Vlanif10] quit
    [PE2] interface vlanif 20
    [PE2-Vlanif20] ip address 172.17.1.1 24
    [PE2-Vlanif20] quit
    
    # Configure PE3.
    <Quidway> system-view
    [Quidway] sysname PE3
    [PE3] vlan batch 20 30
    [PE3] interface gigabitethernet 2/0/0
    [PE3-GigabitEthernet2/0/0] port link-type trunk
    [PE3-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [PE3-GigabitEthernet2/0/0] quit
    [PE3] interface gigabitethernet 3/0/0
    [PE3-GigabitEthernet3/0/0] port link-type trunk
    [PE3-GigabitEthernet3/0/0] port trunk allow-pass vlan 30
    [PE3-GigabitEthernet3/0/0] quit
    [PE3] interface vlanif 20
    [PE3-Vlanif20] ip address 172.17.1.2 24
    [PE3-Vlanif20] quit
    [PE3] interface vlanif 30
    [PE3-Vlanif30] ip address 172.18.1.1 24
    [PE3-Vlanif30] quit
    
    # Configure PE4.
    <Quidway> system-view
    [Quidway] sysname PE4
    [PE4] vlan batch 30 40
    [PE4] interface gigabitethernet 2/0/0
    [PE4-GigabitEthernet2/0/0] port link-type trunk
    [PE4-GigabitEthernet2/0/0] port trunk allow-pass vlan 30
    [PE4-GigabitEthernet2/0/0] quit
    [PE4] interface gigabitethernet 3/0/0
    [PE4-GigabitEthernet3/0/0] port link-type trunk
    [PE4-GigabitEthernet3/0/0] port trunk allow-pass vlan 40
    [PE4-GigabitEthernet3/0/0] quit
    [PE4] interface vlanif 30
    [PE4-Vlanif30] ip address 172.18.1.2 24
    [PE4-Vlanif30] quit
    [PE4] interface vlanif 40
    [PE4-Vlanif40] ip address 172.19.1.1 24
    [PE4-Vlanif40] quit
    

  2. Configure an IGP. In this example, OSPF is used.

    When configuring OSPF, advertise 32-bit loopback interface addresses (LSR IDs) of PE1, PE2, PE3, and PE4.

    # Configure PE1.
    [PE1] router id 1.1.1.1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 172.19.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    # Configure PE2.
    [PE2] router id 2.2.2.2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.2 32
    [PE2-LoopBack1] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    # Configure PE3.
    [PE3] router id 3.3.3.3
    [PE3] interface loopback 1
    [PE3-LoopBack1] ip address 3.3.3.3 32
    [PE3-LoopBack1] quit
    [PE3] ospf 1
    [PE3-ospf-1] area 0
    [PE3-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [PE3-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 172.18.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] quit
    [PE3-ospf-1] quit
    # Configure PE4.
    [PE4] router id 4.4.4.4
    [PE4] interface loopback 1
    [PE4-LoopBack1] ip address 4.4.4.4 32
    [PE4-LoopBack1] quit
    [PE4] ospf 1
    [PE4-ospf-1] area 0
    [PE4-ospf-1-area-0.0.0.0] network 4.4.4.4 0.0.0.0
    [PE4-ospf-1-area-0.0.0.0] network 172.18.1.0 0.0.0.255
    [PE4-ospf-1-area-0.0.0.0] network 172.19.1.0 0.0.0.255
    [PE4-ospf-1-area-0.0.0.0] quit
    [PE4-ospf-1] quit
    # Wait for 40s and run the display ip routing-table command on PE1, PE2, and PE3. Output similar to the following is displayed (PE1 is used as an example). The output indicates that the PEs have learned the routes to one another.
    [PE1] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 12       Routes : 13                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.2/32  OSPF    10   1           D   172.16.1.2      Vlanif10       
            3.3.3.3/32  OSPF    10   2           D   172.19.1.1      Vlanif40       
                        OSPF    10   2           D   172.16.1.2      Vlanif10       
            4.4.4.4/32  OSPF    10   1           D   172.19.1.1      Vlanif40       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  Direct  0    0           D   172.16.1.1      Vlanif10       
         172.16.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
         172.17.1.0/24  OSPF    10   2           D   172.16.1.2      Vlanif10       
         172.18.1.0/24  OSPF    10   2           D   172.19.1.1      Vlanif40       
         172.19.1.0/24  Direct  0    0           D   172.19.1.2      Vlanif40       
         172.19.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif40       

  3. Configure basic MPLS functions and LDP.

    # Configure PE1.
    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] mpls
    [PE1-Vlanif10] mpls ldp
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] mpls
    [PE1-Vlanif40] mpls ldp
    [PE1-Vlanif40] quit
    # Configure PE2.
    [PE2] mpls lsr-id 2.2.2.2
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 10
    [PE2-Vlanif10] mpls
    [PE2-Vlanif10] mpls ldp
    [PE2-Vlanif10] quit
    [PE2] interface vlanif 20
    [PE2-Vlanif20] mpls
    [PE2-Vlanif20] mpls ldp
    [PE2-Vlanif20] quit
    # Configure PE3.
    [PE3] mpls lsr-id 3.3.3.3
    [PE3] mpls
    [PE3-mpls] quit
    [PE3] mpls ldp
    [PE3-mpls-ldp] quit
    [PE3] interface vlanif 20
    [PE3-Vlanif20] mpls
    [PE3-Vlanif20] mpls ldp
    [PE3-Vlanif20] quit
    [PE3] interface vlanif 30
    [PE3-Vlanif30] mpls
    [PE3-Vlanif30] mpls ldp
    [PE3-Vlanif30] quit
    # Configure PE4.
    [PE4] mpls lsr-id 4.4.4.4
    [PE4] mpls
    [PE4-mpls] quit
    [PE4] mpls ldp
    [PE4-mpls-ldp] quit
    [PE4] interface vlanif 30
    [PE4-Vlanif30] mpls
    [PE4-Vlanif30] mpls ldp
    [PE4-Vlanif30] quit
    [PE4] interface vlanif 40
    [PE4-Vlanif40] mpls
    [PE4-Vlanif40] mpls ldp
    [PE4-Vlanif40] quit

  4. Create a remote LDP session between PEs.

    # Configure PE1.

    [PE1] mpls ldp remote-peer 3.3.3.3
    [PE1-mpls-ldp-remote-3.3.3.3] remote-ip 3.3.3.3
    [PE1-mpls-ldp-remote-3.3.3.3] quit

    # Configure PE2.

    [PE2] mpls ldp remote-peer 4.4.4.4
    [PE2-mpls-ldp-remote-4.4.4.4] remote-ip 4.4.4.4
    [PE2-mpls-ldp-remote-4.4.4.4] quit

    # Configure PE3.

    [PE3] mpls ldp remote-peer 1.1.1.1
    [PE3-mpls-ldp-remote-1.1.1.1] remote-ip 1.1.1.1
    [PE3-mpls-ldp-remote-1.1.1.1] quit

    # Configure PE4.

    [PE4] mpls ldp remote-peer 2.2.2.2
    [PE4-mpls-ldp-remote-2.2.2.2] remote-ip 2.2.2.2
    [PE4-mpls-ldp-remote-2.2.2.2] quit
    After the configuration is complete, run the display mpls ldp session command on the PEs. The command output shows that the status of the remote LDP peer relationship is Operational, indicating that remote LDP sessions have been set up. The output on PE1 is used as an example:
    [PE1] display mpls ldp session
    
    LDP Session(s) in Public Network
    Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
    A '*' before a session means the session is being deleted.
    ------------------------------------------------------------------------------
    PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
    ------------------------------------------------------------------------------
    2.2.2.2:0          Operational DU   Passive  0000:00:00  4/4
    3.3.3.3:0          Operational DU   Passive  0000:00:00  4/4
    4.4.4.4:0          Operational DU   Passive  0000:00:00  4/4
    ------------------------------------------------------------------------------
    TOTAL: 3 session(s) Found.
    

  5. Enable MPLS L2VPN on PEs.

    # Configure PE1.

    [PE1] mpls l2vpn
    [PE1-l2vpn] quit

    # Configure PE2.

    [PE2] mpls l2vpn
    [PE2-l2vpn] quit

    # Configure PE3.

    [PE3] mpls l2vpn
    [PE3-l2vpn] quit

    # Configure PE4.

    [PE4] mpls l2vpn
    [PE4-l2vpn] quit

  6. Configure a VSI on the PEs.

    # Configure PE1.

    [PE1] vsi a2 static
    [PE1-vsi-a2] pwsignal ldp
    [PE1-vsi-a2-ldp] vsi-id 2
    [PE1-vsi-a2-ldp] peer 2.2.2.2
    [PE1-vsi-a2-ldp] peer 3.3.3.3
    [PE1-vsi-a2-ldp] peer 4.4.4.4
    [PE1-vsi-a2-ldp] quit
    [PE1-vsi-a2] quit

    # Configure PE2.

    [PE2] vsi a2 static
    [PE2-vsi-a2] pwsignal ldp
    [PE2-vsi-a2-ldp] vsi-id 2
    [PE2-vsi-a2-ldp] peer 1.1.1.1
    [PE2-vsi-a2-ldp] peer 3.3.3.3
    [PE2-vsi-a2-ldp] peer 4.4.4.4
    [PE2-vsi-a2-ldp] quit
    [PE2-vsi-a2] quit

    Configuration of PE3 and PE4 is similar to configuration of PE1 and PE2.

  7. Bind the VSI to interfaces on the PEs.

    # Configure PE1.

    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] dot1q termination vid 100
    [PE1-GigabitEthernet1/0/0.1] l2 binding vsi a2
    [PE1-GigabitEthernet1/0/0.1] quit

    # Configure PE2.

    [PE2] interface gigabitethernet 1/0/0.1
    [PE2-GigabitEthernet1/0/0.1] dot1q termination vid 100
    [PE2-GigabitEthernet1/0/0.1] l2 binding vsi a2
    [PE2-GigabitEthernet1/0/0.1] quit

    # Configure PE3.

    [PE3] interface gigabitethernet 1/0/0.1
    [PE3-GigabitEthernet1/0/0.1] dot1q termination vid 100
    [PE3-GigabitEthernet1/0/0.1] l2 binding vsi a2
    [PE3-GigabitEthernet1/0/0.1] quit

    # Configure PE4.

    [PE4] interface gigabitethernet 1/0/0.1
    [PE4-GigabitEthernet1/0/0.1] dot1q termination vid 100
    [PE4-GigabitEthernet1/0/0.1] l2 binding vsi a2
    [PE4-GigabitEthernet1/0/0.1] quit

  8. Configure STP.

    1. Configure the MST region and activate the region.

      # Configure PE1.

      [PE1] stp region-configuration
      [PE1-mst-region] region-name RG1
      [PE1-mst-region] active region-configuration
      [PE1-mst-region] quit

      # Configure PE4.

      [PE4] stp region-configuration
      [PE4-mst-region] region-name RG1
      [PE4-mst-region] active region-configuration
      [PE4-mst-region] quit

      # Configure CE1.

      [CE1] stp region-configuration
      [CE1-mst-region] region-name RG1
      [CE1-mst-region] active region-configuration
      [CE1-mst-region] quit

      # Configure PE2.

      [PE2] stp region-configuration
      [PE2-mst-region] region-name RG1
      [PE2-mst-region] active region-configuration
      [PE2-mst-region] quit

      # Configure PE3.

      [PE3] stp region-configuration
      [PE3-mst-region] region-name RG1
      [PE3-mst-region] active region-configuration
      [PE3-mst-region] quit

      # Configure CE2.

      [CE2] stp region-configuration
      [CE2-mst-region] region-name RG1
      [CE2-mst-region] active region-configuration
      [CE2-mst-region] quit
    2. Configure the priorities of the PEs to make PE1 and PE2 the primary roots and PE3 and PE4 the secondary roots.

      # Configure PE1.

      [PE1] stp instance 0 priority 0

      # Configure PE2.

      [PE2] stp instance 0 priority 0

      # Configure PE3.

      [PE3] stp instance 0 priority 4096

      # Configure PE4.

      [PE4] stp instance 0 priority 4096
    3. Enable association between MSTP and VPLS on the CEs and PEs, and configure root protection on the secondary roots.

      # Configure CE1.

      [CE1] stp enable
      [CE1] interface gigabitethernet 1/0/1
      [CE1-GigabitEthernet1/0/1] stp enable
      [CE1-GigabitEthernet1/0/1] quit
      [CE1] interface gigabitethernet 1/0/0
      [CE1-GigabitEthernet1/0/0] stp enable
      [CE1-GigabitEthernet1/0/0] quit
      [CE1] interface gigabitethernet 2/0/0
      [CE1-GigabitEthernet2/0/0] stp edged-port enable
      [CE1-GigabitEthernet2/0/0] quit

      (Optional) Configure BPDU protection on CE1.

      [CE1] stp bpdu-protection

      # Configure CE2.

      [CE2] stp enable
      [CE2] interface gigabitethernet 1/0/1
      [CE2-GigabitEthernet1/0/1] stp enable
      [CE2-GigabitEthernet1/0/1] quit
      [CE2] interface gigabitethernet 1/0/0
      [CE2-GigabitEthernet1/0/0] stp enable
      [CE2-GigabitEthernet1/0/0] quit
      [CE2] interface gigabitethernet 2/0/0
      [CE2-GigabitEthernet2/0/0] stp edged-port enable
      [CE2-GigabitEthernet2/0/0] quit

      (Optional) Configure BPDU protection on CE2.

      [CE2] stp bpdu-protection
      NOTE:
      If edge ports are connected to network devices that have STP enabled and BPDU protection is enabled, the edge ports will be shut down and their attributes remain unchanged after they receive BPDUs.

      # Configure PE1.

      [PE1] stp enable
      [PE1] interface gigabitethernet 1/0/0
      [PE1-GigabitEthernet1/0/0] stp vpls-subinterface enable
      [PE1-GigabitEthernet1/0/0] stp enable
      [PE1-GigabitEthernet1/0/0] quit
      [PE1] interface gigabitethernet 2/0/0
      [PE1-GigabitEthernet2/0/0] stp disable
      [PE1-GigabitEthernet2/0/0] quit
      [PE1] interface gigabitethernet 3/0/0
      [PE1-GigabitEthernet3/0/0] stp disable
      [PE1-GigabitEthernet3/0/0] quit
      

      # Configure PE2.

      [PE2] stp enable
      [PE2] interface gigabitethernet 1/0/0
      [PE2-GigabitEthernet1/0/0] stp vpls-subinterface enable
      [PE2-GigabitEthernet1/0/0] stp enable
      [PE2-GigabitEthernet1/0/0] quit
      [PE2] interface gigabitethernet 2/0/0
      [PE2-GigabitEthernet2/0/0] stp disable
      [PE2-GigabitEthernet2/0/0] quit
      [PE2] interface gigabitethernet 3/0/0
      [PE2-GigabitEthernet3/0/0] stp disable
      [PE2-GigabitEthernet3/0/0] quit
      

      # Configure PE3.

      [PE3] stp enable
      [PE3] interface gigabitethernet 1/0/0
      [PE3-GigabitEthernet1/0/0] stp vpls-subinterface enable
      [PE3-GigabitEthernet1/0/0] stp root-protection
      [PE3-GigabitEthernet1/0/0] stp enable
      [PE3-GigabitEthernet1/0/0] quit
      [PE3] interface gigabitethernet 2/0/0
      [PE3-GigabitEthernet2/0/0] stp disable
      [PE3-GigabitEthernet2/0/0] quit
      [PE3] interface gigabitethernet 3/0/0
      [PE3-GigabitEthernet3/0/0] stp disable
      [PE3-GigabitEthernet3/0/0] quit
      

      # Configure PE4.

      [PE4] stp enable
      [PE4] interface gigabitethernet 1/0/0
      [PE4-GigabitEthernet1/0/0] stp vpls-subinterface enable
      [PE4-GigabitEthernet1/0/0] stp root-protection
      [PE4-GigabitEthernet1/0/0] stp enable
      [PE4-GigabitEthernet1/0/0] quit
      [PE4] interface gigabitethernet 2/0/0
      [PE4-GigabitEthernet2/0/0] stp disable
      [PE4-GigabitEthernet2/0/0] quit
      [PE4] interface gigabitethernet 3/0/0
      [PE4-GigabitEthernet3/0/0] stp disable
      [PE4-GigabitEthernet3/0/0] quit
      

  9. Verify the configuration.

    Run the display vsi name a2 verbose command on PE1. The command output shows that the VSI state is Up.

    [PE1] display vsi name a2 verbose
    
     ***VSI Name               : a2
        Administrator VSI      : no
        Isolate Spoken         : disable
        VSI Index              : 0
        PW Signaling           : ldp
        Member Discovery Style : static
        PW MAC Learn Style     : unqualify
        Encapsulation Type     : vlan
        MTU                    : 1500
        Diffserv Mode          : uniform
        Mpls Exp               : --
        DomainId               : 255
        Domain Name            :
        Ignore AcState         : disable
        P2P VSI                : disable
        Create Time            : 0 days, 20 hours, 29 minutes, 54 seconds
        VSI State              : up
    
        VSI ID                 : 2
       *Peer Router ID         : 2.2.2.2
        Negotiation-vc-id      : 2
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 4099
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0xd
        Broadcast Tunnel ID    : 0xd
        Broad BackupTunnel ID  : 0x0
        CKey                   : 2
        NKey                   : 1
        Stp Enable             : 0
        PwIndex                : 0
        Control Word           : disable
       *Peer Router ID         : 3.3.3.3
        Negotiation-vc-id      : 2
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 4100
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0xf
        Broadcast Tunnel ID    : 0xf
        Broad BackupTunnel ID  : 0x0
        CKey                   : 4
        NKey                   : 3
        Stp Enable             : 0
        PwIndex                : 0
        Control Word           : disable
       *Peer Router ID         : 4.4.4.4
        Negotiation-vc-id      : 2
        primary or secondary   : primary
        ignore-standby-state   : no
        VC Label               : 4101
        Peer Type              : dynamic
        Session                : up
        Tunnel ID              : 0xb
        Broadcast Tunnel ID    : 0xb
        Broad BackupTunnel ID  : 0x0
        CKey                   : 6
        NKey                   : 5
        Stp Enable             : 0
        PwIndex                : 0
        Control Word           : disable
    
        Interface Name         : GigabitEthernet1/0/0.1
        State                  : up
        Access Port            : false
        Last Up Time           : 2015/03/16 15:56:44
        Total Up Time          : 0 days, 0 hours, 1 minutes, 24 seconds
    
       **PW Information:
    
       *Peer Ip Address        : 3.3.3.3
        PW State               : up
        Local VC Label         : 4100
        Remote VC Label        : 4099
        Remote Control Word    : disable
        PW Type                : label
        Local  VCCV            : alert lsp-ping bfd
        Remote VCCV            : alert lsp-ping bfd
        Tunnel ID              : 0xf
        Broadcast Tunnel ID    : 0xf
        Broad BackupTunnel ID  : 0x0
        Ckey                   : 0x4
        Nkey                   : 0x3
        Main PW Token          : 0xf
        Slave PW Token         : 0x0
        Tnl Type               : LSP
        OutInterface           : Vlanif10
        Backup OutInterface    :
        Stp Enable             : 0
        PW Last Up Time        : 2015/03/16 15:56:48
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 24 seconds
       *Peer Ip Address        : 4.4.4.4
        PW State               : up
        Local VC Label         : 4101
        Remote VC Label        : 4099
        Remote Control Word    : disable
        PW Type                : label
        Local  VCCV            : alert lsp-ping bfd
        Remote VCCV            : alert lsp-ping bfd
        Tunnel ID              : 0xb
        Broadcast Tunnel ID    : 0xb
        Broad BackupTunnel ID  : 0x0
        Ckey                   : 0x6
        Nkey                   : 0x5
        Main PW Token          : 0xb
        Slave PW Token         : 0x0
        Tnl Type               : LSP
        OutInterface           : Vlanif40
        Backup OutInterface    :
        Stp Enable             : 0
        PW Last Up Time        : 2015/03/16 15:56:49
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 24 seconds
       *Peer Ip Address        : 2.2.2.2
        PW State               : up
        Local VC Label         : 4099
        Remote VC Label        : 4099
        Remote Control Word    : disable
        PW Type                : label
        Local  VCCV            : alert lsp-ping bfd
        Remote VCCV            : alert lsp-ping bfd
        Tunnel ID              : 0xd
        Broadcast Tunnel ID    : 0xd
        Broad BackupTunnel ID  : 0x0
        Ckey                   : 0x2
        Nkey                   : 0x1
        Main PW Token          : 0xd
        Slave PW Token         : 0x0
        Tnl Type               : LSP
        OutInterface           : Vlanif10
        Backup OutInterface    :
        Stp Enable             : 0
        PW Last Up Time        : 2015/03/16 15:57:06
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 24 seconds
    

    PC1 (10.1.1.1) can ping PC2 (10.1.1.2).

    If the link between CE1 and PE1 fails or PE1 is faulty, PE4 becomes the primary root. In this case, PC1 and PE2 can still ping each other.

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 100
    #
    stp bpdu-protection
    #
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration                                                    
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type access                                                          
     port default vlan 100
     stp edged-port enable
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 100
    #
    stp bpdu-protection
    #
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type access                                                          
     port default vlan 100
     stp edged-port enable
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
    router id 1.1.1.1
    #
    vlan batch 10 40
    #
    stp instance 0 priority 0 
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration                                                    
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls l2vpn
    #
    vsi a2 static 
     pwsignal ldp 
      vsi-id 2
      peer 2.2.2.2 
      peer 3.3.3.3
      peer 4.4.4.4
    # 
    mpls ldp
    #
    mpls ldp remote-peer 3.3.3.3
     remote-ip 3.3.3.3
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 172.19.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     stp vpls-subinterface enable
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 100
     l2 binding vsi a2
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
     stp disable
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 172.19.1.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    router id 2.2.2.2
    #
    vlan batch 10 20
    #
    stp instance 0 priority 0 
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration                                                    
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls l2vpn
    #
    vsi a2 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.1
      peer 3.3.3.3
      peer 4.4.4.4
    #
    mpls ldp
    #
    mpls ldp remote-peer 4.4.4.4
     remote-ip 4.4.4.4
    #
    interface Vlanif10
     ip address 172.16.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 172.17.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     stp vpls-subinterface enable
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 100
     l2 binding vsi a2
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
     stp disable
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 172.17.1.0 0.0.0.255
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    router id 3.3.3.3
    #
    vlan batch 20 30
    #
    stp instance 0 priority 4096 
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration                                                    
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls l2vpn
    #
    vsi a2 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.1
      peer 2.2.2.2
      peer 4.4.4.4
    #
    mpls ldp
    #
    mpls ldp remote-peer 1.1.1.1
     remote-ip 1.1.1.1
    #
    interface Vlanif20
     ip address 172.17.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 172.18.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     stp root-protection
     stp vpls-subinterface enable
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 100
     l2 binding vsi a2
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
     stp disable
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 172.17.1.0 0.0.0.255
      network 172.18.1.0 0.0.0.255
    #
    return
  • PE4 configuration file

    #
    sysname PE4
    #
    router id 4.4.4.4
    #
    vlan batch 30 40
    #
    stp instance 0 priority 4096 
    stp enable
    #
    stp region-configuration                                                        
     region-name RG1                                                                
     active region-configuration                                                    
    #
    mpls lsr-id 4.4.4.4
    mpls
    #
    mpls l2vpn
    #
    vsi a2 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.1
      peer 2.2.2.2
      peer 3.3.3.3
    #
    mpls ldp
    #
    mpls ldp remote-peer 2.2.2.2
     remote-ip 2.2.2.2
    #
    interface Vlanif30
     ip address 172.18.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 172.19.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     stp root-protection
     stp vpls-subinterface enable
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 100
     l2 binding vsi a2
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
     stp disable
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 172.18.1.0 0.0.0.255
      network 172.19.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038290

Views: 102933

Downloads: 24

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next