No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S1720, S2700, S5700, and S6720 V200R012(C00 and C20)

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DHCP policy VLAN, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel, and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a 6to4 Tunnel

Example for Configuring a 6to4 Tunnel

Networking Requirements

Figure 13-13 shows that SwitchA connects to a 6to4 network using an IPv6 network-side interface, and that SwitchB is a 6to4 relay agent and connects to the IPv6 Internet (2002::/64). SwitchC and SwitchD are connected through an IPv4 backbone network. A 6to4 tunnel needs to be set up between SwitchA and SwitchB so that hosts on the 6to4 network and the IPv6 network can communicate.

Figure 13-13  Networking diagram for configuring a 6to4 tunnel

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IPv4/IPv6 dual stack on SwitchA and SwitchB so that they can access the IPv4 and IPv6 networks.

  2. Configure a 6to4 tunnel on SwitchA and SwitchB to connect IPv6 networks through the IPv4 backbone network.

  3. Configure a static route between SwitchA and SwitchB so that they can connect through the IPv4 backbone network.

Procedure

  1. Configure SwitchA.

    # Enable the service loopback function on an Eth-Trunk.

    NOTE:

    The interface must be idle and not transmitting services.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] service type tunnel
    [SwitchA-Eth-Trunk1] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] eth-trunk 1
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # Configure an IPv4/IPv6 dual stack.

    [SwitchA] ipv6
    [SwitchA] vlan batch 100 200
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 200
    [SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ipv6 enable
    [SwitchA-Vlanif200] ipv6 address 2002:0a01:0101:1::1/64
    [SwitchA-Vlanif200] quit

    # Configure a 6to4 tunnel.

    [SwitchA] interface tunnel 1
    [SwitchA-Tunnel1] tunnel-protocol ipv6-ipv4 6to4
    [SwitchA-Tunnel1] eth-trunk 1
    [SwitchA-Tunnel1] ipv6 enable
    [SwitchA-Tunnel1] ipv6 address 2002:0a01:0101::1/64
    [SwitchA-Tunnel1] source vlanif 100
    [SwitchA-Tunnel1] quit

    # Configure a route to the other 6to4 network.

    [SwitchA] ipv6 route-static 2002:: 16 tunnel 1

  2. Configure SwitchB.

    # Enable the service loopback function on an Eth-Trunk.

    NOTE:

    The interface must be idle and not transmitting services.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] interface eth-trunk 1
    [SwitchB-Eth-Trunk1] service type tunnel
    [SwitchB-Eth-Trunk1] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] eth-trunk 1
    [SwitchB-GigabitEthernet0/0/3] quit
    

    # Configure an IPv4/IPv6 dual stack.

    [SwitchB] ipv6
    [SwitchB] vlan batch 200 300
    [SwitchB] interface gigabitethernet0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 300
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 300
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 300
    [SwitchB-Vlanif300] ip address 10.3.1.2 24
    [SwitchB-Vlanif300] quit
    [SwitchB] interface gigabitethernet0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/2] port hybrid pvid vlan 200
    [SwitchB-GigabitEthernet0/0/2] port hybrid untagged vlan 200
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] ipv6 enable
    [SwitchB-Vlanif200] ipv6 address 2002:0a03:0102:1::1/64
    [SwitchB-Vlanif200] quit

    # Configure a 6to4 tunnel.

    [SwitchB] interface tunnel 1
    [SwitchB-Tunnel1] eth-trunk 1
    [SwitchB-Tunnel1] tunnel-protocol ipv6-ipv4 6to4
    [SwitchB-Tunnel1] ipv6 enable
    [SwitchB-Tunnel1] ipv6 address 2002:0a03:0102::1/64
    [SwitchB-Tunnel1] source vlanif 300
    [SwitchB-Tunnel1] quit

    # Configure a route to the other 6to4 network.

    [SwitchB] ipv6 route-static 2002:: 16 tunnel 1

  3. Assign IPv4 addresses to interfaces and configure OSPF.

    # Configure OSPF on SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    

    # Configure OSPF on SwitchB.

    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit
    

    # Assign IPv4 addresses to interfaces and configure OSPF on SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 100 200
    [SwitchC] interface vlanif 100
    [SwitchC-Vlanif100] ip address 10.1.1.2 24
    [SwitchC-Vlanif100] quit
    [SwitchC] interface vlanif 200
    [SwitchC-Vlanif200] ip address 10.2.1.1 24
    [SwitchC-Vlanif200] quit
    [SwitchC] interface gigabitethernet0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchC-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface gigabitethernet0/0/2
    [SwitchC-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchC-GigabitEthernet0/0/2] port hybrid pvid vlan 200
    [SwitchC-GigabitEthernet0/0/2] port hybrid untagged vlan 200
    [SwitchC-GigabitEthernet0/0/2] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit
    

    # Assign IPv4 addresses to interfaces and configure OSPF on SwitchD.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchD
    [SwitchD] vlan batch 200 300
    [SwitchD] interface vlanif 200
    [SwitchD-Vlanif200] ip address 10.2.1.2 24
    [SwitchD-Vlanif200] quit
    [SwitchD] interface vlanif 300
    [SwitchD-Vlanif300] ip address 10.3.1.1 24
    [SwitchD-Vlanif300] quit
    [SwitchD] interface gigabitethernet0/0/1
    [SwitchD-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchD-GigabitEthernet0/0/1] port hybrid pvid vlan 300
    [SwitchD-GigabitEthernet0/0/1] port hybrid untagged vlan 300
    [SwitchD-GigabitEthernet0/0/1] quit
    [SwitchD] interface gigabitethernet0/0/2
    [SwitchD-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchD-GigabitEthernet0/0/2] port hybrid pvid vlan 200
    [SwitchD-GigabitEthernet0/0/2] port hybrid untagged vlan 200
    [SwitchD-GigabitEthernet0/0/2] quit
    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit
    

  4. Verify the configuration.

    # Check the IPv6 status of Tunnel1 on SwitchA.

    [SwitchA] display ipv6 interface tunnel 1
    Tunnel1 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::244:1FF:FE41:5410
      Global unicast address(es):
        2002:A01:101::1, subnet is 2002:A01:101::/64
      Joined group address(es):
        FF02::1:FF00:1
        FF02::1:FF41:5410
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds 
    

    You can see that the tunnel status is Up.

    # Ping the 6to4 address of the tunnel interface on SwitchB from SwitchA.

    [SwitchA] ping ipv6 2002:0a03:0102::1
      PING 2002:0a03:0102::1 : 56  data bytes, press CTRL_C to break
        Reply from 2002:A03:102::1
        bytes=56 Sequence=1 hop limit=64  time = 8 ms
        Reply from 2002:A03:102::1
        bytes=56 Sequence=2 hop limit=64  time = 25 ms
        Reply from 2002:A03:102::1
        bytes=56 Sequence=3 hop limit=64  time = 4 ms
        Reply from 2002:A03:102::1
        bytes=56 Sequence=4 hop limit=64  time = 5 ms
        Reply from 2002:A03:102::1
        bytes=56 Sequence=5 hop limit=64  time = 5 ms
    
      --- 2002:0a03:0102::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 4/9/25 ms

    The 6to4 address can be pinged successfully.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2002:A01:101:1::1/64
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet0/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address 2002:A01:101::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source Vlanif100
     eth-trunk 1
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    ipv6 route-static 2002:: 16 Tunnel1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 200 300
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2002:A03:102:1::1/64
    #
    interface Vlanif300
     ip address 10.3.1.2 255.255.255.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet0/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address 2002:A03:102::1/64
     tunnel-protocol ipv6-ipv4 6to4
     source Vlanif300
     eth-trunk 1
    #
    ospf 1
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255
    #
    ipv6 route-static 2002:: 16 Tunnel1
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif200
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
    
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 200 300
    #
    interface Vlanif200
     ip address 10.2.1.2 255.255.255.0
    #
    interface Vlanif300
     ip address 10.3.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ospf 1
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038342

Views: 84860

Downloads: 281

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next