No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S1720, S2700, S5700, and S6720 V200R012(C00 and C20)

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DHCP policy VLAN, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel, and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Connecting a Device to an NLB Cluster (Using Multi-Interface ARP)

Example for Connecting a Device to an NLB Cluster (Using Multi-Interface ARP)

Networking Requirements

In Figure 2-28, the Switch connects to three NLB servers respectively through GE0/0/1, GE0/0/2, and GE0/0/3 in VLAN 10.

Figure 2-28  Networking diagram for configuring multi-interface ARP

The NLB cluster works in multicast mode. Each server in the NLB cluster has an IP address and a MAC address. All servers in the cluster share the cluster IP address (10.128.246.252/24) and cluster MAC address (03bf-0a80-f6fc). There are reachable routes between the Switch and Client.

The customer requires that the Switch send the packet destined for the cluster IP address to each server in the NLB cluster.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and add the interfaces to VLANs.
  2. Configure a MAC address entry mapping multiple outbound interfaces and configure a static ARP entry so that the Switch can send the packets destined for the cluster IP address to the three servers in the NLB cluster.

Procedure

  1. Create VLANs and add interfaces to the VLANs.

    # Create a VLAN on the Switch and add the interfaces to the VLAN.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] vlan 10
    [Switch-vlan10] port gigabitethernet 0/0/1 to 0/0/3
    [Switch-vlan10] quit
    

  2. # Create a VLANIF interface on the Switch and assign an IP address to the VLANIF interface.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.128.246.251 24
    [Switch-Vlanif10] quit
    

  3. Configure a MAC address entry mapping multiple outbound interfaces on the Switch.

    [Switch] mac-address multiport 03bf-0a80-f6fc interface gigabitethernet 0/0/1 to gigabitethernet 0/0/3 vlan 10
    

  4. Configure static ARP entries on the Switch.

    [Switch] arp static 10.128.246.252 03bf-0a80-f6fc
    [Switch] quit

  5. Verify the configuration.

    # Run the display mac-address multiport vlan 10 command on the Switch to check the configured MAC address entry mapping multiple outbound interfaces.

    <Switch> display mac-address multiport vlan 10
    --------------------------------------------------------------------------------
    MAC Address       VLANID    Out-Interface               Status                                                                      
    --------------------------------------------------------------------------------
    03bf-0a80-f6fc    10        GigabitEthernet0/0/1        Active                                
                                GigabitEthernet0/0/2        Active                                
                                GigabitEthernet0/0/3        Active                                
                                                3 port(s)                           
    --------------------------------------------------------------------------------
     Total Group(s) : 1 
    

    # Run the display arp static command on the Switch to check static ARP entries.

    <Switch> display arp static
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE  
                                              VLAN/CEVLAN                
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc            S--         Multi-port:3            
    ------------------------------------------------------------------------------
    Total:1        Dynamic:0      Static:1     Interface:0 
    

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10 
#
interface Vlanif10
 ip address 10.128.246.251 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10 
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038342

Views: 85902

Downloads: 283

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next