No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S1720, S2700, S5700, and S6720 V200R012(C00 and C20)

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DHCP policy VLAN, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel, and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IPv6 DNS Client

Example for Configuring an IPv6 DNS Client

Networking Requirements

As shown in Figure 12-2, SwitchA, functioning as the IPv6 DNS client and working jointly with IPv6 DNS server, can access the host with the IPv6 address as fc00:2::1/64 based on the domain name huawei.com.

On SwitchA, the static IPv6 DNS entries of SwitchB and SwitchC are configured. This ensures that SwitchA can manage both the devices based on the domain names SwitchB and SwitchC.

Figure 12-2  Networking diagram of IPv6 DNS configurations

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure static DNS entries on SwitchA to access SwitchB and SwitchC using the domain name.

  2. Configure dynamic DNS resolution on SwithcA to enable SwitchA to access the web server by querying dynamic DNS entries.

  3. Configure domain name suffixes on SwitchA so that SwitchA can filter domain names using the domain name suffix list.

  4. Configure routes on the switches to ensure reachable routes between them.

Procedure

  1. Configure SwitchA.

    # Configure IPv6 function.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] ipv6 
    [SwitchA] vlan 101
    [SwitchA-vlan101] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 101
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 101
    [SwitchA-GigabitEthernet0/0/1] quit 
    [SwitchA] interface vlanif 101 
    [SwitchA-Vlanif101] ipv6 enable
    [SwitchA-Vlanif101] ipv6 address fc00:1::1/64
    [SwitchA-Vlanif101] quit 

    # Configure static IPv6 DNS entries.

    [SwitchA] ipv6 host SwitchB fc00:1::2
    [SwitchA] ipv6 host SwitchC fc00:2::3

    # Enable the DNS resolution function.

    [SwitchA] dns resolve

    # Configure the IPv6 address of the IPv6 DNS server.

    [SwitchA] dns server ipv6 fc00:3::2

    # Set the domain name suffix to ".net".

    [SwitchA] dns domain net

    # Set the domain name suffix to ".com".

    [SwitchA] dns domain com
    [SwitchA] quit
    NOTE:

    To resolve the domain name, you also need to configure the route from Switch A to the IPv6 DNS server. For details on how to configure the route, see Configuration Examples for Static Routes in "Static Route Configuration" in the S1720, S2700, S5700, and S6720 V200R012(C00&C20) Configuration Guide - IP Unicast Routing.

  2. Verify the configuration.

    # Run the ping ipv6 huawei.com command on Switch A. You can find that the Ping operation succeeds, and the destination IPv6 address is fc00:2::1.

    <SwitchA> ping ipv6 huawei.com
      Resolved Host ( huawei.com -> FC00:2::1 )                                       
      PING huawei.com : 56  data bytes, press CTRL_C to break                       
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=1 hop limit=63  time = 56 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=2 hop limit=63  time = 14 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=3 hop limit=63  time = 50 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=4 hop limit=63  time = 7 ms                               
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=5 hop limit=63  time = 7 ms                               
                                                                                    
      --- huawei.com ping statistics ---                                            
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 7/26/56 ms 

    # Run the display ipv6 host command on SwitchA. You can view the mapping relationships between the host names and the IPv6 addresses in IPv6 static DNS entries.

    <SwitchA> display ipv6 host
    Host              Age        Flags   IPv6Address (es)
    SwitchB           0          static  FC00:1::2
    SwitchC           0          static  FC00:2::3

    Run the display dns ipv6 dynamic-host command on SwitchA. You can view information about IPv6 dynamic DNS entries in the dynamic cache.

    <SwitchA> display dns ipv6 dynamic-host
    No  Domain-name           Ipv6address          TTL 
    1   huawei.com            FC00:2::1            3579  
    NOTE:

    TTL in the command output indicates the life time of the entry, in seconds.

Configuration Files

  • SwitchA configuration file

  • #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 101
    #
    ipv6 host SwitchB FC00:1::2
    ipv6 host SwitchC FC00:2::3
    #
    dns resolve
    dns server ipv6 FC00:3::2
    dns domain net
    dns domain com
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #                                                                               
    ipv6 route-static FC00:2:: 64 FC00:1::2                                             
    ipv6 route-static FC00:3:: 64 FC00:1::2   
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #                                                                               
    ipv6 
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::2/64
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::2/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                                               
    ipv6 route-static FC00:3:: 64 FC00:2::3  
    #
    return
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::3/64
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:3::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                                               
    ipv6 route-static FC00:1:: 64 FC00:2::2  
    #
    return
    
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038342

Views: 85287

Downloads: 281

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next