No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Service Holding upon CAPWAP Link Disconnection

Example for Configuring Service Holding upon CAPWAP Link Disconnection

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. Then the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

An enterprise deploys WLAN area A to provide WLAN services. As shown in Figure 5-4, the AP is directly connected to the switch, service data is directly forwarded in AC bypass deployment mode, and the switch connects to the Internet through the egress route. The enterprise requires that data forwarding is not affected even when the AC is faulty to improve data transmission reliability.

Figure 5-4  Networking diagram for configuring service holding upon CAPWAP link disconnection

Configuration Roadmap

  1. Configure basic WLAN services.
  2. Configure service holding upon CAPWAP link disconnection to improve data transmission reliability so that data forwarding is not affected even when the AC is faulty.
Table 5-9  Data plan

Item

Data

DHCP server

Switch, which assigns IP addresses to STAs and APs

IP address pool for APs

10.1.1.3-10.1.1.254/24

IP address pool for STAs

10.1.2.2-10.1.2.254/24

Gateway address for APs

10.1.1.1/24

Gateway address for STAs

10.1.2.1/24

AC source interface

VLANIF100: 10.1.1.2/24

AP group
  • Name: ap-group1
  • Referenced profile: AP system profile wlan-system, VAP profile wlan-vap, and regulatory domain profile domain
Regulatory domain profile
  • Name: domain
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security
AP system profile
  • Name: wlan-system
  • Service holding upon CAPWAP link disconnection: enabled

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure the switch and AC to enable the AC to communicate with the APs.

    # Create VLAN100 (management VLAN) and VLAN101 (service VLAN) on the switch. Set the link type of GE0/0/1 that connects the switch to the APs to trunk and PVID of the interface to 100, and configure the interface to allow packets of VLAN100 and VLAN101 to pass. Set the link type of GE0/0/2 on the switch to trunk, and configure the interface to allow packets of VLAN100 to pass.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    

    # Add GE0/0/1 that connects the AC to the switch to VLAN100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the DHCP function on the switch to allocate IP addresses to APs and STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.

    # Configure VLANIF100 to use the interface address pool to allocate IP addresses to APs.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.1.1 255.255.255.0
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.1.1.2
    [Switch-Vlanif100] quit
    

    # Configure VLANIF101 to use the interface address pool to allocate IP addresses to STAs.

    [Switch] interface vlanif 101
    [Switch-Vlanif101] ip address 10.1.2.1 255.255.255.0
    [Switch-Vlanif101] dhcp select interface
    [Switch-Vlanif101] quit
    

  4. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain
    [AC-wlan-regulate-domain-domain] country-code cn
    [AC-wlan-regulate-domain-domain] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.1.1.2 255.255.255.0
    [AC-Vlanif100] quit
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.1.1.254    AP6010DN-AGN    nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create the AP system profile wlan-system and configure the service holding function.

    [AC-wlan-view] ap-system-profile name wlan-system
    [AC-wlan-ap-system-prof-wlan-system] keep-service enable
    [AC-wlan-ap-system-prof-wlan-system] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind the AP system profile and VAP profile to the AP group and apply the VAP profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] ap-system-profile wlan-system
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Verify the configuration.

    The WLAN with SSID wlan-net is available for STAs connected to the AP, and these STAs can connect to the WLAN without authentication. If the AC is powered off, service data forwarding for wireless users in area A is not affected.

Configuration Files

  • Switch configuration file

    #                            
     sysname Switch                         
    #                   
     vlan batch 100 to 101              
    #                                    
     dhcp enable                        
    #                               
    interface Vlanif100                     
     ip address 10.1.1.1 255.255.255.0               
     dhcp select interface            
     dhcp server excluded-ip-address 10.1.1.2
    #                             
    interface Vlanif101             
     ip address 10.1.2.1 255.255.255.0                      
     dhcp select interface               
    # 
     interface GigabitEthernet0/0/1                  
     port link-type trunk                    
     port trunk pvid vlan 100                      
     port trunk allow-pass vlan 100 to 101                 
     port-isolate enable group 1 
    #                    
     interface GigabitEthernet0/0/2                  
     port link-type trunk               
     port trunk allow-pass vlan 100               
    #
    return
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #                          
    interface GigabitEthernet0/0/1              
     port link-type trunk                            
     port trunk allow-pass vlan 100             
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode direct-forward
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain
     ap-system-profile name wlan-system
      keep-service enable
     ap-group name ap-group1
      ap-system-profile wlan-system
      regulatory-domain-profile domain
      radio 0
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 148773

Downloads: 425

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next