No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Example for the Shopping Mall and Supermarket IoT Solution - Smart Shopping Guide

Configuration Example for the Shopping Mall and Supermarket IoT Solution - Smart Shopping Guide

Example of Configuring the Shopping Mall and Supermarket IoT Solution - Smart Shopping Guide (With Tablet Kiosks Installed)

Service Requirements

A shopping mall wants to reduce the number of shop assistants to reuse labor costs. It also wants to perform Big Data analytics on customers' actions of picking up commodities to understand popularity of commodities, make proper marketing strategies, and improve sales profits. Additionally, the shopping mall wants to provide wireless network access for its customers.

To meet these requirements, Huawei provides the smart shopping guide solution with tablet kiosks installed.

Networking Requirements
  • AC networking mode: Layer 2 in bypass mode
  • DHCP deployment mode: Configure an AC as the DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 28-4  Networking diagram for configuring the smart shopping guide solution
Data Planning
Table 28-3  AC data planning

Item

Data

Management VLAN

VLAN 100

Service VLAN for customers or employees

VLAN 101

Service VLAN for tablet kiosks

VLAN 102

AC's source interface

VLANIF 100

DHCP server The AC functions as a DHCP server to assign IP addresses to APs and STAs.
IP address pool for STAs

10.23.101.2 to 10.23.101.254/24

10.23.102.2 to 10.23.102.254/24

AP group
  • Name: ap-group1
  • Referenced profiles: VAP profiles wlan-net and wlan-ble, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: CN
SSID profile
For tablet kiosks:
  • Name: wlan-ble
  • SSID name: wlan-ble
For customers or employees:
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
For tablet kiosks:
  • Name: wlan-ble
  • Security policy: Open
For customers or employees:
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
For tablet kiosks:
  • Name: wlan-ble
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 102
  • Referenced profiles: SSID profile wlan-ble, security profile wlan-ble, and authentication profile wlan-ble
For customers or employees:
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net
RADIUS authentication parameters
  • Name of the RADIUS server template: wlan-ble
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-ble
MAC access profile Name: wlan-ble
Authentication profile
  • Name: wlan-ble
  • Referenced profiles and authentication scheme: MAC access profile wlan-ble, RADIUS server template wlan-ble, and authentication profile wlan-ble
Configuration Roadmap
  1. Configure network interworking of the APs, switch, AC, and host computer.

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

  3. Configure the APs to go online.

  4. Configure WLAN services to provide wireless access for tablet kiosks and wireless network services for customers or employees.

  5. Configure the Bluetooth data transparent transmission function.

  6. Associate BLE labels with commodities.

Configuration Notes
  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure the switch and AC to enable the AP to communicate with the AC.

    # Configure the access switch. Add GE0/0/1 on the switch to VLAN 100 (management VLAN), and GE0/0/2 to VLAN 100, VLAN 101, and VLAN 102 (service VLANs).

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 to 102
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 to 102
    [Switch-GigabitEthernet0/0/2] quit
    

    # Configure the AC. Add GE0/0/1 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 to 102
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the AP to communicate with the host computer and RADIUS server.

    Configure routes based on the actual networking situation to ensure network interworking between the AP and host computer.

  4. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    # Configure the DHCP server based on the address pool of a VLANIF interface.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.23.102.1 24
    [AC-Vlanif102] dhcp select interface
    [AC-Vlanif102] quit
    

  5. Configure the AP to go online.

    # Create an AP group to which APs with the same configuration are to be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the country code for the AC in the profile, and bind the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the source interface on the AC.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to the AP group ap-group1. Configure an AP name based on the AP's deployment location, so that you can know where the AP is deployed from its name. If the AP with MAC address 60de-4476-e360 is in area 1, name the AP area_1.
    NOTE:

    The ap auth-mode command sets the AP authentication mode to MAC address authentication by default. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP4050DN-E is used and has two radios: radio 0 and radio 1.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply 
    ----------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime ExtraInfo
    ----------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP4050DN-E      nor   0   25S    -
    ----------------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters to provide wireless network services for customers or employees.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Configure WLAN service parameters to provide wireless access for tablet kiosks.
    1. Configure RADIUS authentication parameters.

      # Create a RADIUS server template.

      [AC-wlan-view] quit
      [AC] radius-server template wlan-ble
      [AC-radius-wlan-ble] radius-server authentication 10.23.103.1 1812
      [AC-radius-wlan-ble] radius-server shared-key cipher huawei@123
      [AC-radius-wlan-ble] quit
      

      # Configure a RADIUS authentication scheme.

      [AC] aaa
      [AC-aaa] authentication-scheme wlan-ble
      [AC-aaa-authen-wlan-ble] authentication-mode radius
      [AC-aaa-authen-wlan-ble] quit
      [AC-aaa] quit
      

    2. Configure a MAC access profile.

      NOTE:
      In a MAC access profile, a MAC address without hyphens (-) is used as the user name and password for MAC address authentication by default.

      # Create MAC access profile wlan-ble.

      [AC] mac-access-profile name wlan-ble
      [AC-mac-access-profile-wlan-ble] quit
      

    3. Create authentication profile wlan-ble, and bind the MAC access profile, authentication scheme, and RADIUS server template to it.

      [AC] authentication-profile name wlan-ble
      [AC-authentication-profile-wlan-ble] mac-access-profile wlan-ble
      [AC-authentication-profile-wlan-ble] authentication-scheme wlan-ble
      [AC-authentication-profile-wlan-ble] radius-server wlan-ble
      [AC-authentication-profile-wlan-ble] quit

    4. Configure WLAN service parameters.

      # Create security profile wlan-ble and configure a security policy in the profile. By default, the security policy is open system authentication.

      [AC] wlan
      [AC-wlan-view] security-profile name wlan-ble
      [AC-wlan-sec-prof-wlan-ble] quit
      

      # Create SSID profile wlan-ble and set the SSID name to wlan-ble.

      [AC-wlan-view] ssid-profile name wlan-ble
      [AC-wlan-ssid-prof-wlan-ble] ssid wlan-ble
      [AC-wlan-ssid-prof-wlan-ble] quit
      

      # Create VAP profile wlan-ble, configure the direct data forwarding mode and service VLANs, and bind the security profile, authentication profile, and SSID profile to the VAP profile.

      [AC-wlan-view] vap-profile name wlan-ble
      [AC-wlan-vap-prof-wlan-ble] forward-mode direct-forward
      [AC-wlan-vap-prof-wlan-ble] service-vlan vlan-id 102
      [AC-wlan-vap-prof-wlan-ble] security-profile wlan-ble
      [AC-wlan-vap-prof-wlan-ble] authentication-profile wlan-ble
      [AC-wlan-vap-prof-wlan-ble] ssid-profile wlan-ble
      [AC-wlan-vap-prof-wlan-ble] quit
      

      # Bind the VAP profile to the AP group, and apply configurations of VAP profile wlan-ble to radio 0 of APs in the AP group.

      [AC-wlan-view] ap-group name ap-group1
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-ble wlan 2 radio 0
      [AC-wlan-ap-group-ap-group1] quit
      [AC-wlan-view] quit
      

  8. Configure third-party server interconnection parameters. For details, see the corresponding product manual.
  9. Configure the Bluetooth data transparent transmission function.

    Configure the IP address of the host computer in the app of the tablet kiosk. Enable the Bluetooth function of the tablet kiosk to allow it to receive BLE broadcast packets from the BLE label. The detailed operations are not provided here.

  10. Associate BLE labels with commodities.

    Use the mobile app to scan a commodity barcode and receive BLE label information through Bluetooth to associate the BLE label with the commodity. The detailed operations are not provided here.

  11. Verify the configuration.

    # The WLAN service configuration is automatically delivered to the AP. After completing the configuration, run the display vap ssid wlan-ble and display vap ssid wlan-net commands. If the Status field displays ON, the VAP has been successfully created on the AP radios.
    [AC] display vap ssid wlan-ble
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID    BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    2      60DE-4476-E361 ON      OPEN          1     wlan-ble
    ------------------------------------------------------------------------------------
    Total: 1
    [AC] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID    BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1      60DE-4476-E360 ON      WPA/WPA2-PSK  1     wlan-net
    0     area_1  1    1      60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    ------------------------------------------------------------------------------------
    Total: 2

    # When the commodity with the BLE label is picked up, information about the commodity is displayed on the tablet kiosk.

Configuration Files
  • Access switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 to 102
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 102
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    authentication-profile name wlan-ble
     mac-access-profile wlan-ble
     authentication-scheme wlan-ble
     radius-server wlan-ble
    #
    dhcp enable
    #
    radius-server template wlan-ble
     radius-server shared-key cipher %^%#sx$wASg6*AV+89@"5.H9}E>4LMJ:+/lj$dR2I3F3%^%#
     radius-server authentication 10.23.103.1 1812 weight 80
    #
    aaa
     authentication-scheme wlan-ble
      authentication-mode radius
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-ble
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#<nO>>G!1b8mt7n!OC"vR%2@4Y&E5yQ=QN{.:MP=B%^%# aes
     ssid-profile name wlan-ble
      ssid wlan-ble
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-ble
      service-vlan vlan-id 102
      ssid-profile wlan-ble
      security-profile wlan-ble
      authentication-profile wlan-ble
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
       vap-profile wlan-ble wlan 2
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 ap-mac 60de-4476-e360 ap-sn 210235419610D2000066
      ap-name area_1
      ap-group ap-group1
    #
    mac-access-profile name wlan-ble
    #
    return

Example of Configuring the Shopping Mall and Supermarket IoT Solution - Smart Shopping Guide (With No Tablet Kiosk Installed)

Service Requirements

A shopping mall wants to perform Big Data analytics on customers' actions of picking up commodities, so that it can understand popularity of commodities, make proper marketing strategies, and improve sales profits. Additionally, the shopping mall wants to provide wireless network access for its customers.

To meet these requirements, Huawei provides the smart shopping guide solution with no tablet kiosk installed.

Networking Requirements
  • AC networking mode: Layer 2 in bypass mode
  • DHCP deployment mode: Configure an AC as the DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 28-5  Networking diagram for configuring the smart shopping guide solution
Data Planning
Table 28-4  AC data planning

Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100

DHCP server The AC functions as a DHCP server to assign IP addresses to APs and STAs.

IP address pool for APs

10.23.100.2 to 10.23.100.254/24

IP address pool for STAs

10.23.101.2 to 10.23.101.254/24

AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net, BLE profile wlan-ble, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: CN
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

BLE profile

  • Name: wlan-ble

  • Bluetooth data transparent transmission: enabled

  • Bluetooth packet reporting mode and interval: reporting at an interval of 3 seconds

  • Data reporting mode: directly reported by APs

  • Server IP address/port number: 10.23.102.1/10001

Configuration Roadmap
  1. Configure network interworking of the APs, switch, AC, and host computer.

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

  3. Configure the APs to go online.

  4. Configure WLAN service parameters to provide wireless network services for customers or employees.

  5. Configure the Bluetooth data transparent transmission function.

  6. Associate BLE labels with commodities.

Configuration Notes
  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure the switch and AC to enable the AP to communicate with the AC.

    # Configure the access switch. Add GE0/0/1 on the switch to VLAN 100 (management VLAN), and GE0/0/2 to VLAN 100 and VLAN 101 (service VLANs).

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/2] quit
    

    # Configure the AC. Add GE0/0/1 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure network interworking between the AP and host computer.

    Configure routes based on the actual networking situation to ensure network interworking between the AP and host computer.

  4. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    # Configure the DHCP server based on the address pool of a VLANIF interface.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  5. Configure the AP to go online.

    # Create an AP group to which APs with the same configuration are to be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the country code for the AC in the profile, and bind the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the source interface on the AC.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to the AP group ap-group1. Configure an AP name based on the AP's deployment location, so that you can know where the AP is deployed from its name. If the AP with MAC address 60de-4476-e360 is in area 1, name the AP area_1.
    NOTE:

    The ap auth-mode command sets the AP authentication mode to MAC address authentication by default. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP4050DN-E is used and has two radios: radio 0 and radio 1.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply 
    ----------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime ExtraInfo
    ----------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP4050DN-E      nor   0   25S    -
    ----------------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters to provide wireless network services for customers or employees.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Configure the Bluetooth data transparent transmission function.

    # Create BLE profile wlan-ble. Enable the Bluetooth data transparent transmission function, configure the destination IP address and port number to which Bluetooth data is transparently transmitted, and configure the mode for the AP to transparently transmit Bluetooth data.
    [AC-wlan-view] ble-profile name wlan-ble
    [AC-wlan-ble-prof-wlan-ble] sniffer enable transparent-mode
    [AC-wlan-ble-prof-wlan-ble] report enable
    [AC-wlan-ble-prof-wlan-ble] report-to-server ip-address 10.23.102.1 port 10001
    [AC-wlan-ble-prof-wlan-ble] report-mode periodic interval 3
    [AC-wlan-ble-prof-wlan-ble] quit
    
    # Add BLE clients within the AP's coverage area to the monitoring list.
    [AC-wlan-view] ble monitoring-list mac 1234-1234-1000 to 1234-1234-1002
    
    # Apply the BLE profile to the AP group.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] ble-profile wlan-ble
    [AC-wlan-ap-group-ap-group1] quit

  8. Associate BLE labels with commodities.

    Use the mobile app to scan a commodity barcode and receive BLE label information through Bluetooth to associate the BLE label with the commodity. The detailed operations are not provided here.

  9. Verify the configuration.

    # After the AP obtains Bluetooth client information, run the display wlan ble site-info all command to check Bluetooth client information obtained by the AP.

    [AC-wlan-view] display wlan ble site-info all
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    Index  MAC             Host AP ID Host AP name RSSI  Power Type       DetachedFlag Aging-Timeout(m)  Broadcast count Advertisement d
    ata
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    0      1234-1234-1000  0          area_1       -30   50%   sensor-tag N            57                10              02-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    1      1234-1234-1001  0          area_1       -31   51%   sensor-tag N            57                7               01-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    2      1234-1234-1002  0          area_1       -33   55%   sensor-tag N            57                16              03-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    Total: 3
    

    # The WLAN service configuration is automatically delivered to the AP. After completing the configuration, run the display vap ssid wlan-net command. If the Status field displays ON, the VAP has been successfully created on the AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    ------------------------------------------------------------------------------------
    AP ID AP name        RfID WID  BSSID          Status  Auth type         STA  SSID
    ------------------------------------------------------------------------------------
    0     area_1         0    1    60DE-4476-E360 ON      WPA/WPA2-PSK      1    wlan-net 
    0     area_1         1    1    60DE-4476-E370 ON      WPA/WPA2-PSK      0    wlan-net 
    ------------------------------------------------------------------------------------
    Total: 2

Configuration Files
  • Access switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#;LgD%=-_`Sr(`u1]DT!Xg2/"/kXHs2/z>nGs-yI1%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ble-profile name wlan-ble
      sniffer enable transparent-mode
      report-mode periodic interval 3
      report-to-server ip-address 10.23.102.1 port 10001
      report enable
     ble monitoring-list mac 1234-1234-1000
     ble monitoring-list mac 1234-1234-1001
     ble monitoring-list mac 1234-1234-1002
     ap-group name ap-group1
      ble-profile wlan-ble
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 ap-mac 60de-4476-e360 ap-sn 210235419610D2000066
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 127855

Downloads: 383

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next