No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring External Portal Authentication

Example for Configuring External Portal Authentication

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. Then the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 11-18, there are a large number of STAs on an enterprise network. A WLAN with the SSID guest is deployed in the lobby of the office building to provide wireless access services for guests. A WLAN with the SSID employee is deployed in office areas to provide wireless access services for employees.

To ensure network security, the enterprise needs to deploy an authentication system to implement access control for all the wireless users who attempt to connect to the enterprise network. Only authenticated users can connect to the enterprise network. Considering the mobility feature of a large number of STAs, the administrator decides to configure Portal authentication on the AC at Layer 3 network to control access.

Figure 11-18  Networking diagram for configuring External Portal authentication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic WLAN services so that the AC can communicate with upper-layer and lower-layer devices and the AP can go online.
  2. Configure RADIUS authentication parameters.
  3. Configure a Portal server profile.
  4. Configure a Portal access profile to manage access control parameters for Portal authentication users.
  5. Configure an authentication-free rule profile so that the AC allows packets to the DNS server to pass through.
  6. Configure an authentication profile to manage NAC configuration.
  7. Configure WLAN service parameters for STAs to access the WLAN.
Table 11-10  Data plan

Item

Data

RADIUS authentication parameters

Name of the RADIUS authentication scheme: radius_huawei

Name of the RADIUS server template: radius_huawei

  • IP address: 172.16.1.1
  • Authentication port number: 1812
  • Shared key: Huawei@123

AAA domain: huawei.com

Portal server profile
  • Name: abc
  • IP address: 172.16.1.1
  • Destination port number in the packets that the AC sends to the Portal server: 50200
  • Portal shared key: Admin@123
Portal access profile
  • Name: portal1

  • Bound profile: Portal server profile abc

Authentication-free rule profile
  • Name: default_free_rule
  • Authentication-free resource: IP address of the DNS server (172.16.1.2)
Authentication profile
  • Name: p1
  • Bound profile: Portal access profile p1, and authentication-free rule profile default_free_rule
  • Forcible authentication domain: huawei.com
DHCP server The router functions as the DHCP server to assign IP addresses to the STAs and APs.
IP address pool for the APs 10.23.100.2 to 10.23.100.254/24
IP address pool for the STAs

10.23.101.2 to 10.23.101.254/24

10.23.102.2 to 10.23.102.254/24

VLAN pool

Name: sta-pool

VLANs added to the VLAN pool: VLAN 101 and VLAN 102

IP address of the AC's source interface VLANIF100: 10.45.200.1/24
AP group

Name: guest

Bound profile: VAP profile guest and regulatory domain profile domain1

Name: employee

Bound profile: VAP profile employee and regulatory domain profile domain1

Regulatory domain profile

Name: domain1

Country code: CN

SSID profile

Name: guest

SSID name: guest

Name: employee

SSID name: employee

Security profile
  • Name: wlan-security
  • Security policy: Open
VAP profile

Name: guest

  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLANs in the VLAN pool
  • Bound profile: SSID profile guest, security profile wlan-security, and authentication profile p1

Name: employee

  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLANs in the VLAN pool
  • Bound profile: SSID profile employee, security profile wlan-security, and authentication profile p1
NOTE:
  • In this example, Switch_A is a Huawei modular switch, and Switch_B is a Huawei fixed switch.

  • When a VLAN pool is used to provide service VLANs on a large network, many VLANs are usually added to the VLAN pool, and interfaces of many devices need to be added to these VLANs. In this situation, a lot of broadcast domains are created if you configure the direct forwarding mode. To reduce the number of broadcast domains, set the data forwarding mode to tunnel forwarding.

  • Configurations of RADIUS server parameters and Portal server parameters must be the same as the configurations on the peer RADIUS server and Portal server. Configure the parameters as required.
  • To ensure that the router and servers can communicate with each other, configure routes on the RADIUS server and Portal server to the router.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure networking parameters.

    # Configure access switch Switch_A. Add GE0/0/1 to GE0/0/5 to VLAN 100 (management VLAN). Interfaces GE0/0/1 to GE0/0/4 have the same configuration. GE0/0/1 is used as an example here.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_A
    [Switch_A] vlan batch 100
    [Switch_A] interface gigabitethernet 0/0/1
    [Switch_A-GigabitEthernet0/0/1] port link-type trunk
    [Switch_A-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_A-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch_A-GigabitEthernet0/0/1] port-isolate enable
    [Switch_A-GigabitEthernet0/0/1] quit
    [Switch_A] interface gigabitethernet 0/0/5
    [Switch_A-GigabitEthernet0/0/5] port link-type trunk
    [Switch_A-GigabitEthernet0/0/5] port trunk allow-pass vlan 100
    [Switch_A-GigabitEthernet0/0/5] quit
    

    # Configure aggregation switch Switch_B. Add GE1/0/1 to VLAN 100, GE1/0/2 to VLANs 101, 102, and 200, and GE1/0/3 to VLAN 201.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_B
    [Switch_B] vlan batch 100 101 102 200 201
    [Switch_B] interface gigabitethernet 1/0/1
    [Switch_B-GigabitEthernet1/0/1] port link-type trunk
    [Switch_B-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch_B-GigabitEthernet1/0/1] quit
    [Switch_B] interface gigabitethernet 1/0/2
    [Switch_B-GigabitEthernet1/0/2] port link-type trunk
    [Switch_B-GigabitEthernet1/0/2] port trunk allow-pass vlan 101 102 200
    [Switch_B-GigabitEthernet1/0/2] quit
    [Switch_B] interface gigabitethernet 1/0/3
    [Switch_B-GigabitEthernet1/0/3] port link-type trunk
    [Switch_B-GigabitEthernet1/0/3] port trunk allow-pass vlan 201
    [Switch_B-GigabitEthernet1/0/3] quit
    

    # Create VLANIF interfaces VLANIF 100 to VLANIF 102, VLANIF 200, and VLANIF 201 on Switch_B and configure their IP addresses. VLANIF 100 works as the gateway of APs. VLANIF 101 and VLANIF 102 are gateways of STAs. Switch_B uses VLANIF 200 to communicate with the AC and VLANIF 201 to communicate with the router.

    [Switch_B] interface vlanif 100
    [Switch_B-Vlanif100] ip address 10.23.100.1 24
    [Switch_B-Vlanif100] quit
    [Switch_B] interface vlanif 101
    [Switch_B-Vlanif101] ip address 10.23.101.1 24
    [Switch_B-Vlanif101] quit
    [Switch_B] interface vlanif 102
    [Switch_B-Vlanif102] ip address 10.23.102.1 24
    [Switch_B-Vlanif102] quit
    [Switch_B] interface vlanif 200
    [Switch_B-Vlanif200] ip address 10.45.200.2 24
    [Switch_B-Vlanif200] quit
    [Switch_B] interface vlanif 201
    [Switch_B-Vlanif201] ip address 10.67.201.2 24
    [Switch_B-Vlanif201] quit
    

    # On the AC, add GE0/0/1 connected to Switch_B to VLAN 101, VLAN 102, and VLAN 200.

    [HUAWEI] sysname AC
    [AC] vlan batch 101 102 200
    [AC] interface vlanif 200
    [AC-Vlanif200] ip address 10.45.200.1 24
    [AC-Vlanif200] quit
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 101 102 200
    [AC-GigabitEthernet0/0/1] quit
    

    # Add GE2/0/0 on the router to VLAN 201 and configure an IP address for VLANIF 201 so that the router can communicate with Switch_B.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 201
    [Router] interface vlanif 201
    [Router-Vlanif201] ip address 10.67.201.1 24
    [Router-Vlanif201] quit
    [Router] interface gigabitethernet 2/0/0
    [Router-GigabitEthernet2/0/0] port link-type trunk
    [Router-GigabitEthernet2/0/0] port trunk allow-pass vlan 201
    [Router-GigabitEthernet2/0/0] quit
    
    # On the router, configure a route to Switch_B.
    [Router] ip route-static 10.23.100.0 24 10.67.201.2
    [Router] ip route-static 10.23.101.0 24 10.67.201.2
    [Router] ip route-static 10.23.102.0 24 10.67.201.2
    

    # Configure a default route on Switch_B with the outbound interface as the router's VLANIF 201.

    [Switch_B] ip route-static 0.0.0.0 0.0.0.0 10.67.201.1
    
    # Configure routes from the AC to APs with the next hop as Switch_B's VLANIF 200.
    [AC] ip route-static 10.23.100.0 24 10.45.200.2
    

  3. Configure a DHCP server to assign IP addresses to APs and STAs.

    # Configure Switch_B as a DHCP relay agent.

    [Switch_B] dhcp enable
    [Switch_B] interface vlanif 100
    [Switch_B-Vlanif100] dhcp select relay
    [Switch_B-Vlanif100] dhcp relay server-ip 10.67.201.1
    [Switch_B-Vlanif100] quit
    [Switch_B] interface vlanif 101
    [Switch_B-Vlanif101] dhcp select relay
    [Switch_B-Vlanif101] dhcp relay server-ip 10.67.201.1
    [Switch_B-Vlanif101] quit
    [Switch_B] interface vlanif 102
    [Switch_B-Vlanif102] dhcp select relay
    [Switch_B-Vlanif102] dhcp relay server-ip 10.67.201.1
    [Switch_B-Vlanif102] quit
    

    # Configure the router as a DHCP server to assign IP addresses to APs and STAs.

    NOTE:
    In this example, the AP and AC are on different network segments. To notify the AP of the AC's IP address so that the AP can go online at Layer 3, configure Option 43 in the address pool used by the AP.
    [Router] dhcp enable
    [Router] ip pool ap
    [Router-ip-pool-ap] network 10.23.100.0 mask 24
    [Router-ip-pool-ap] gateway-list 10.23.100.1
    [Router-ip-pool-ap] option 43 sub-option 3 ascii 10.45.200.1
    [Router-ip-pool-ap] quit
    [Router] ip pool sta1
    [Router-ip-pool-sta1] network 10.23.101.0 mask 24
    [Router-ip-pool-sta1] gateway-list 10.23.101.1
    [Router-ip-pool-sta1] dns-list 172.16.1.2
    [Router-ip-pool-sta1] quit
    [Router] ip pool sta2
    [Router-ip-pool-sta2] network 10.23.102.0 mask 24
    [Router-ip-pool-sta2] gateway-list 10.23.102.1
    [Router-ip-pool-sta2] dns-list 172.16.1.2
    [Router-ip-pool-sta2] quit
    [Router] interface vlanif 201
    [Router-Vlanif201] dhcp select global
    [Router-Vlanif201] quit
    

  4. Configure a VLAN pool for service VLANs.

    # Create a VLAN pool, add VLAN 101 and VLAN 102 to the pool, and set the VLAN assignment algorithm to hash in the VLAN pool.

    NOTE:

    This example uses the VLAN assignment algorithm hash as an example. The default VLAN assignment algorithm is hash. If the default setting is retained, you do not need to run the assignment hash command.

    In this example, only VLAN 101 and VLAN 102 are added to the VLAN pool. You can add multiple VLANs to a VLAN pool. Similar to adding VLAN 101 and VLAN 102 to a VLAN pool, you need to create corresponding VLANIF interfaces and configure IP addresses on Switch_B, and configure interface address pools on the router.

    [AC] vlan pool sta-pool
    [AC-vlan-pool-sta-pool] vlan 101 102
    [AC-vlan-pool-sta-pool] assignment hash
    [AC-vlan-pool-sta-pool] quit
    

  5. Configure the APs to go online.

    # Create AP groups guest and employee.

    [AC] wlan
    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-employee] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 200
    
    # Import the APs offline on the AC. Add APs deployed in the lobby to AP group guest and APs in office areas to AP group employee. Configure names for the APs based on the APs' deployment locations, so that you can know where the APs are deployed from their names. For example, if the AP with MAC address 60de-4474-9640 is deployed in room 1 of the second floor of the office building, name the AP office2-1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP6010DN-AGN is used and has two radios: radio 0 and radio 1.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name lobby-1
    [AC-wlan-ap-0] ap-group guest
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4476-e380
    [AC-wlan-ap-1] ap-name lobby-2
    [AC-wlan-ap-1] ap-group guest
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    [AC-wlan-view] ap-id 2 ap-mac 60de-4474-9640
    [AC-wlan-ap-2] ap-name office2-1
    [AC-wlan-ap-2] ap-group employee
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-2] quit
    [AC-wlan-view] ap-id 3 ap-mac 60de-4474-9660
    [AC-wlan-ap-3] ap-name office2-2
    [AC-wlan-ap-3] ap-group employee
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-3] quit
    [AC-wlan-view] quit
    

    # After an AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC] display ap all
    Total AP information:
    nor  : normal          [4]
    Extra information:
    P  : insufficient power supply
    ----------------------------------------------------------------------------------------------------
    ID   MAC            Name      Group    IP            Type            State STA Uptime      ExtraInfo
    ----------------------------------------------------------------------------------------------------
    0    60de-4474-9640 office2-1 employee 10.23.100.253 AP5030DN        nor   0   2H:30M:1S   -
    1    60de-4474-9660 office2-2 employee 10.23.100.251 AP5030DN        nor   0   2H:35M:2S   -
    2    60de-4476-e360 lobby-1   guest    10.23.100.254 AP5030DN        nor   0   2H:29M:29S   -
    3    60de-4476-e380 lobby-2   guest    10.23.100.252 AP5030DN        nor   0   2H:34M:11S   -
    ----------------------------------------------------------------------------------------------------
    Total: 4

  6. Configure a RADIUS server template, and a RADIUS authentication scheme.

    # Configure a RADIUS server template.

    [AC] radius-server template radius_huawei
    [AC-radius-radius_huawei] radius-server authentication 172.16.1.1 1812
    [AC-radius-radius_huawei] radius-server shared-key cipher Huawei@123
    [AC-radius-radius_huawei] quit

    # Configure a RADIUS authentication scheme.

    [AC] aaa
    [AC-aaa] authentication-scheme radius_huawei
    [AC-aaa-authen-radius_huawei] authentication-mode radius
    [AC-aaa-authen-radius_huawei] quit
    

    # Create an AAA domain and configure the RADIUS server template and authentication scheme.

    [AC-aaa] domain huawei.com
    [AC-aaa-domain-huawei.com] radius-server radius_huawei
    [AC-aaa-domain-huawei.com] authentication-scheme radius_huawei
    [AC-aaa-domain-huawei.com] quit
    [AC-aaa] quit
    

  7. Configure a Portal server profile.

    [AC] web-auth-server abc
    [AC-web-auth-server-abc] server-ip 172.16.1.1
    [AC-web-auth-server-abc] shared-key cipher Admin@123
    [AC-web-auth-server-abc] port 50200 
    [AC-web-auth-server-abc] url https://172.16.1.1:8443/webauth
    [AC-web-auth-server-abc] quit

  8. Configure the Portal access profile portal1.

    [AC] portal-access-profile name portal1
    [AC-portal-access-profile-portal1] web-auth-server abc layer3
    [AC-portal-access-profile-portal1] quit

  9. Configure an authentication-free rule profile.

    [AC] free-rule-template name default_free_rule
    [AC-free-rule-default_free_rule] free-rule 1 destination ip 172.16.1.2 mask 24
    [AC-free-rule-default_free_rule] quit
    

  10. Configure the authentication profile p1.

    [AC] authentication-profile name p1
    [AC-authen-profile-p1] portal-access-profile portal1
    [AC-authen-profile-p1] free-rule-template default_free_rule
    [AC-authen-profile-p1] access-domain huawei.com portal force
    [AC-authen-profile-p1] quit

  11. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile. By default, the security policy is open system.

    [AC] wlan
    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profiles guest and employee, and set the SSID names to guest and employee, respectively.

    [AC-wlan-view] ssid-profile name guest
    [AC-wlan-ssid-prof-guest] ssid guest
    [AC-wlan-ssid-prof-guest] quit
    [AC-wlan-view] ssid-profile name employee
    [AC-wlan-ssid-prof-employee] ssid employee
    [AC-wlan-ssid-prof-employee] quit
    

    # Create VAP profiles guest and employee, set the data forwarding mode and service VLANs, and apply the security profiles and SSID profiles to the VAP profiles.

    [AC-wlan-view] vap-profile name guest
    [AC-wlan-vap-prof-guest] forward-mode tunnel
    [AC-wlan-vap-prof-guest] service-vlan vlan-pool sta-pool
    [AC-wlan-vap-prof-guest] security-profile wlan-security
    [AC-wlan-vap-prof-guest] ssid-profile guest
    [AC-wlan-vap-prof-guest] authentication-profile p1
    [AC-wlan-vap-prof-guest] quit
    [AC-wlan-view] vap-profile name employee
    [AC-wlan-vap-prof-employee] forward-mode tunnel
    [AC-wlan-vap-prof-employee] service-vlan vlan-pool sta-pool
    [AC-wlan-vap-prof-employee] security-profile wlan-security
    [AC-wlan-vap-prof-employee] ssid-profile employee
    [AC-wlan-vap-prof-employee] authentication-profile p1
    [AC-wlan-vap-prof-employee] quit
    

    # Bind VAP profiles to the AP groups and apply the VAP profiles to radio 0 and radio 1 of the APs.

    [AC-wlan-view] ap-group name guest
    [AC-wlan-ap-group-guest] vap-profile guest wlan 1 radio all
    [AC-wlan-ap-group-guest] quit
    [AC-wlan-view] ap-group name employee
    [AC-wlan-ap-group-employee] vap-profile employee wlan 1 radio 0
    [AC-wlan-ap-group-employee] vap-profile employee wlan 1 radio 1
    [AC-wlan-ap-group-employee] quit
    

  12. Set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  13. Verify the configuration.

    • After the configuration is complete, the WLAN with the SSID guest is available for STAs in the lobby and the WLAN with the SSID employee is available for STAs in office areas.
    • The STAs obtain IP addresses when they successfully associate with the WLAN.
    • When a user opens the browser and attempts to access the network, the user is automatically redirected to the authentication page provided by the external Portal server. After entering the correct user name and password on the page, the user can access the network.

Configuration Files

  • Switch_A configuration file

    #
    sysname Switch_A
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Switch_B configuration file

    #
    sysname Switch_B
    #
    vlan batch 100 to 102 200 201
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.67.201.1
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.67.201.1
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.67.201.1
    #
    interface Vlanif200
     ip address 10.45.200.2 255.255.255.0
    #
    interface Vlanif201
     ip address 10.67.201.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 101 to 102 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    ip route-static 0.0.0.0 0.0.0.0 10.67.201.1
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 201
    #
    dhcp enable
    #
    ip pool ap
     gateway-list 10.23.100.1 
     network 10.23.100.0 mask 255.255.255.0 
     option 43 sub-option 3 ascii 10.45.200.1 
    #
    ip pool sta1
     gateway-list 10.23.101.1 
     network 10.23.101.0 mask 255.255.255.0 
     dns-list 172.16.1.2
    #
    ip pool sta2
     gateway-list 10.23.102.1 
     network 10.23.102.0 mask 255.255.255.0 
     dns-list 172.16.1.2
    #
    interface Vlanif201
     ip address 10.67.201.1 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    ip route-static 10.23.100.0 255.255.255.0 10.67.201.2
    ip route-static 10.23.101.0 255.255.255.0 10.67.201.2
    ip route-static 10.23.102.0 255.255.255.0 10.67.201.2
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 101 to 102 200
    #
    authentication-profile name p1
     portal-access-profile portal1
     free-rule-template default_free_rule
     access-domain huawei.com portal force
    #
    vlan pool sta-pool
     vlan 101 to 102
    #
    radius-server template radius_huawei                                                                                                
     radius-server shared-key cipher %^%#Ug1l9V#SI(JTFp+*)J7<%CUQB(74-4vSIKO!x:NI%^%#                                                   
     radius-server authentication 172.16.1.1 1812 weight 80                                                                            
    #
    free-rule-template name default_free_rule                                                                                           
     free-rule 1 destination ip 172.16.1.2 mask 255.255.255.0                                                                          
    # 
    web-auth-server abc                                                                                                                 
     server-ip 172.16.1.1                                                                                                              
     port 50200                                                                                                                         
     shared-key cipher %^%#4~ZXE3]6@BXu;2;aw}hA{rSb,@"L@T#e{%6G1AiD%^%#                                                                 
     url https://172.16.1.1:8443/webauth                                                                                               
    #
    portal-access-profile name portal1                                                                                                  
     web-auth-server abc layer3                                                                                                         
    #
    aaa
     authentication-scheme radius_huawei                                                                                                
      authentication-mode radius
     domain huawei.com
      authentication-scheme radius_huawei
      radius-server radius_huawei
    #
    interface Vlanif200
     ip address 10.45.200.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101 to 102 200
    #
    ip route-static 10.23.100.0 255.255.255.0 10.45.200.2
    #
    capwap source interface vlanif200
    #
    wlan
     security-profile name wlan-security
     ssid-profile name guest
      ssid guest
     ssid-profile name employee
      ssid employee
     vap-profile name guest
      forward-mode tunnel
      service-vlan vlan-pool sta-pool
      ssid-profile guest
      security-profile wlan-security
      authentication-profile p1
     vap-profile name employee
      forward-mode tunnel
      service-vlan vlan-pool sta-pool
      ssid-profile employee
      security-profile wlan-security
      authentication-profile p1
     regulatory-domain-profile name domain1
     ap-group name guest
      regulatory-domain-profile domain1
      radio 0
       vap-profile guest wlan 1
      radio 1
       vap-profile guest wlan 1
     ap-group name employee
      regulatory-domain-profile domain1
      radio 0
       vap-profile employee wlan 1
      radio 1
       vap-profile employee wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name lobby-1
      ap-group guest
     ap-id 1 type-id 19 ap-mac 60de-4476-e380 ap-sn 210235419610D2000066
      ap-name lobby-2
      ap-group guest
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
     ap-id 2 type-id 19 ap-mac 60de-4474-9640 ap-sn 210235554710CB000075
      ap-name office2-1
      ap-group employee
     ap-id 3 type-id 19 ap-mac 60de-4474-9660 ap-sn 210235419610D2000097
      ap-name office2-2
      ap-group employee
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 125878

Downloads: 382

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next