No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast CAC Based on Multicast Bandwidth

Example for Configuring Multicast CAC Based on Multicast Bandwidth

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. Then the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Context

As shown in Figure 20-1, enterprise users can access the Internet through the WLAN to meet the basic requirement of mobile office.

Video conference multicast sources are deployed on the WLAN to specially provide video conference services. The multicast source IP address ranges from 225.1.1.1 to 225.1.1.5. The administrator wants to configure multicast connection admission control (CAC) based on multicast bandwidth to deny access of employees when the multicast bandwidth reaches the upper limit, ensuring access quality of video conferences.

Figure 20-1  Networking for configuring multicast CAC based on multicast bandwidth

Configuration Roadmap

  1. Configure basic WLAN services to ensure that users can access the WLAN.

  2. Configure the multicast-to-unicast function to convert multicast data packets to unicast data packets, improving multicast data transmission efficiency.

  3. Configure multicast CAC based on the multicast bandwidth to control access of multicast users.

Table 20-4  Data planning

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to STAs and APs.
IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-vap, regulatory domain profile domain1, and AP system profile ap-system
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security, and traffic profile wlan-traffic
IP address segment of multicast groups

225.1.1.1-225.1.1.5

Traffic profile
  • Name: wlan-traffic
  • Maximum multicast bandwidth of a VAP: 40 Mbit/s (40,960 kbit/s)
AP system profile
  • Name: ap-system
  • Bandwidth of global multicast groups on an AP: 2 Mbit/s (2048 kbit/s)

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure SwitchA and the AC so that the AP and AC can transmit CAPWAP packets.

    # Add GE0/0/1 that connects SwitchA to the AP to management VLAN 100 and add GE0/0/2 that connects SwitchA to the AC to the same VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Add GE0/0/1 that connects the AC to SwitchA to VLAN 100.

    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the AC to communicate with the upstream device.

    NOTE:

    Configure AC uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AC uplink interface GE0/0/2 to service VLAN 101.

    [AC] interface gigabitethernet 0/0/2
    [AC-GigabitEthernet0/0/2] port link-type trunk
    [AC-GigabitEthernet0/0/2] port trunk allow-pass vlan 101
    [AC-GigabitEthernet0/0/2] quit
    

  4. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  5. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio all
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  8. Configure the multicast-to-unicast function.

    # Create traffic profile wlan-traffic, and enable the Internet Group Management Protocol (IGMP) snooping and multicast-to-unicast functions in the traffic profile.
    [AC-wlan-view] traffic-profile name wlan-traffic
    [AC-wlan-traffic-prof-wlan-traffic] igmp-snooping enable
    [AC-wlan-traffic-prof-wlan-traffic] traffic-optimize multicast-unicast enable
    

  9. Configure broadcast CAC based on broadcast bandwidth.

    # Configure the maximum multicast bandwidth to 40960 kbit/s for a VAP.

    [AC-wlan-traffic-prof-wlan-traffic] igmp-snooping max-bandwidth 40960
    [AC-wlan-traffic-prof-wlan-traffic] quit
    

    # Bind traffic profile wlan-traffic to VAP profile wlan-vap.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] traffic-profile wlan-traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-vap-prof-wlan-vap] quit

    # Create AP system profile ap-system and configure the bandwidth to 2048 kbit/s for the IP address segment of multicast groups ranging from 225.1.1.1 to 225.1.1.5.

    [AC-wlan-view] ap-system-profile name ap-system
    [AC-wlan-ap-system-prof-ap-system] igmp-snooping group-bandwidth start-group-address 225.1.1.1 end-group-address 225.1.1.5 bandwidth 2048
    [AC-wlan-ap-system-prof-ap-system] quit
    

    # Bind AP system profile ap-system to AP group ap-group1.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] ap-system-profile ap-system
    [AC-wlan-ap-group-ap-group1] quit

  10. Verify the configuration.

    Run the display wlan igmp-snooping vap-cac command on the AC to check the multicast CAC configuration and statistics on the VAP. When the difference between the CurBw and MaxBw values is smaller than the configured bandwidth of a multicast group, new users cannot join the multicast group.

    [AC-wlan-view] display wlan igmp-snooping vap-cac ap-id 0
    Info: This operation may take a few seconds, please wait.done.
    Rf            : Radio ID                  WID             : WLAN ID
    CurBw         : Current bandwidth(kbps)   MaxBw           : Max bandwidth(kbps)
    CurUser       : Current user number       MaxUser         : Max user number
    BwUtilization : Bandwidth utilization     UserUtilization : User utilization
    --------------------------------------------------------------------------------
    Rf  WID  CurBw/MaxBw        BwUtilization  CurUser/MaxUser  UserUtilization
    --------------------------------------------------------------------------------
    0   1    0/40960            0%             0/0              0%
    1   1    0/40960            0%             0/0              0%
    --------------------------------------------------------------------------------
    Total: 2

Configuration Files

  • SwitchA configuration file
    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    capwap source interface vlanif100
    #
    wlan
     traffic-profile name wlan-traffic 
      igmp-snooping enable
      igmp-snooping max-bandwidth 40960
      traffic-optimize multicast-unicast enable
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile wlan-traffic
     regulatory-domain-profile name domain1
     rrm-profile name default
      calibrate auto-channel-select disable
      calibrate auto-txpower-select disable
     ap-system-profile name ap-system
      igmp-snooping group-bandwidth start-group-address 225.1.1.1 end-group-address 225.1.1.5 bandwidth 2048
     ap-group name ap-group1
      ap-system-profile ap-system 
      regulatory-domain-profile domain1
      radio 0
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 160859

Downloads: 445

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next