No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Shopping Mall and Supermarket IoT Solution - Indoor Navigation

Example for Configuring the Shopping Mall and Supermarket IoT Solution - Indoor Navigation

Service Requirements

In a shopping mall with large areas and complex environment, it is difficult for customers to find parked cars and shops. To help customers to easily find shops or parked cars, improve customer satisfaction, and promote customers' buying intention, the shopping mall expects to provide navigation services.

To meet these requirements of the shopping mall, Huawei provides the indoor navigation solution. This solution provides customers with easy and secure Wi-Fi network access and improves customers' network experience. Additionally, an indoor navigation app is provided for customers to find shops or parked cars, improving customer satisfaction.

Networking Requirements

  • AC networking mode: Layer 2 in bypass mode
  • DHCP deployment mode: Configure an AC as the DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 30-4  Network for configuring indoor navigation

Data Planning

Table 30-2  Data planning

Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100

DHCP server The AC functions as a DHCP server to assign IP addresses to APs and STAs.
IP address pool for STAs

10.23.101.2 to 10.23.101.254/24

AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net, regulatory domain profile default, and BLE profile wlan-ble
Regulatory domain profile
  • Name: default
  • Country code: CN
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

BLE Profile

  • Name: wlan-ble

  • Bluetooth monitoring function of APs' built-in Bluetooth modules: enabled
  • Bluetooth broadcast function of APs' built-in Bluetooth modules: enabled

Configuration Roadmap

  1. Configure network interworking between the AC and location server, and between the location server and app server.

  2. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

  3. Configure the APs to go online.

  4. Configure WLAN services.

  5. Configure the Bluetooth terminal location function.

  6. Configure the location server.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure network interworking between the AC and location server, and between the location server and app server.

    Configure routes based on the actual networking to ensure network interworking.

  3. Configure the switch and AC to enable APs to communicate with the AC.

    # Configure the access switch. Add GE0/0/1 on the switch to VLAN 100, and GE0/0/2 through GE0/0/4 to VLAN 100 and VLAN 101.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 to 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type trunk
    [Switch-GigabitEthernet0/0/4] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/4] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/4] quit
    

    # Configure the AC. Add GE0/0/1 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 to 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  4. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    # Configure the DHCP server based on the address pool of a VLANIF interface.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  5. Configure the APs to go online.

    # Create an AP group to which APs with the same configuration are to be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the country code for the AC in the profile, and bind the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the source interface on the AC.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to the AP group ap-group1. Configure an AP name based on the AP's deployment location, so that you can know where the AP is deployed from its name. If the AP with MAC address 60de-4476-e360 is in area 1, name the AP area_1. Add the APs to area_2 and area_3 in the same way.
    NOTE:

    The ap auth-mode command sets the AP authentication mode to MAC address authentication by default. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP4050DN-E is used and has two radios: radio 0 and radio 1.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4476-e380
    [AC-wlan-ap-1] ap-name area_2
    Warning: This operation may cause AP reset. Continue? [Y/N]:y
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    [AC-wlan-view] ap-id 2 ap-mac 60de-4476-e3a0
    [AC-wlan-ap-2] ap-name area_3
    Warning: This operation may cause AP reset. Continue? [Y/N]:y
    [AC-wlan-ap-2] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-2] quit
    

    # After the APs are powered on, run the display ap all command to check the AP states. If the State field displays nor, the APs have gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [3]
    Extra information:
    P  : insufficient power supply 
    ----------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime ExtraInfo
    ----------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP4050DN-E      nor   0   22S    -
    1    60de-4476-e380 area_2 ap-group1 10.23.100.253 AP4050DN-E      nor   0   51S    -
    2    60de-4476-e3a0 area_3 ap-group1 10.23.100.252 AP4050DN-E      nor   0   55S    -
    ----------------------------------------------------------------------------------------------
    Total: 3
    

  6. Configure WLAN services.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Configure the Bluetooth terminal location function.

    # Create BLE profile wlan-ble and configure the Bluetooth location function.
    [AC-wlan-view] ble-profile name wlan-ble
    [AC-wlan-ble-prof-wlan-ble] sniffer enable ibeacon-mode
    [AC-wlan-ble-prof-wlan-ble] broadcaster enable
    [AC-wlan-ble-prof-wlan-ble] quit
    
    # Add the BLE devices within the AP's coverage area to the monitoring list.
    [AC-wlan-view] ble monitoring-list mac 1234-1234-1000 to 1234-1234-1002
    
    # Apply the BLE profile to the AP group.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] ble-profile wlan-ble
    [AC-wlan-ap-group-ap-group1] quit

  8. Configure the location server.

    Configure Bluetooth terminal location parameters on the location server.

  9. Verify the configuration.

    # The WLAN service configuration is automatically delivered to the APs. After completing the configuration, run the display vap ssid wlan-net command. If the Status field displays ON, the VAP has been successfully created on the AP radios.
    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID    BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1      60DE-4476-E360 ON      WPA/WPA2-PSK  1     wlan-net
    0     area_1  1    1      60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    1     area_2  0    1      60DE-4476-E380 ON      WPA/WPA2-PSK  1     wlan-net
    1     area_2  1    1      60DE-4476-E390 ON      WPA/WPA2-PSK  0     wlan-net
    2     area_3  0    1      60DE-4476-E3a0 ON      WPA/WPA2-PSK  1     wlan-net
    2     area_3  1    1      60DE-4476-E3b0 ON      WPA/WPA2-PSK  0     wlan-net
    ------------------------------------------------------------------------------------
    Total: 6
    
    # Check Bluetooth tag information obtained by the APs.
    [AC-wlan-view] display wlan ble site-info all
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    Index  MAC             Host AP ID Host AP name RSSI  Power Type       DetachedFlag Aging-Timeout(m)  Broadcast count Advertisement d
    ata
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    0      1234-1234-1000  0          area_1       -30   50%   ibeacon    N            57                10              02-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    1      1234-1234-1001  1          area_2       -31   51%   ibeacon    N            57                10              01-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    2      1234-1234-1002  2          area_3       -32   55%   ibeacon    N            57                10              03-02-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-fa
    ------------------------------------------------------------------------------------------------------------------------------------
    ---------------
    Total: 3

    # A Bluetooth terminal can discover the wireless network with the SSID wlan-net, and can associate with it after successful authentication. After opening the indoor navigation app and obtaining location information from the app server, you can use the car seeking and shop seeking functions.

Configuration Files

  • Access switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#.s:$0fYX$<HdNy8PVSOXjJ+o#IwB{Hd5toDo)`F$%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ble-profile name wlan-ble
      broadcaster enable
      sniffer enable ibeacon-mode
     ble monitoring-list mac 1234-1234-1000
     ble monitoring-list mac 1234-1234-1001
     ble monitoring-list mac 1234-1234-1002
     ap-group name ap-group1
      ble-profile wlan-ble
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 ap-mac 60de-4476-e360 ap-sn 210235419610D2000066
      ap-name area_1
      ap-group ap-group1
     ap-id 1 ap-mac 60de-4476-e380 ap-sn 210235419610D2000067
      ap-name area_2
      ap-group ap-group1
     ap-id 2 ap-mac 60de-4476-e3a0 ap-sn 210235419610D2000068
      ap-name area_3
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 160943

Downloads: 445

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next