No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - WLAN-AC

S5700 and S6720 V200R012C00

This document describes the configurations of WLAN, including WLAN Service Configuration, Radio Resource Management, Roaming, WLAN QoS, WLAN Security, WDS, Mesh, Location, Hotspot 2.0, Dual-Link Cold Backup, N+1 Backup.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Airtime Fair Scheduling

Example for Configuring Airtime Fair Scheduling

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. Then the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 9-17, the AP is directly connected to the AC. An enterprise branch needs to deploy basic WLAN services for mobile office so that branch users can access internal network resources anywhere at any time.

The enterprise network administrator expects that users can be assigned equal bandwidth occupation time so that the overall user experience can be improved.

Figure 9-17  Networking diagram for configuring airtime fair scheduling

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic WLAN services so that users can connect to the wireless network.
  2. Enable airtime fair scheduling to ensure that users on the same radio have equal bandwidth occupation time to improve user experience.
Table 9-16  Data planning

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to the STAs and AP.
IP address pool for the AP 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap, regulatory domain profile domain1 and 2G radio profile wlan-radio2g
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid, security profile wlan-security
2G radio profile
  • Name: wlan-radio2g
  • Configuring WMM.

RRM profile
  • Name: rrm
  • Configuring airtime fair scheduling.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see "How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?" in WLAN QoS Configuration of the Configuration Guide - WLAN-AC of the corresponding product version.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure SwitchA and the AC so that the AP and AC can transmit CAPWAP packets.

    # Add GE0/0/1 that connects SwitchA to the AP to management VLAN 100 and add GE0/0/2 that connects SwitchA to the AC to the same VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Add GE0/0/1 that connects the AC to SwitchA to VLAN 100.

    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the AC to communicate with the upstream device.

    NOTE:

    Configure AC uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AC uplink interface GE0/0/2 to service VLAN 101.

    [AC] interface gigabitethernet 0/0/2
    [AC-GigabitEthernet0/0/2] port link-type trunk
    [AC-GigabitEthernet0/0/2] port trunk allow-pass vlan 101
    [AC-GigabitEthernet0/0/2] quit
    

  4. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  5. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio all
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Configure airtime fair scheduling.

    # Create the 2G radio profile wlan-radio2g.

    NOTE:
    The following example configures a 2G radio profile. The configuration of the 5G radio profile is similar.
    [AC-wlan-view] radio-2g-profile name wlan-radio2g
    [AC-wlan-radio-2g-prof-wlan-radio2g] quit

    # Bind the 2G radio profile wlan-radio2g to the AP group ap-group1.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio2g
    [AC-wlan-ap-group-ap-group1] quit

    # Create the RRM profile rrm and enable airtime fair scheduling.

    [AC-wlan-view] rrm-profile name rrm
    [AC-wlan-rrm-prof-rrm] airtime-fair-schedule enable
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-rrm-prof-rrm] quit
    

    # Bind the RRM profile rrm to the 2G radio profile wlan-radio2g.

    [AC-wlan-view] radio-2g-profile name wlan-radio2g
    [AC-wlan-radio-2g-prof-wlan-radio2g] rrm-profile rrm
    [AC-wlan-radio-2g-prof-wlan-radio2g] quit

  8. Set channels and power for the AP radios.

    NOTE:

    The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable the automatic channel and power calibration functions.

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.
    [AC-wlan-view] rrm-profile name rrm
    [AC-wlan-rrm-prof-rrm] calibrate auto-channel-select disable
    [AC-wlan-rrm-prof-rrm] calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-rrm] quit
    # Set a channel and power for radio 0 of the AP.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] channel 20mhz 6
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Set a channel and power for radio 1 of the AP.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] channel 20mhz 149
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  9. Verify the configuration.

    Run the display rrm-profile command on the AC to check the configuration of the RRM profile. The command output shows that airtime fair scheduling has been enabled. Therefore, users on the network can fairly use the network bandwidth.

    [AP-wlan-view] display rrm-profile name rrm
    ------------------------------------------------------------                    
    Auto channel select                                    : disable                 
    Auto transmit power select                             : disable                 
    PER threshold for trigger channel/power select(%)      : 60                     
    Airtime fairness schedule                              : enable            
    Dynamic adjust EDCA parameter                          : disable                
    UAC check client's SNR                                 : disable                
    UAC client's SNR threshold(dB)                         : 20                     
    UAC check client number                                : disable                
    UAC client number access threshold                     : 64                     
    UAC client number roam threshold                       : 64                     
    UAC check channel utilization                          : disable                
    UAC channel utilization access threshold               : 80                     
    UAC channel utilization roam threshold                 : 80                     
    UAC hide SSID                                          : disable                
    Band steer deny threshold                              : 5                      
    Band balance start threshold                           : 10                     
    Band balance gap threshold(%)                          : 20                     
    Client's band expire based on continuous probe counts  : 35                     
    Station load balance                                   : disable                
    Station load balance start threshold                   : 10                     
    Station load balance gap threshold(%)                  : 20                     
    Station load balance deny threshold                    : 3                      
    Smart-roam                                             : disable                
    Smart-roam check SNR                                   : enable                 
    Smart-roam standing SNR threshold(dB)                  : 20                     
    Smart-roam SNR quick-kickoff-threshold(dB)             : 0                      
    Smart-roam check rate                                  : disable                
    AMC policy                                             : auto-balance           
    Smart-roam rate threshold(%)                           : 20                     
    Smart-roam rate quick-kickoff-threshold(%)             : 0                      
    Smart-roam high level SNR margin(dB)                   : 15                     
    Smart-roam low level SNR margin(dB)                    : 6                      
    Smart-roam SNR check interval(s)                       : 3                      
    Smart-roam unable roam client expire time(m)           : 120                    
    ------------------------------------------------------------

Configuration Files

  • SwitchA configuration file
    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     rrm-profile name rrm
      calibrate auto-channel-select disable
      calibrate auto-txpower-select disable
      airtime-fair-schedule enable
     radio-2g-profile name wlan-radio2g
      rrm-profile rrm
     ap-group name ap-group1
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile wlan-radio2g
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    return
Translation
Download
Updated: 2018-12-24

Document ID: EDOC1100038361

Views: 158962

Downloads: 436

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next