No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R012C00 Configuration Guide - QoS

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, ACL-based simplified traffic policy, and HQoS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Traffic Shaping

Example for Configuring Traffic Shaping

Networking Requirements

The Switch is connected to the router through GE2/0/1. The voice, video, and data services, with 802.1p priorities of 6, 5, and 2, respectively, are transmitted to users through the router and Switch, as shown in Figure 4-14. The rate of traffic from the user LAN is higher than the inbound interface rate on the router; therefore, jitter may occur on outbound interface GE2/0/1 of the Switch. The following requirements must be met to reduce jitter and ensure bandwidth of services:

  • The CIR on the outbound interface is 10000 kbit/s.
  • The CIR and PIR for the voice service are 3000 kbit/s and 5000 kbit/s respectively.
  • The CIR and PIR for the video service are 5000 kbit/s and 8000 kbit/s respectively.
  • The CIR and PIR for the data service are 2000 kbit/s and 3000 kbit/s respectively.
Figure 4-14  Networking of traffic shaping

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces to enable the users to access the network through the Switch.

  2. Configure priority mapping to map packet priorities to per hop behaviors (PHBs).

  3. Configure traffic shaping on the outbound interface to limit the traffic rate on the interface.

  4. Configure queue-based traffic shaping to limit the rates of voice, video, and data services.

Procedure

  1. Configure VLANs and interfaces.

    # Create VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10

    # Configure GE1/0/1 and GE2/0/1 as trunk interfaces and add them to VLAN 10.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet2/0/1] quit

    # Create VLANIF 10 and assign IP address 10.10.10.2/24 to it.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.10.10.2 255.255.255.0
    [Switch-Vlanif10] quit
    NOTE:

    Assign IP address 10.10.10.1/24 to the router interface connected to the Switch.

  2. Configure priority mapping.

    # Create DiffServ domain ds1, and map 802.1p priorities 6, 5, and 2 to PHBs CS7, EF, and AF2 respectively in the domain.

    [Switch] diffserv domain ds1
    [Switch-dsdomain-ds1] 8021p-inbound 6 phb cs7
    [Switch-dsdomain-ds1] 8021p-inbound 5 phb ef
    [Switch-dsdomain-ds1] 8021p-inbound 2 phb af2
    [Switch-dsdomain-ds1] quit
    [Switch] interface gigabitethernet 1/0/1 
    [Switch-GigabitEthernet1/0/1] trust upstream ds1
    [Switch-GigabitEthernet1/0/1] quit

  3. Configure traffic shaping on the outbound interface.

    # Configure traffic shaping on GE2/0/1 to limit the traffic rate on the interface to 10000 kbit/s.

    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] qos lr cir 10000 outbound
    

  4. Configure queue-based traffic shaping.

    # Configure traffic shaping for queues on the Switch to limit the CIR and PIR of the voice service to 3000 kbit/s and 5000 kbit/s, the CIR and PIR of the video service to 5000 kbit/s and 8000 kbit/s, and the CIR and PIR of the data service to 2000 kbit/s and 3000 kbit/s.

    [Switch-GigabitEthernet2/0/1] qos queue 7 shaping cir 3000 pir 5000
    [Switch-GigabitEthernet2/0/1] qos queue 5 shaping cir 5000 pir 8000
    [Switch-GigabitEthernet2/0/1] qos queue 2 shaping cir 2000 pir 3000
    [Switch-GigabitEthernet2/0/1] quit
    [Switch] quit

  5. Verify the configuration.

    # Check the configuration of the DiffServ domain ds1.

    <Switch> display diffserv domain name ds1
    diffserv domain name:ds1
     8021p-inbound 0 phb be green
     8021p-inbound 1 phb af1 green
     8021p-inbound 2 phb af2 green
     8021p-inbound 3 phb af3 green
     8021p-inbound 4 phb af4 green
     8021p-inbound 5 phb ef green
     8021p-inbound 6 phb cs7 green
     8021p-inbound 7 phb cs7 green
     8021p-outbound be green map 0
     ......
    

    # After the configuration is complete, the committed bandwidth for the packets sent from GE2/0/1 is 10000 kbit/s; the transmission rate of the voice service ranges from 3000 kbit/s to 5000 kbit/s; the transmission rate of the video service ranges from 5000 kbit/s to 8000 kbit/s; the transmission rate of the data service ranges from 2000 kbit/s to 3000 kbit/s.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    diffserv domain ds1
     8021p-inbound 6 phb cs7 green
    #
    interface Vlanif10
     ip address 10.10.10.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     trust upstream ds1
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     qos lr cir 10000 cbs 1250000 outbound
     qos queue 2 shaping cir 2000 pir 3000
     qos queue 5 shaping cir 5000 pir 8000
     qos queue 7 shaping cir 3000 pir 5000
    #
    return
    
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038410

Views: 17795

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next