No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring GVRP

Example for Configuring GVRP

Networking Requirements

In Figure 12-10, company A's headquarters, a branch of company A, and company B are connected using switches. GVRP is enabled to implement dynamic VLAN registration.

Figure 12-10  Configuring GVRP

The branch of Company A can communicate with Company A's headquarters using SwitchA and SwitchB. Company B can communicate with company A's headquarters using SwitchB and SwitchC. Interfaces connected to company A allow only the VLAN to which Company B belongs to pass.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable GVRP to implement dynamic VLAN registration.

  2. Configure GVRP on all switches of company A and set the registration mode of the interfaces to normal to simplify configurations.

  3. Configure GVRP on all switches of company A and set the registration mode to fixed for the interfaces connecting to company A to allow only the VLAN to which company B belongs to pass.

NOTE:

Before enabling GVRP, you must configure the VCMP role as transparent or silent.

Procedure

  1. Configure SwitchA.

    # Enable GVRP globally.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vcmp role silent
    [SwitchA] gvrp
    

    # Set the link type of GE 1/0/1 and GE 1/0/2 to trunk and configure the interfaces to allow all VLANs to pass through.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchA-GigabitEthernet1/0/2] quit
    

    # Enable GVRP and set the registration mode on the interfaces.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] gvrp
    [SwitchA-GigabitEthernet1/0/1] gvrp registration normal
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] gvrp
    [SwitchA-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchA-GigabitEthernet1/0/2] quit
    

    The configuration of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

  2. Configure SwitchB.

    # Enable GVRP globally.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vcmp role silent
    [SwitchB] gvrp
    

    # Set the link type of GE 1/0/1 and GE 1/0/2 to trunk and configure the interfaces to allow all VLANs to pass through.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchB-GigabitEthernet1/0/2] quit
    

    # Enable GVRP and set the registration mode on the interfaces.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] gvrp
    [SwitchB-GigabitEthernet1/0/1] gvrp registration normal
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] gvrp
    [SwitchB-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchB-GigabitEthernet1/0/2] quit
    

  3. Configure SwitchC.

    # Create VLAN 101 to VLAN 200.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 101 to 200
    

    # Enable GVRP globally.

    [SwitchC] vcmp role silent
    [SwitchC] gvrp
    

    # Set the link type of GE 1/0/1 and GE 1/0/2 to trunk and configure the interfaces to allow all VLANs to pass through.

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type trunk
    [SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] port link-type trunk
    [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchC-GigabitEthernet1/0/2] quit
    

    # Enable GVRP and set the registration mode on the interfaces.

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] gvrp
    [SwitchC-GigabitEthernet1/0/1] gvrp registration fixed
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] gvrp
    [SwitchC-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchC-GigabitEthernet1/0/2] quit
    

  4. Verify the configuration.

    After the configuration is complete, the branch of Company A can communicate with the headquarters, and users of Company A in VLAN 101 to VLAN 200 can communicate with users in Company B.

    Run the display gvrp statistics command on SwitchA to view GVRP statistics on GVRP interfaces, including the GVRP state of each interface, number of GVRP registration failures, source MAC address of the last GVRP PDU, and registration mode of each interface.

    [SwitchA] display gvrp statistics
    
      GVRP statistics on port GigabitEthernet1/0/1 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    
      GVRP statistics on port GigabitEthernet1/0/2 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    Info: GVRP is disabled on one or multiple ports.
    

    Verify the configurations of SwitchB and SwitchC in the same way.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vcmp role silent
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vcmp role silent
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vcmp role silent
    #
    vlan batch 101 to 200
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
     gvrp registration fixed
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 108112

Downloads: 71

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next