No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MAC Address-based Assignment (the Switch Connects to Downstream Terminals)

Example for Configuring MAC Address-based Assignment (the Switch Connects to Downstream Terminals)

Networking Requirements

On a company intranet, the network administrator adds the PCs in a department to the same VLAN. To improve information security, only employees in this department are allowed to access the intranet.

In Figure 4-26, only PC1, PC2, and PC3 are allowed to access the intranet through the switch.

Use MAC-address based VLAN assignment and associate MAC addresses of PCs with the specified VLAN.

Figure 4-26  Networking of MAC address-based assignment

Configuration Roadmap

  1. Create VLANs and determine which VLAN the PCs of employees belong to.

  2. Add Ethernet interfaces to VLANs so that packets from the VLANs can pass through the interfaces.

  3. Associate MAC addresses of PC1, PC2, and PC3 with the specified VLAN so that the VLAN of the packets can be determined based on the source MAC address.

Procedure

  1. Configure the Switch.

    # Create VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    

    # Add interfaces to the VLANs. The configuration of GE1/0/3 and GE1/0/4 is the same as that of GE1/0/2.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/2] quit
    

    # Associate MAC addresses of PC1, PC2, and PC3 with VLAN 10.

    [Switch] vlan 10
    [Switch-vlan10] mac-vlan mac-address 22-22-22
    [Switch-vlan10] mac-vlan mac-address 33-33-33
    [Switch-vlan10] mac-vlan mac-address 44-44-44
    [Switch-vlan10] quit
    

    # Enable MAC address-based VLAN assignment on GE1/0/2. The configuration of GE1/0/3 and GE1/0/4 is the same as that of GE1/0/2, and is not mentioned here.

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] mac-vlan enable
    [Switch-GigabitEthernet1/0/2] quit
    

  2. Verify the configuration.

    PC1, PC2, and PC3 can access the intranet, whereas other PCsusers cannot access the intranet.

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10
#
vlan 10
 mac-vlan mac-address 0022-0022-0022 priority 0
 mac-vlan mac-address 0033-0033-0033 priority 0
 mac-vlan mac-address 0044-0044-0044 priority 0
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid untagged vlan 10
 mac-vlan enable
#
interface GigabitEthernet1/0/3
 port link-type hybrid
 port hybrid untagged vlan 10
 mac-vlan enable
#
interface GigabitEthernet1/0/4
 port link-type hybrid
 port hybrid untagged vlan 10
 mac-vlan enable
#
return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 116722

Downloads: 73

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next