No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intersecting ERPS Rings

Example for Configuring Intersecting ERPS Rings

Networking Requirements

Generally, redundant links are used on an Ethernet switching network to provide link backup and enhance network reliability. The use of redundant links, however, may produce loops, causing broadcast storms and rendering the MAC address table unstable. As a result, communication quality deteriorates, and communication services may even be interrupted.

To prevent loops caused by redundant links, enable ERPS on the nodes of the ring network. ERPS is a Layer 2 loop-breaking protocol defined by the ITU-T, and provides fast convergence of carrier-class reliability standards.

As shown in Figure 19-17, intersecting ERPS rings are used. SwitchA, SwitchB, SwitchC, and SwitchD constitute the major ring, and SwitchA, LSW1, LSW2, LSW3, and SwitchD constitute a sub-ring.

Figure 19-17  Networking of intersecting ERPS rings

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the link type of all ports to be added to ERPS rings as trunk.

  2. Create ERPS rings and configure control VLANs and Ethernet Ring Protection (ERP) instances in the ERPS rings.

  3. Specify the ERPS version and configure a sub-ring.

  4. Add Layer 2 ports to ERPS rings and specify port roles.

  5. Configure the topology change notification and TC protection.

  6. Configure the Guard timers and WTR timers in the ERPS rings.

  7. Configure Layer 2 forwarding on SwitchA through SwitchD and LSW1 through LSW3.

Procedure

  1. Configure the link type of all ports to be added to ERPS rings as trunk.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, LSW1, LSW2, and LSW3 are similar to the configuration of SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] quit

  2. Create ERPS ring 1 and ERPS ring 2 and configure ERP instances in the two rings. Set the control VLAN ID of ERPS ring 1 to 10 and the control VLAN ID of ERPS ring 2 to 20. Enable ERPS rings 1 and 2 to transmit data packets from VLANs 100 to 200.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, LSW1, LSW2, and LSW3 are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 1 vlan 10 20 100 to 200
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit
    [SwitchA] erps ring 1
    [SwitchA-erps-ring1] control-vlan 10
    [SwitchA-erps-ring1] protected-instance 1
    [SwitchA-erps-ring1] quit
    [SwitchA] erps ring 2
    [SwitchA-erps-ring2] control-vlan 20
    [SwitchA-erps-ring2] protected-instance 1
    [SwitchA-erps-ring2] quit

  3. Specify ERPSv2 and configure ERPS ring 2 as a sub-ring.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, LSW1, LSW2, and LSW3 are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] erps ring 1
    [SwitchA-erps-ring1] version v2
    [SwitchA-erps-ring1] quit
    [SwitchA] erps ring 2
    [SwitchA-erps-ring2] version v2
    [SwitchA-erps-ring2] sub-ring
    [SwitchA-erps-ring2] quit

  4. Add the ports to ERPS rings and specify port roles. Configure GE1/0/1 on SwitchB and GE1/0/2 on LSW3 as their respective RPL owner ports.

    # Configure SwitchA. The configurations of SwitchC, SwitchD, LSW1, and LSW2 are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] erps ring 2
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] erps ring 1
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] stp disable
    [SwitchA-GigabitEthernet1/0/3] erps ring 1
    [SwitchA-GigabitEthernet1/0/3] quit

    # Configure SwitchB. The configurations of LSW3 is similar to the configuration of SwitchB, and are not mentioned here.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] stp disable
    [SwitchB-GigabitEthernet1/0/1] erps ring 1 rpl owner
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] stp disable
    [SwitchB-GigabitEthernet1/0/2] erps ring 1
    [SwitchB-GigabitEthernet1/0/2] quit
    

  5. Configure the topology change notification function and TC protection on SwitchA and SwitchD (interconnecting nodes).

    # Configure SwitchA.

    [SwitchA] erps ring 1
    [SwitchA-erps-ring1] tc-protection interval 200
    [SwitchA-erps-ring1] tc-protection threshold 60
    [SwitchA-erps-ring1] quit
    [SwitchA] erps ring 2
    [SwitchA-erps-ring2] tc-notify erps ring 1
    [SwitchA-erps-ring2] quit

    # Configure SwitchD.

    [SwitchD] erps ring 1
    [SwitchD-erps-ring1] tc-protection interval 200
    [SwitchD-erps-ring1] tc-protection threshold 60
    [SwitchD-erps-ring1] quit
    [SwitchD] erps ring 2
    [SwitchD-erps-ring2] tc-notify erps ring 1
    [SwitchD-erps-ring2] quit

  6. Configure the Guard timers and WTR timers in the ERPS rings.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, LSW1, LSW2, and LSW3 are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] erps ring 1
    [SwitchA-erps-ring1] wtr-timer 6
    [SwitchA-erps-ring1] guard-timer 100
    [SwitchA-erps-ring1] quit
    [SwitchA] erps ring 2
    [SwitchA-erps-ring2] wtr-timer 6
    [SwitchA-erps-ring2] guard-timer 100
    [SwitchA-erps-ring2] quit

  7. Configure Layer 2 forwarding on SwitchA through SwitchD.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, LSW1, LSW2, and LSW3 are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] vlan batch 100 to 200
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 to 200
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 to 200 
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 100 to 200
    [SwitchA-GigabitEthernet1/0/3] quit

  8. Verify the configuration.

    # After the network becomes stable, run the display erps command to check brief information about the ERPS ring and ports added to the ERPS ring. SwitchB is used as an example.

    [SwitchB] display erps
    D  : Discarding
    F  : Forwarding
    R  : RPL Owner
    N  : RPL Neighbour
    FS : Forced Switch
    MS : Manual Switch
    Total number of rings configured = 1
    Ring  Control  WTR Timer  Guard Timer  Port 1               Port 2
    ID    VLAN     (min)      (csec)
    --------------------------------------------------------------------------------
       1       10          6          100  (D,R)GE1/0/1         (F)GE1/0/2
    --------------------------------------------------------------------------------

    # Run the display erps verbose command to check detailed information about the ERPS ring and ports added to the ERPS ring.

    [SwitchB] display erps verbose
    Ring ID                             : 1
    Description                         : Ring 1
    Control Vlan                        : 10
    Protected Instance                  : 1 
    Service Vlan                        : 100 to 200
    WTR Timer Setting (min)             : 6      Running (s)           : 0  
    Guard Timer Setting (csec)          : 100    Running (csec)        : 0  
    Holdoff Timer Setting (deciseconds) : 0      Running (deciseconds) : 0  
    WTB Timer Running (csec)            : 0  
    Ring State                          : Idle
    RAPS_MEL                            : 7
    Revertive Mode                      : Revertive
    R-APS Channel Mode                  : -
    Version                             : 2
    Sub-ring                            : No 
    Forced Switch Port                  : -
    Manual Switch Port                  : -
    TC-Notify                           : -
    Time since last topology change     : 0 days 4h:12m:20s
    --------------------------------------------------------------------------------
    Port                Port Role     Port Status     Signal Status
    --------------------------------------------------------------------------------
    GE1/0/1             RPL Owner     Discarding      Non-failed      
    GE1/0/2             Common        Forwarding      Non-failed

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 100 to 200
    #
    stp region-configuration
     instance 1 vlan 10 20 100 to 200
     active region-configuration
    #
    erps ring 1
     control-vlan 10
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     tc-protection interval 200
     tc-protection threshold 60
    erps ring 2
     control-vlan 20
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     sub-ring
     tc-notify erps ring 1
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 100 to 200
    #
    stp region-configuration
     instance 1 vlan 10 100 to 200
     active region-configuration
    #
    erps ring 1
     control-vlan 10
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1 rpl owner
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10 100 to 200
    #
    stp region-configuration
     instance 1 vlan 10 100 to 200
     active region-configuration
    #
    erps ring 1
     control-vlan 10
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10 20 100 to 200
    #
    stp region-configuration
     instance 1 vlan 10 20 100 to 200
     active region-configuration
    #
    erps ring 1
     control-vlan 10
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     tc-protection interval 200
     tc-protection threshold 60
    erps ring 2
     control-vlan 20
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     sub-ring
     tc-notify erps ring 1
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 100 to 200
     stp disable
     erps ring 1
    #
    return
  • LSW1 configuration file

    #
    sysname LSW1
    #
    vlan batch 20 100 to 200
    #
    stp region-configuration
     instance 1 vlan 20 100 to 200
     active region-configuration
    #
    erps ring 2
     control-vlan 20
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     sub-ring
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    return
  • LSW2 configuration file

    #
    sysname LSW2
    #
    vlan batch 20 100 to 200
    #
    stp region-configuration
     instance 1 vlan 20 100 to 200
     active region-configuration
    #
    erps ring 2
     control-vlan 20
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     sub-ring
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    return
  • LSW3 configuration file

    #
    sysname LSW3
    #
    vlan batch 20 100 to 200
    #
    stp region-configuration
     instance 1 vlan 20 100 to 200
     active region-configuration
    #
    erps ring 2
     control-vlan 20
     protected-instance 1
     wtr-timer 6
     guard-timer 100
     version v2
     sub-ring
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 200
     stp disable
     erps ring 2 rpl owner
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 94221

Downloads: 67

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next