No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Transparent Transmission of Protocol Packets in a VLAN

Example for Configuring Transparent Transmission of Protocol Packets in a VLAN

Networking Requirements

A company has multiple subsidiary companies. When the parent company communicates with a subsidiary company through the core switch, the core switch processes the packets before forwarding them. If multiple subsidiary companies communicate with the parent company simultaneously, then network performance deteriorates, lowering communication efficiency and increasing communication costs. Transparent transmission of protocol packets in a VLAN can be configured on the core switch to solve this problem.

In Figure 4-36, after transparent transmission of protocol packets in a VLAN is enabled, the Switch forwards data from the specified VLAN without sending the data to its CPU. This improves the processing efficiency, reduces communication costs, and minimizes the probability of malicious attacks on the Switch.

Figure 4-36  VLAN transparent transmission

Configuration Roadmap

  1. Create VLANs.

  2. Enable transparent transmission of protocol packets in a VLAN.

  3. Add Ethernet interfaces to VLANs.

Procedure

  1. Configure the Switch.

    # Create VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # Enable transparent transmission of protocol packets in a VLAN.

    [Switch] vlan 20
    [Switch-vlan20] protocol-transparent
    [Switch-vlan20] quit
    

    # Add interfaces to the VLANs.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid tagged vlan 10 20
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type hybrid
    [Switch-GigabitEthernet1/0/3] port hybrid tagged vlan 20
    [Switch-GigabitEthernet1/0/3] quit
    

  2. Configure SwitchA and SwitchB. Add upstream interfaces on SwitchA and SwitchB to VLAN 10 and VLAN 20 in tagged mode, and add downstream interfaces to VLAN 10 and VLAN 20 in default mode.
  3. Verify the configuration.

    # After the configuration is complete, run the display this command on VLAN 20. The command output shows that transparent transmission of protocol packets in a VLAN is enabled.

    [Switch] vlan 20
    [Switch-vlan20] display this
    #
    vlan 20
     protocol-transparent
    #
    return
    

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10 20
#
vlan 20
 protocol-transparent
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid tagged vlan 10 20
#
interface GigabitEthernet1/0/3
 port link-type hybrid
 port hybrid tagged vlan 20
#
return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 94988

Downloads: 67

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next