No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VLAN ID-based Voice VLAN (IP Phones Send Tagged Voice Packets)

Example for Configuring a VLAN ID-based Voice VLAN (IP Phones Send Tagged Voice Packets)

Networking Requirements

As shown in Figure 9-7, the switch connects to IP phones and a PC. The switch uses VLAN 2 to transmit voice packets and VLAN 3 to transmit data packets. PC A connects to IP phone A and they connect to the switch, and IP phone B separately connects to the switch. IP phones can obtain voice VLAN information through LLDP and send tagged voice packets. Users require high quality of the VoIP service; therefore, voice data flows must be transmitted with a high priority to ensure the call quality. In addition, the administrator manages many IP phones and requires simplified configurations.

Figure 9-7  Networking for configuring a VLAN ID-based voice VLAN

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs on the switch and add interfaces to VLANs to implement Layer 2 connectivity.
  2. Enable LLDP so that IP phones can obtain voice VLAN information through LLDP.
  3. Configure VLAN 2 as the voice VLAN and configure the interface to allow voice packets to pass through. Configure a VLAN ID-based voice VLAN, which relieves you from configuring OUIs.

Procedure

  1. Configure VLANs and interfaces on the Switch.

    # Create VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2 3
    

    # Configure VLANs allowed by GE1/0/1.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 3
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 3
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 2
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid tagged vlan 2
    [Switch-GigabitEthernet1/0/2] quit
    

  2. Enable LLDP.

    [Switch] lldp enable

  3. # Enable the voice VLAN function on GE1/0/1. The configuration of GE1/0/2 is similar to the configuration of GE1/0/1, and is not mentioned here.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] voice-vlan 2 enable
    [Switch-GigabitEthernet1/0/1] voice-vlan remark-mode vlan
    [Switch-GigabitEthernet1/0/1] quit

  4. Verify the configuration.

    Run the display voice-vlan 2 status command to check the voice VLAN configuration.

    [Switch] display voice-vlan 2 status
    Voice VLAN Configurations: 
    -----------------------------------------------------------
    Voice VLAN ID            : 2
    Voice VLAN status        : Enable
    Voice VLAN 8021p remark  : 6
    Voice VLAN dscp remark   : 46
    -----------------------------------------------------------
    Port Information: 
    -------------------------------------------------------------------------------
    Port                       Add-Mode  Security-Mode  Legacy  PribyVLAN  Untag
    -------------------------------------------------------------------------------
    GigabitEthernet1/0/2       Manual    Normal         Disable Enable     Disable
    GigabitEthernet1/0/1       Manual    Normal         Disable Enable     Disable

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 2 to 3
#
lldp enable
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 voice-vlan 2 enable
 port hybrid pvid vlan 3
 port hybrid tagged vlan 2
 port hybrid untagged vlan 3
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 voice-vlan 2 enable
 port hybrid tagged vlan 2
#
return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 94099

Downloads: 67

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next