No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MUX VLAN on an Aggregation Device

Example for Configuring MUX VLAN on an Aggregation Device

Networking Requirements

All employees of an enterprise can access the server on the enterprise network. The enterprise allows communication between certain employees while prohibiting communication between others.

As shown in Figure 7-4, Switch1 is located at the aggregation layer and used as the gateway of user hosts. Switch2, Switch3, Switch4, Switch5, and Switch6 are access devices. You can configure MUX VLAN on Switch1 to conserve VLAN IDs on the enterprise network. MUX VLAN meets the enterprise's requirements and has fewer requirements on network maintenance.

Figure 7-4  MUX VLAN networking

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a principal VLAN and a VLANIF interface. The IP address of the VLANIF interface is used as the gateway IP address of user hosts and server.

  2. Configure a group VLAN.

  3. Configure a separate VLAN.

  4. Add ports to the VLANs and enable the MUX VLAN feature on the ports.

  5. Add ports of access devices to VLANs.

Procedure

  1. Configure MUX VLAN.

    # Create VLAN 2, VLAN 3, VLAN 4, and VLANIF 2 on Switch1. The IP address of VLANIF 2 is used as the gateway IP address for user hosts and server.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan batch 2 3 4
    [Switch1] interface vlanif 2
    [Switch1-Vlanif2] ip address 192.168.100.100 24
    [Switch1-Vlanif2] quit
    

    # Configure a group VLAN and a separate VLAN on Switch1.

    [Switch1] vlan 2
    [Switch1-vlan2] mux-vlan
    [Switch1-vlan2] subordinate group 3
    [Switch1-vlan2] subordinate separate 4
    [Switch1-vlan2] quit
    

    # Add ports to the VLANs and enable the MUX VLAN feature on the ports.

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type trunk
    [Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet1/0/2] port mux-vlan enable vlan 2
    [Switch1-GigabitEthernet1/0/2] quit
    [Switch1] interface gigabitethernet 1/0/3
    [Switch1-GigabitEthernet1/0/3] port link-type trunk
    [Switch1-GigabitEthernet1/0/3] port trunk allow-pass vlan 3
    [Switch1-GigabitEthernet1/0/3] port mux-vlan enable vlan 3
    [Switch1-GigabitEthernet1/0/3] quit
    [Switch1] interface gigabitethernet 1/0/4
    [Switch1-GigabitEthernet1/0/4] port link-type trunk
    [Switch1-GigabitEthernet1/0/4] port trunk allow-pass vlan 3
    [Switch1-GigabitEthernet1/0/4] port mux-vlan enable vlan 3
    [Switch1-GigabitEthernet1/0/4] quit
    [Switch1] interface gigabitethernet 1/0/5
    [Switch1-GigabitEthernet1/0/5] port link-type trunk
    [Switch1-GigabitEthernet1/0/5] port trunk allow-pass vlan 4
    [Switch1-GigabitEthernet1/0/5] port mux-vlan enable vlan 4
    [Switch1-GigabitEthernet1/0/5] quit
    [Switch1] interface gigabitethernet 1/0/6
    [Switch1-GigabitEthernet1/0/6] port link-type trunk
    [Switch1-GigabitEthernet1/0/6] port trunk allow-pass vlan 4
    [Switch1-GigabitEthernet1/0/6] port mux-vlan enable vlan 4
    [Switch1-GigabitEthernet1/0/6] quit
    

  2. Add ports of access switches to VLANs. The configuration details are not mentioned here.
  3. Verify the configuration.

    The server can communicate with HostB, HostC, HostD, and HostE at Layer 2.

    HostB can communicate with HostC at Layer 2.

    HostD cannot communicate with HostE at Layer 2.

    HostB and HostC cannot communicate with HostD and HostE at Layer 2.

Configuration Files

Switch1 configuration file

#
sysname Switch1
#
vlan batch 2 to 4
#
vlan 2
 mux-vlan
 subordinate separate 4 
 subordinate group 3
#
interface Vlanif2                                                             
 ip address 192.168.100.100 255.255.255.0  
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 
 port mux-vlan enable vlan 2
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 3
 port mux-vlan enable vlan 3
#
interface GigabitEthernet1/0/4
 port link-type trunk
 port trunk allow-pass vlan 3
 port mux-vlan enable vlan 3
#
interface GigabitEthernet1/0/5
 port link-type trunk
 port trunk allow-pass vlan 4
 port mux-vlan enable vlan 4
#
interface GigabitEthernet1/0/6
 port link-type trunk
 port trunk allow-pass vlan 4
 port mux-vlan enable vlan 4
#
return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 137024

Downloads: 73

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next