No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Protocol-based VLAN Assignment

Example for Configuring Protocol-based VLAN Assignment

Networking Requirements

A company uses multiple services, including IPTV, VoIP, and Internet access. Each service uses a different protocol. To facilitate network management, each service is added to a different VLAN.

In Figure 4-29, Swithc1 receives packets from multiple services that all use different protocols. Users in VLAN 10 use IPv4 to communicate with remote users, and users in VLAN 20 use IPv6 to communicate with the servers. Switch1 needs to assign VLANs to packets of different services and transmit packets with different VLAN IDs to different servers.

Figure 4-29  Networking diagram for protocol-based VLAN assignment

Configuration Roadmap

  1. Create VLANs and determine which VLAN each service belongs to.

  2. Associate protocols with VLANs so that the VLANs that received packets belong to can be assigned based on protocols.

  3. Add interfaces to VLANs so that packets of the protocol-based VLANs can pass through those interfaces.
  4. Associate interfaces with VLANs.

    After Switch receives a frame from a specified protocol, it assigns the VLAN ID associated with the protocol to the frame.

Procedure

  1. Create VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan batch 10 20

  2. Configure protocol-based VLAN assignment.

    # Associate IPv4 with VLAN 10 on Switch1.

    [Switch1] vlan 10
    [Switch1-vlan10] protocol-vlan ipv4
    [Switch1-vlan10] quit

    # Associate IPv6 with VLAN 20 on Switch1.

    [Switch1] vlan 20
    [Switch1-vlan20] protocol-vlan ipv6
    [Switch1-vlan20] quit

  3. Associate interfaces with protocol-based VLANs.

    # Associate GE1/0/2 with VLAN 10 and set the 802.1p priority of VLAN 10 to 5 on Switch1.

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] protocol-vlan vlan 10 all priority 5
    [Switch1-GigabitEthernet1/0/2] quit

    # Associate GE1/0/3 with VLAN 20 and set the 802.1p priority of VLAN 20 to 6 on Switch1.

    [Switch1] interface gigabitethernet 1/0/3
    [Switch1-GigabitEthernet1/0/3] protocol-vlan vlan 20 all priority 6
    [Switch1-GigabitEthernet1/0/3] quit

  4. Configure interfaces.

    # Add GE1/0/1 to VLAN 10 and VLAN 20 in trunk mode on Switch1.

    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type trunk
    [Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20
    [Switch1-GigabitEthernet1/0/1] quit

    # Add GE1/0/2 to VLAN 10 in untagged mode on Switch1.

    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type hybrid
    [Switch1-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [Switch1-GigabitEthernet1/0/2] quit

    # Add GE1/0/3 to VLAN 20 in untagged mode on Switch1.

    [Switch1] interface gigabitethernet 1/0/3
    [Switch1-GigabitEthernet1/0/3] port link-type hybrid
    [Switch1-GigabitEthernet1/0/3] port hybrid untagged vlan 20
    [Switch1-GigabitEthernet1/0/3] quit

    # Add GE1/0/1 to VLAN 10 and VLAN 20 in trunk mode on the switch.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20
    [Switch-GigabitEthernet1/0/1] quit

    # Add GE1/0/2 to VLAN 10 in trunk mode on the switch.

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/2] quit

    # Add GE1/0/3 to VLAN 20 in trunk mode on the switch.

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type trunk
    [Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/3] quit

  5. Verify the configuration.

    After the configuration is complete, run the display protocol-vlan interface all command on Switch1 to view the protocol-based VLAN assignment.

    [Switch1] display protocol-vlan interface all
    -------------------------------------------------------------------------------
     Interface                VLAN    Index        Protocol Type           Priority
    -------------------------------------------------------------------------------
     GigabitEthernet1/0/2     10      0            IPv4                    5
     GigabitEthernet1/0/3     20      0            IPv6                    6
    

Configuration Files

  • Switch1 configuration file

    #
    sysname Switch1
    #
    vlan batch 10 20
    #
    vlan 10
     protocol-vlan 0 ipv4
    vlan 20
     protocol-vlan 0 ipv6
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid untagged vlan 10
     protocol-vlan vlan 10 0 priority 5
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid untagged vlan 20
     protocol-vlan vlan 20 0 priority 6
    #
    return
  • Switch configuration file

    #
    sysname Switch
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 93487

Downloads: 67

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next