No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R012C00

This document describes the configuration of Ethernet services, including configuring MAC address table, link aggregation, VLANs, VLAN aggregation, MUX VLAN, VLAN termination, Voice VLAN, VLAN mapping, QinQ, GVRP, VCMP, STP/RSTP/MSTP, VBST, SEP, RRPP, ERPS, LBDT, HVRP, and Layer 2 protocol transparent transmission.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN ID-based 2 to 1 VLAN Mapping

Example for Configuring VLAN ID-based 2 to 1 VLAN Mapping

Networking Requirements

As shown in Figure 11-7, Residential Gateway, Corridor Switch, and Community Switch allow users to connect to the aggregation layer. To save VLAN resources and isolate same services used by different users, configure the QinQ function on the Corridor Switch and configure VLAN mapping on the Community Switch.

Figure 11-7  Networking diagram for configuring 2 to 1 VLAN mapping

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add switch ports connecting to users to specified VLANs to distinguish different services.

  2. Configure the QinQ function on the Corridor Switch to distinguish users and services.

  3. Configure VLAN mapping on the Community Switch to save VLAN resources.

Procedure

  1. Add downlink interfaces of S1 and S2 to specified VLANs.

    # Configure S1.

    <HUAWEI> system-view
    [HUAWEI] sysname S1
    [S1] vlan batch 2 to 4
    [S1] interface gigabitethernet 1/0/1
    [S1-GigabitEthernet1/0/1] port link-type access
    [S1-GigabitEthernet1/0/1] port default vlan 2
    [S1-GigabitEthernet1/0/1] quit
    [S1] interface gigabitethernet 1/0/2
    [S1-GigabitEthernet1/0/2] port link-type access
    [S1-GigabitEthernet1/0/2] port default vlan 3
    [S1-GigabitEthernet1/0/2] quit
    [S1] interface gigabitethernet 1/0/3
    [S1-GigabitEthernet1/0/3] port link-type access
    [S1-GigabitEthernet1/0/3] port default vlan 4
    [S1-GigabitEthernet1/0/3] quit
    [S1] interface gigabitethernet 1/0/4
    [S1-GigabitEthernet1/0/4] port link-type trunk
    [S1-GigabitEthernet1/0/4] port trunk allow-pass vlan 2 to 4
    [S1-GigabitEthernet1/0/4] quit

    # Configure S2.

    <HUAWEI> system-view
    [HUAWEI] sysname S2
    [S2] vlan batch 2 to 4
    [S2] interface gigabitethernet 1/0/1
    [S2-GigabitEthernet1/0/1] port link-type access
    [S2-GigabitEthernet1/0/1] port default vlan 2
    [S2-GigabitEthernet1/0/1] quit
    [S2] interface gigabitethernet 1/0/2
    [S2-GigabitEthernet1/0/2] port link-type access
    [S2-GigabitEthernet1/0/2] port default vlan 3
    [S2-GigabitEthernet1/0/2] quit
    [S2] interface gigabitethernet 1/0/3
    [S2-GigabitEthernet1/0/3] port link-type access
    [S2-GigabitEthernet1/0/3] port default vlan 4
    [S2-GigabitEthernet1/0/3] quit
    [S2] interface gigabitethernet 1/0/4
    [S2-GigabitEthernet1/0/4] port link-type trunk
    [S2-GigabitEthernet1/0/4] port trunk allow-pass vlan 2 to 4
    [S2-GigabitEthernet1/0/4] quit

  2. Configure the QinQ function on the Corridor Switch to allow the Corridor Switch to send double-tagged packets to the Community Switch.

    # Configure S3.

    <HUAWEI> system-view
    [HUAWEI] sysname S3
    [S3] vlan batch 201 401
    [S3] interface gigabitethernet 1/0/1
    [S3-GigabitEthernet1/0/1] port link-type hybrid
    [S3-GigabitEthernet1/0/1] port hybrid untagged vlan 201 401
    [S3-GigabitEthernet1/0/1] port vlan-stacking vlan 2 to 3 stack-vlan 201
    [S3-GigabitEthernet1/0/1] port vlan-stacking vlan 4 stack-vlan 401
    [S3-GigabitEthernet1/0/1] quit
    [S3] interface gigabitethernet 1/0/2
    [S3-GigabitEthernet1/0/2] port link-type trunk
    [S3-GigabitEthernet1/0/2] port trunk allow-pass vlan 201 401
    [S3-GigabitEthernet1/0/2] quit

    # Configure S4.

    <HUAWEI> system-view
    [HUAWEI] sysname S4
    [S4] vlan batch 201 401
    [S4] interface gigabitethernet 1/0/1
    [S4-GigabitEthernet1/0/1] port link-type hybrid
    [S4-GigabitEthernet1/0/1] port hybrid untagged vlan 201 401
    [S4-GigabitEthernet1/0/1] port vlan-stacking vlan 2 to 3 stack-vlan 201
    [S4-GigabitEthernet1/0/1] port vlan-stacking vlan 4 stack-vlan 401
    [S4-GigabitEthernet1/0/1] quit
    [S4] interface gigabitethernet 1/0/2
    [S4-GigabitEthernet1/0/2] port link-type trunk
    [S4-GigabitEthernet1/0/2] port trunk allow-pass vlan 201 401
    [S4-GigabitEthernet1/0/2] quit

  3. Configure VLAN mapping on S5.

    <HUAWEI> system-view
    [HUAWEI] sysname S5
    [S5] vlan batch 501
    [S5] interface gigabitethernet 1/0/1
    [S5-GigabitEthernet1/0/1] port link-type trunk
    [S5-GigabitEthernet1/0/1] port trunk allow-pass vlan 501
    [S5-GigabitEthernet1/0/1] port vlan-mapping vlan 201 inner-vlan 2 to 3 map-vlan 501
    [S5-GigabitEthernet1/0/1] port vlan-mapping vlan 401 inner-vlan 4 map-vlan 501
    [S5-GigabitEthernet1/0/1] quit
    [S5] interface gigabitethernet 1/0/2
    [S5-GigabitEthernet1/0/2] port link-type trunk
    [S5-GigabitEthernet1/0/2] port trunk allow-pass vlan 501
    [S5-GigabitEthernet1/0/2] port vlan-mapping vlan 201 inner-vlan 2 to 3 map-vlan 501
    [S5-GigabitEthernet1/0/2] port vlan-mapping vlan 401 inner-vlan 4 map-vlan 501
    [S5-GigabitEthernet1/0/2] quit
    [S5] interface gigabitethernet 1/0/3
    [S5-GigabitEthernet1/0/3] port link-type trunk
    [S5-GigabitEthernet1/0/3] port trunk allow-pass vlan 501
    [S5-GigabitEthernet1/0/3] quit

  4. Verify the configurations.

    Verify that users can connect to the network and that same services are sent on the same VLAN.

Configuration Files

  • Configuration file of S1

    #
    sysname S1
    #
    vlan batch 2 to 4
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 2
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 3
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 4
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    return
  • Configuration file of S2

    #
    sysname S2
    #
    vlan batch 2 to 4
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 2
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 3
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 4
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     port trunk allow-pass vlan 2 to 4
    #
    return
  • Configuration file of S3

    #
    sysname S3
    #
    vlan batch 201 401
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 201 401
     port vlan-stacking vlan 2 to 3 stack-vlan 201
     port vlan-stacking vlan 4 stack-vlan 401
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201 401
    #
    return
  • Configuration file of S4

    #
    sysname S4
    #
    vlan batch 201 401
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid untagged vlan 201 401
     port vlan-stacking vlan 2 to 3 stack-vlan 201
     port vlan-stacking vlan 4 stack-vlan 401
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 201 401
    #
    return
  • Configuration file of S5

    #
    sysname S5
    #
    vlan batch 501
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 501
     port vlan-mapping vlan 201 inner-vlan 2 to 3 map-vlan 501                                                                          
     port vlan-mapping vlan 401 inner-vlan 4 map-vlan 501
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 501
     port vlan-mapping vlan 201 inner-vlan 2 to 3 map-vlan 501                                                                          
     port vlan-mapping vlan 401 inner-vlan 4 map-vlan 501
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 501
    #
    return
Translation
Download
Updated: 2019-01-18

Document ID: EDOC1100038843

Views: 115385

Downloads: 73

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next