No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 12800 and 12800E V200R005C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a DHCP Server Based on the Global Address Pool

Example for Configuring a DHCP Server Based on the Global Address Pool

Networking Requirements

As shown in Figure 3-16, an enterprise has two offices on the same network segment. To reduce network construction costs, the enterprise uses one DHCP server to assign IP addresses to clients in the two offices.

All the clients in Office1 are on the network segment 10.1.1.0/25 and added to VLAN 10. Clients in Office1 only use the DNS service with the lease time of ten days. All the clients in Office2 are on the network segment 10.1.1.128/25 and added to VLAN 20. Clients in Office2 use the DNS service and NetBIOS service with the lease time of two days.

You can configure a global address pool on SwitchB and enable the server to dynamically assign IP addresses to hosts in the two offices.

Figure 3-16 Networking diagram for configuring a DHCP server based on the global address pool

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create two global address pools on SwitchB and set attributes of the pools. Assign IP addresses to Office1 and Office2 as required.
  2. Configure VLANIF interfaces to use the global address pool for assigning IP addresses to clients.

Procedure

  1. Enable DHCP.

    <Huawei> system-view
    [~Huawei] sysname SwitchB
    [*Huawei] commit
    [~SwitchB] dhcp enable
    [*SwitchB] commit

  2. Create address pools and set the attributes of the address pools.

    # Set the attributes of IP address pool 1, including the address pool range, DNS server address, gateway address, and address lease.

    [~SwitchB] ip pool pool1
    [*SwitchB-ip-pool-pool1] gateway-list 10.1.1.1
    [*SwitchB-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.128
    [*SwitchB-ip-pool-pool1] dns-list 10.1.1.2
    [*SwitchB-ip-pool-pool1] excluded-ip-address 10.1.1.2
    [*SwitchB-ip-pool-pool1] excluded-ip-address 10.1.1.4
    [*SwitchB-ip-pool-pool1] lease day 10
    [*SwitchB-ip-pool-pool1] commit
    [~SwitchB-ip-pool-pool1] quit

    # Set the attributes of IP address pool 2, including the address pool range, DNS server address, egress gateway address, NetBIOS server address, and address lease.

    [~SwitchB] ip pool pool2
    [*SwitchB-ip-pool-pool2] gateway-list 10.1.1.129
    [*SwitchB-ip-pool-pool2] network 10.1.1.128 mask 255.255.255.128
    [*SwitchB-ip-pool-pool2] dns-list 10.1.1.2
    [*SwitchB-ip-pool-pool2] nbns-list 10.1.1.4
    [*SwitchB-ip-pool-pool2] lease day 2
    [*SwitchB-ip-pool-pool2] commit
    [~SwitchB-ip-pool-pool2] quit

  3. Set the address assignment mode on the VLANIF interfaces.

    # Add 10GE1/0/1 and 10GE1/0/2 to the corresponding VLANs.

    [~SwitchB] vlan batch 10 20
    [*SwitchB] interface 10ge 1/0/1 
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit
    [~SwitchB] interface 10ge 1/0/2 
    [~SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchB-10GE1/0/2] commit
    [~SwitchB-10GE1/0/2] quit
    

    # Configure an IP address for VLANIF10.

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 10.1.1.1 255.255.255.128
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit

    # Configure an IP address for VLANIF20.

    [~SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ip address 10.1.1.129 255.255.255.128
    [*SwitchB-Vlanif20] commit
    [~SwitchB-Vlanif20] quit

  4. Verify the configuration.

    # Run the display ip pool command on SwitchB to view the IP address pool configuration.

    [~SwitchB] display ip pool
     -----------------------------------------------------------------------------  
      Pool name      : pool1                                                        
      Pool number    : 0                                                           
      Position       : Local           Status           : Unlocked               
      Gateway        : 10.1.1.1                                                 
      Mask           : 255.255.255.128                                          
      VPN instance   : --                                                       
                                                                                
     ----------------------------------------------------------------------------- 
      Pool name      : pool2                                                      
      Pool number    : 1                                                           
      Position       : Local           Status           : Unlocked             
      Gateway        : 10.1.1.129                                              
      Mask           : 255.255.255.128                                     
      VPN instance   : --                                                
                                                                           
                                                                          
      IP address Statistic                                                
        Total       :250                                                  
        Used        :6          Idle        :242        Expired     :0     
        Conflict    :0          Disable   :2     
    

Configuration Files

Configuration file of SwitchB

#
sysname SwitchB
#
vlan batch 10 20
#
dhcp enable
#
ip pool pool1
 gateway-list 10.1.1.1
 network 10.1.1.0 mask 255.255.255.128
 lease day 10 hour 0 minute 0
 dns-list 10.1.1.2
 excluded-ip-address 10.1.1.2
 excluded-ip-address 10.1.1.4
#
ip pool pool2
 gateway-list 10.1.1.129
 network 10.1.1.128 mask 255.255.255.128
 lease day 2 hour 0 minute 0
 dns-list 10.1.1.2
 nbns-list 10.1.1.4
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.128
#
interface Vlanif20
 ip address 10.1.1.129 255.255.255.128
#
interface 10GE1/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface 10GE1/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1100039535

Views: 38895

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next