No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 12800 and 12800E V200R005C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IPv6 DNS Client

Example for Configuring an IPv6 DNS Client

Networking Requirements

As shown in Figure 9-2, SwitchA functions as an IPv6 DNS client to interact with the IPv6 DNS server. The user requires that SwitchA can use the domain name huawei.com to access the server with the IPv6 address fc00:2::1/64.

The user requires that SwitchA can use the domain name SwitchB to access the device; therefore, configure IPv6 static domain name resolution entries of SwitchB on SwitchA.

Figure 9-2 Networking diagram for configuring the IPv6 DNS client

Configuration Roadmap

The configuration roadmap of IPv6 DNS client is as follows:

  1. Configure an IPv6 address for each interface on SwitchA and SwitchB, and configure static routes so that there are reachable routes between devices.

  2. Configure IPv6 static domain name resolution entries on SwitchA so that SwitchA can use the domain name to communicate with SwitchB.

  3. Configure the IPv6 dynamic domain name resolution function on SwitchA so that SwitchA can use the dynamic DNS query method to communicate with the IPv6 DNS server.

Procedure

  1. Configure an IPv6 address and static routes for each interface on SwitchA and SwitchB.

    # Add interfaces on SwitchA to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 101
    [*SwitchA-vlan101] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 101
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # Configure an IPv6 address for the VLANIF interface on SwitchA.

    [~SwitchA] interface vlanif 101
    [*SwitchA-Vlanif101] ipv6 enable
    [*SwitchA-Vlanif101] ipv6 address fc00:1::1/64
    [*SwitchA-Vlanif101] quit
    [*SwitchA] commit

    # Configure the static routes from SwitchA to two servers.

    [~SwitchA] ipv6 route-static fc00:2:: 64 fc00:1::2
    [*SwitchA] ipv6 route-static fc00:3:: 64 fc00:1::2
    [*SwitchA] commit

    # Add interfaces on SwitchB to VLANs.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 101 102 103
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 101
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 102
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] interface 10ge 1/0/3
    [*SwitchB-10GE1/0/3] port link-type trunk
    [*SwitchB-10GE1/0/3] port trunk allow-pass vlan 103
    [*SwitchB-10GE1/0/3] quit
    [*SwitchB] commit

    # Configure IPv6 addresses for the VLANIF interfaces on SwitchB.

    [~SwitchB] interface vlanif 101
    [*SwitchB-Vlanif101] ipv6 enable
    [*SwitchB-Vlanif101] ipv6 address fc00:1::2/64
    [*SwitchB-Vlanif101] quit
    [*SwitchB] interface vlanif 102
    [*SwitchB-Vlanif102] ipv6 enable
    [*SwitchB-Vlanif102] ipv6 address fc00:2::2/64
    [*SwitchB-Vlanif102] quit
    [*SwitchB] interface vlanif 103
    [*SwitchB-Vlanif103] ipv6 enable
    [*SwitchB-Vlanif103] ipv6 address fc00:3::2/64
    [*SwitchB-Vlanif103] quit
    [*SwitchB] commit
    NOTE:

    To implement the IPv6 dynamic domain name resolution function, ensure that the routes from the two servers to SwitchA are reachable.

  2. Configure IPv6 static domain name resolution entries on SwitchA.

    [~SwitchA] ipv6 host SwitchB fc00:1::2
    [*SwitchA] commit

  3. Configure the IPv6 dynamic domain name resolution function on SwitchA.

    [~SwitchA] dns resolve
    [*SwitchA] dns server ipv6 fc00:3::1
    [*SwitchA] commit

  4. Verify the configuration.

    # Run the ping ipv6 huawei.com command on SwitchA. The command output shows that the ping operation is successful and the destination address is fc00:2::1.

    [~SwitchA] ping ipv6 huawei.com
      PING huawei.com (FC00:2::1): 56  data bytes, press CTRL_C to break
        Reply from FC00:2::1 
        bytes=56 Sequence=1 hop limit=64 time=8 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=2 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=3 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=4 hop limit=64 time=1 ms
        Reply from FC00:2::1 
        bytes=56 Sequence=5 hop limit=64 time=1 ms
                
      ---FC00:2::1 ping statistics---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max=1/2/8 ms

    # Run the display ipv6 host command on SwitchA. The command output shows the mapping between host names and IPv6 addresses in the IPv6 static domain name resolution table.

    [~SwitchA] display ipv6 host
    Host Name            Age        Flags  Address                                                                                      
    ------------------------------------------------                                                                                    
    SwitchB                0        static FC00:1::2 

    # Run the display dns ipv6 dynamic-host command on SwitchA. The command output shows information about dynamic IPv6 DNS entries in the dynamic cache.

    [~SwitchA] display dns ipv6 dynamic-host
    No   Domain Name           Ipv6address                              TTL          Alias 
    1    huawei.com            FC00:2::1                                  6   

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    ipv6 host SwitchB FC00:1::2
    #
    dns resolve
    dns server ipv6 FC00:3::1
    #
    vlan batch 101
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::1/64
    #                                                                               
    interface 10GE1/0/1                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 101                                                 
    #                                                                               
    ipv6 route-static FC00:2:: 64 FC00:1::2                                             
    ipv6 route-static FC00:3:: 64 FC00:1::2  
    #
    return
    
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 101 to 103
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::2/64
    #                                                                               
    interface Vlanif102
     ipv6 enable
     ipv6 address FC00:2::2/64
    #                                                                               
    interface Vlanif103
     ipv6 enable
     ipv6 address FC00:3::2/64
    #                                                                               
    interface 10GE1/0/1                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 101                                                 
    #                                                                               
    interface 10GE1/0/2                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 102                                                 
    #                                                                               
    interface 10GE1/0/3                                                             
     port link-type trunk                                                           
     port trunk allow-pass vlan 103                                                 
    #                                                                               
    return
    
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1100039535

Views: 40701

Downloads: 25

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next