No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 12800 and 12800E V200R005C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring 6PE

Example for Configuring 6PE

Networking Requirements

As shown in Figure 10-9, an enterprise has two data centers: data center A and data center B. The two data centers are deployed as IPv6 networks. The gateway of data center A's server Server_1 is CE_1; the gateway of data center B's server Server_2 is CE_2. Data center A and data center B access the IPv4/MPLS backbone network through PE_1 and PE_2. The IPv4/MPLS backbone network resides between PE_1 and PE_2.

The enterprise requires that data center A and data center B communicate through the IPv4/MPLS backbone network so that Server_1 in data center A and Server_2 in data center B can communicate with each other.

NOTE:

Before using MPLS functions, purchase a license.

Figure 10-9 Networking diagram for configuring 6PE

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for device interfaces.

  2. Enable MPLS on PE_1 and PE_2.

  3. Configure 6PE peers on PE_1 and PE_2.

  4. Configure static routes on CE_1, CE_2, PE_1 and PE_2.

Procedure

  1. Configure IP addresses for device interfaces.

    # Configure PE_1.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE_1
    [*HUAWEI] commit
    [~PE_1] vlan batch 100 200
    [*PE_1] interface 10ge 1/0/1
    [*PE_1-10GE1/0/1] port link-type trunk
    [*PE_1-10GE1/0/1] port trunk allow-pass vlan 100
    [*PE_1-10GE1/0/1] quit
    [*PE_1] interface 10ge 1/0/2
    [*PE_1-10GE1/0/2] port link-type trunk
    [*PE_1-10GE1/0/2] port trunk allow-pass vlan 200
    [*PE_1-10GE1/0/2] quit
    [*PE_1] interface vlanif 100
    [*PE_1-Vlanif100] ipv6 enable
    [*PE_1-Vlanif100] ipv6 address fc00:3::1 64
    [*PE_1-Vlanif100] quit
    [*PE_1] interface vlanif 200
    [*PE_1-Vlanif200] ip address 4.3.5.1 24
    [*PE_1-Vlanif200] quit
    [*PE_1] interface loopback 0
    [*PE_1-LoopBack0] ip address 1.1.1.9 255.255.255.255
    [*PE_1-LoopBack0] quit
    [*PE_1] commit
    

    # Configure PE_2.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE_2
    [*HUAWEI] commit
    [~PE_2] vlan batch 100 200
    [*PE_2] interface 10ge 1/0/1
    [*PE_2-10GE1/0/1] port link-type trunk
    [*PE_2-10GE1/0/1] port trunk allow-pass vlan 100
    [*PE_2-10GE1/0/1] quit
    [*PE_2] interface 10ge 1/0/2
    [*PE_21-10GE1/0/2] port link-type trunk
    [*PE_21-10GE1/0/2] port trunk allow-pass vlan 200
    [*PE_21-10GE1/0/2] quit
    [*PE_2] interface vlanif 100
    [*PE_21-Vlanif100] ipv6 enable
    [*PE_21-Vlanif100] ipv6 address fc00:4::1 64
    [*PE_2-Vlanif100] quit
    [*PE_21] interface vlanif 200
    [*PE_2-Vlanif200] ip address 4.3.5.2 24
    [*PE_2-Vlanif200] quit
    [*PE_2] interface loopback 0
    [*PE_2-LoopBack0] ip address 2.2.2.9 255.255.255.255
    [*PE_2-LoopBack0] quit
    [*PE_2] commit
    

    # Configure CE_1.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE_1
    [*HUAWEI] commit
    [~CE_1] vlan batch 100 300
    [*CE_1] interface 10ge 1/0/1
    [*CE_1-10GE1/0/1] port link-type trunk
    [*CE_1-10GE1/0/1] port trunk allow-pass vlan 100
    [*CE_1-10GE1/0/1] quit
    [*CE_1] interface 10ge 1/0/2
    [*CE_1-10GE1/0/2] port default vlan 300
    [*CE_1-10GE1/0/2] quit
    [*CE_1] interface vlanif 100
    [*CE_1-Vlanif100] ipv6 enable
    [*CE_1-Vlanif100] ipv6 address fc00:3::2 64
    [*CE_1-Vlanif100] quit
    [*CE_1] interface vlanif 300
    [*CE_1-Vlanif300] ipv6 enable
    [*CE_1-Vlanif300] ipv6 address fc00:1::1 64
    [*CE_1-Vlanif300] quit
    [*CE_1] commit
    

    # Configure CE_2.

    <HUAWEI> system-view
    [~HUAWEI] sysname CE_2
    [*HUAWEI] commit
    [~CE_2] vlan batch 100 300
    [*CE_2] interface 10ge 1/0/1
    [*CE_2-10GE1/0/1] port link-type trunk
    [*CE_2-10GE1/0/1] port trunk allow-pass vlan 100
    [*CE_2-10GE1/0/1] quit
    [*CE_2] interface 10ge 1/0/2
    [*CE_2-10GE1/0/2] port default vlan 300
    [*CE_2-10GE1/0/2] quit
    [*CE_2] interface vlanif 100
    [*CE_2-Vlanif100] ipv6 enable
    [*CE_2-Vlanif100] ipv6 address fc00:4::2 64
    [*CE_2-Vlanif100] quit
    [*CE_2] interface vlanif 300
    [*CE_2-Vlanif300] ipv6 enable
    [*CE_2-Vlanif300] ipv6 address fc00:2::1 64
    [*CE_2-Vlanif300] quit
    [*CE_2] commit
    

  2. Enable MPLS on PE_1 and PE_2.

    # Enable MPLS and LDP on PE_1.

    [~PE_1] mpls lsr-id 1.1.1.9
    [*PE_1] mpls
    [*PE_1-mpls] lsp-trigger all
    [*PE_1-mpls] quit
    [*PE_1] mpls ldp
    [*PE_1-mpls-ldp] quit
    [*PE_1] interface vlanif 200
    [*PE_1-Vlanif200] mpls
    [*PE_1-Vlanif200] mpls ldp
    [*PE_1-Vlanif200] quit
    [*PE_1] commit
    

    # Enable MPLS and LDP on PE_2.

    [~PE_2] mpls lsr-id 2.2.2.9
    [*PE_2] mpls
    [*PE_2-mpls] lsp-trigger all
    [*PE_2-mpls] quit
    [*PE_2] mpls ldp
    [*PE_2-mpls-ldp] quit
    [*PE_2] interface vlanif 200
    [*PE_2-Vlanif200] mpls
    [*PE_2-Vlanif200] mpls ldp
    [*PE_2-Vlanif200] quit
    [*PE_2] commit
    

    # Configure OSPF on PE_1 to trigger the setup of an LSP.

    [~PE_1] ospf
    [*PE_1-ospf-1] area 0
    [*PE_1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [*PE_1-ospf-1-area-0.0.0.0] network 4.3.5.0 0.0.0.255
    [*PE_1-ospf-1-area-0.0.0.0] quit
    [*PE_1-ospf-1] quit
    [*PE_1] commit
    

    # Configure OSPF on PE_2 to trigger the setup of an LSP.

    [~PE_2] ospf
    [*PE_2-ospf-1] area 0
    [*PE_2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [*PE_2-ospf-1-area-0.0.0.0] network 4.3.5.0 0.0.0.255
    [*PE_2-ospf-1-area-0.0.0.0] quit
    [*PE_2-ospf-1] quit
    [*PE_2] commit
    

  3. Configure 6PE peers on PE_1 and PE_2.

    # Configure IBGP on PE_1, enable the 6PE capability on the peer, and import direct and static IPv6 routes.

    [~PE_1] bgp 65100
    [*PE_1-bgp] peer 2.2.2.9 as-number 65100
    [*PE_1-bgp] peer 2.2.2.9 connect-interface loopback 0
    [*PE_1-bgp] ipv6-family
    [*PE_1-bgp-af-ipv6] import-route direct
    [*PE_1-bgp-af-ipv6] import-route static
    [*PE_1-bgp-af-ipv6] peer 2.2.2.9 enable
    [*PE_1-bgp-af-ipv6] peer 2.2.2.9 label-route-capability
    [*PE_1-bgp-af-ipv6] apply-label explicit-null
    [*PE_1-bgp-af-ipv6] quit
    [*PE_1-bgp] quit
    [*PE_1] commit
    

    # Configure IBGP on PE_2, enable the 6PE capability on the peer, and import direct and static IPv6 routes.

    [~PE_2] bgp 65100
    [*PE_2-bgp] peer 1.1.1.9 as-number 65100
    [*PE_2-bgp] peer 1.1.1.9 connect-interface loopback 0
    [*PE_2-bgp] ipv6-family
    [*PE_2-bgp-af-ipv6] import-route direct
    [*PE_2-bgp-af-ipv6] import-route static
    [*PE_2-bgp-af-ipv6] peer 1.1.1.9 enable
    [*PE_2-bgp-af-ipv6] peer 1.1.1.9 label-route-capability
    [*PE_2-bgp-af-ipv6] apply-label explicit-null
    [*PE_2-bgp-af-ipv6] quit
    [*PE_2-bgp] quit
    [*PE_2] commit
    

  4. Configure static routes on CE_1, CE_2, PE_1 and PE_2.

    # Configure CE_1.

    [~CE_1] ipv6 route-static :: 0 vlanif 100 fc00:3::1
    [*CE_1] commit

    # Configure CE_2.

    [~CE_2] ipv6 route-static :: 0 vlanif 100 fc00:4::1
    [*CE_2] commit

    # Configure PE_1.

    [~PE_1] ipv6 route-static fc00:1:: 64 vlanif 100 fc00:3::2
    [*PE_1] commit
    

    # Configure PE_2.

    [~PE_2] ipv6 route-sattic fc00:2:: 64 vlanif 100 fc00:4::2
    [*PE_2] commit
    

  5. Verify the configuration.

    # CE_1 can ping the IPv6 address of CE_2 successfully.

    [~CE_1] ping ipv6 fc00:4::2
    PING FC00:4::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:4::2
        bytes=56 Sequence=1 hop limit=63  time = 50 ms
        Reply from FC00:4::2
        bytes=56 Sequence=2 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=3 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=4 hop limit=63  time = 1 ms
        Reply from FC00:4::2
        bytes=56 Sequence=5 hop limit=63  time = 1 ms
    
      --- FC00:4::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/10/50 ms 

    # Server_1 and Server_2 can ping each other.

Configuration Files

  • Configuration file of PE_1

    #
    sysname PE_1
    #
    vlan batch 100 200
    #
    mpls lsr-id 1.1.1.9
    #
    mpls
     lsp-trigger all
    #
    mpls ldp
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:3::1/64
    #
    interface Vlanif200
     ip address 4.3.5.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 65100
     peer 2.2.2.9 as-number 65100
     peer 2.2.2.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 2.2.2.9 enable
     #
     ipv6-family unicast
      apply-label explicit-null
      import-route direct
      import-route static
      peer 2.2.2.9 enable
      peer 2.2.2.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 4.3.5.0 0.0.0.255
    #
    ipv6 route-static FC00:1:: 64 Vlanif100 FC00:3::2 
    #
    return
  • Configuration file of PE_2

    #
    sysname PE_2
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    #
    mpls
     lsp-trigger all
    #
    mpls ldp
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:4::1/64
    #
    interface Vlanif200
     ip address 4.3.5.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 65100
     peer 1.1.1.9 as-number 65100
     peer 1.1.1.9 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 1.1.1.9 enable
     #
     ipv6-family unicast
      apply-label explicit-null
      import-route direct
      import-route static
      peer 1.1.1.9 enable
      peer 1.1.1.9 label-route-capability
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 4.3.5.0 0.0.0.255
    #
    ipv6 route-static FC00:2:: 64 Vlanif100 FC00:4::2 
    #
    return
  • Configuration file of CE_1

    #
    sysname CE_1
    #
    vlan batch 100 300
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:3::2 64
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:1::1 64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    ipv6 route-static :: 0 Vlanif100 FC00:3::1
    #
    return
  • Configuration file of CE_2

    #
    sysname CE_2
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:4::2 64
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:2::1 64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    ipv6 route-static :: 0 Vlanif100 FC00:4::1
    #
    return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1100039535

Views: 38663

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next