No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 12800 and 12800E V200R005C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IPv6 over IPv4 Manual Tunnel

Example for Configuring an IPv6 over IPv4 Manual Tunnel

Networking Requirements

As shown in Figure 10-7, an enterprise has two data centers: data center A and data center B. The two data centers are deployed as IPv6 networks. The gateway of data center A's server Server_1 is Switch_1; the gateway of data center B's server Server_2 is Switch_2. There is an IPv4 network between the two data centers, and there are reachable routes between Router_1 and Router_2 on the IPv4 network.

The enterprise wants to establish a stable link between data center A and data center B so that Server_1 in data center A and Server_2 in data center B can communicate with each other.

Figure 10-7 Networking diagram for configuring an IPv6 over IPv4 manual tunnel

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on Switch_1 and Switch_2 so that Switch_1 can communicate with the IPv4 network and IPv6 network of data center A and Switch_2 can communicate with the IPv4 network and IPv6 network of data center B.

  2. Configure OSPF routes to ensure that there are reachable IPv4 routes between Switch_1 and Switch_2.

  3. Configure tunnel interfaces to establish an IPv6 over IPv4 manual tunnel between Switch_1 and Switch_2.

  4. Configure tunnel routes using static routing to ensure that Server_1 and Server_2 can communicate through the IPv6 over IPv4 manual tunnel.

Procedure

  1. Configure an IP address for each physical interface.

    # Configure Switch_1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_1
    [*HUAWEI] commit
    [~Switch_1] vlan batch 100 300
    [*Switch_1] interface 10ge 1/0/1
    [*Switch_1-10GE1/0/1] port link-type trunk
    [*Switch_1-10GE1/0/1] port trunk allow-pass vlan 100
    [*Switch_1-10GE1/0/1] quit
    [*Switch_1] interface 10ge 1/0/2
    [*Switch_1-10GE1/0/2] port default vlan 300
    [*Switch_1-10GE1/0/2] quit
    [*Switch_1] interface vlanif 100
    [*Switch_1-Vlanif100] ip address 192.168.50.2 24
    [*Switch_1-Vlanif100] quit
    [*Switch_1] interface vlanif 300
    [*Switch_1-Vlanif300] ipv6 enable
    [*Switch_1-Vlanif300] ipv6 address fc00:1::1 64
    [*Switch_1-Vlanif300] quit
    [*Switch_1] commit
    

    # Configure Switch_2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch_2
    [*HUAWEI] commit
    [~Switch_2] vlan batch 200 300
    [*Switch_2] interface 10ge 1/0/1
    [*Switch_2-10GE1/0/1] port link-type trunk
    [*Switch_2-10GE1/0/1] port trunk allow-pass vlan 200
    [*Switch_2-10GE1/0/1] quit
    [*Switch_2] interface 10ge 1/0/2
    [*Switch_2-10GE1/0/2] port default vlan 300
    [*Switch_2-10GE1/0/2] quit
    [*Switch_2] interface vlanif 200
    [*Switch_2-Vlanif200] ip address 192.168.51.2 24
    [*Switch_2-Vlanif200] quit
    [*Switch_2] interface vlanif 300
    [*Switch_2-Vlanif300] ipv6 enable
    [*Switch_2-Vlanif300] ipv6 address fc00:2::1 64
    [*Switch_2-Vlanif300] quit
    [*Switch_2] commit
    

  2. Configure OSPF routes to ensure that there are reachable IPv4 routes between Switch_1 and Switch_2.

    # Configure Switch_1.

    [~Switch_1] ospf 1
    [*Switch_1-ospf-1] area 0
    [*Switch_1-ospf-1-area-0.0.0.0] network 192.168.50.0 0.0.0.255
    [*Switch_1-ospf-1-area-0.0.0.0] quit
    [*Switch_1-ospf-1] quit
    [*Switch_1] commit
    

    # Configure Switch_2.

    [~Switch_2] ospf 1
    [*Switch_2-ospf-1] area 0
    [*Switch_2-ospf-1-area-0.0.0.0] network 192.168.51.0 0.0.0.255
    [*Switch_2-ospf-1-area-0.0.0.0] quit
    [*Switch_2-ospf-1] quit
    [*Switch_2] commit
    

  3. Configure tunnel interfaces.

    # Configure Switch_1 .

    [~Switch_1] interface tunnel 1
    [*Switch_1-Tunnel1] tunnel-protocol ipv6-ipv4
    [*Switch_1-Tunnel1] source 192.168.50.2
    [*Switch_1-Tunnel1] destination 192.168.51.2
    [*Switch_1-Tunnel1] ipv6 enable
    [*Switch_1-Tunnel1] ipv6 address fc00:3::1 64
    [*Switch_1-Tunnel1] quit
    [*Switch_1] commit
    

    # Configure Switch_2 .

    [~Switch_2] interface tunnel 1
    [*Switch_2-Tunnel1] tunnel-protocol ipv6-ipv4
    [*Switch_2-Tunnel1] source 192.168.51.2
    [*Switch_2-Tunnel1] destination 192.168.50.2
    [*Switch_2-Tunnel1] ipv6 enable
    [*Switch_2-Tunnel1] ipv6 address fc00:3::2 64
    [*Switch_2-Tunnel1] quit
    [*Switch_2] commit
    

  4. Configuring Tunnel Routes

    # Configure Switch_1.

    [~Switch_1] ipv6 route-static fc00:2:: 64 tunnel 1
    [*Switch_1] commit
    [~Switch_1] quit
    

    # Configure Switch_2.

    [~Switch_2] ipv6 route-static fc00:1:: 64 tunnel 1
    [*Switch_2] commit
    [~Switch_2] quit
    

  5. Verify the configuration.

    # Switch_1 can ping the IPv4 address (192.168.51.2) of VLANIF 200 on Switch_2 successfully.

    <Switch_1> ping 192.168.51.2
      PING 192.168.51.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.51.2: bytes=56 Sequence=1 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=2 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=3 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=4 ttl=253 time=1 ms
        Reply from 192.168.51.2: bytes=56 Sequence=5 ttl=253 time=1 ms
    
      --- 192.168.51.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/1/1 ms

    # Switch_1 can ping the IPv6 address (fc00:3::2) of Tunnel1 on Switch_2 successfully.

    <Switch_1> ping ipv6 FC00:3::2
      PING FC00:3::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:3::2
        bytes=56 Sequence=1 hop limit=63  time = 28 ms
        Reply from FC00:3::2
        bytes=56 Sequence=2 hop limit=63  time = 27 ms
        Reply from FC00:3::2
        bytes=56 Sequence=3 hop limit=63  time = 26 ms
        Reply from FC00:3::2
        bytes=56 Sequence=4 hop limit=63  time = 27 ms
        Reply from FC00:3::2
        bytes=56 Sequence=5 hop limit=63  time = 26 ms
      --- FC00:3::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 26/26/28 ms

    # Server_1 and Server_2 can ping each other.

Configuration Files

  • Configuration file of Switch_1

    #
    sysname Switch_1
    #
    vlan batch 100 300
    #
    interface Vlanif100
     ip address 192.168.50.2 255.255.255.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:1::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::1/64
     tunnel-protocol ipv6-ipv4
     source 192.168.50.2
     destination 192.168.51.2
    #
    ospf 1
     area 0.0.0.0
      network 192.168.50.0 0.0.0.255
    #
    ipv6 route-static FC00:2:: 64 Tunnel1
    #
    return
  • Configuration file of Switch_2

    #
    sysname Switch_2
    #
    vlan batch 200 300
    #
    interface Vlanif200
     ip address 192.168.51.2 255.255.255.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address FC00:2::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port default vlan 300
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::2/64
     tunnel-protocol ipv6-ipv4
     source 192.168.51.2
     destination 192.168.50.2
    #
    ospf 1
     area 0.0.0.0
      network 192.168.51.0 0.0.0.255
    #
    ipv6 route-static FC00:1:: 64 Tunnel1
    #
    return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1100039535

Views: 43718

Downloads: 25

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next