No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 12800 and 12800E V200R005C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intra-VLAN Proxy ARP

Example for Configuring Intra-VLAN Proxy ARP

Networking Requirements

In Figure 2-21, 10GE1/0/1 and 10GE1/0/2 belong to sub-VLAN2. VLAN2 is a sub-VLAN of super-VLAN3. Requirements:
  • ServerA and ServerB in VLAN2 are isolated at Layer 2.
  • ServerA and ServerB can communicate at Layer 3 using Intra-VLAN proxy ARP.

The IP address of the VLANIF interface corresponding to the super-VLAN is 10.10.10.1 and the mask is 255.255.255.0.

Figure 2-21 Networking diagram for configuring intra-VLAN proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create and configure a super-VLAN and sub-VLAN.
  2. Add interfaces to the sub-VLAN.
  3. Create a VLANIF interface corresponding to the super-VLAN and configure an IP address for the VLANIF interface.
  4. Enable intra-VLAN proxy ARP on the VLANIF interface.

Procedure

  1. Configure a super-VLAN and sub-VLAN.

    # Configure sub-VLAN2.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] commit
    [~Switch-vlan2] quit
    # Enable Layer 2 interface isolation on 10GE1/0/1 and 10GE1/0/2.
    [~Switch] interface 10ge 1/0/1
    [~Switch-10GE1/0/1] port-isolate enable group 1
    [*Switch-10GE1/0/1] quit
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port-isolate enable group 1
    [*Switch-10GE1/0/2] quit
    [*Switch] commit
    # Add 10GE1/0/1 and 10GE1/0/2 to sub-VLAN2.
    [~Switch] interface 10ge 1/0/1
    [~Switch-10GE1/0/1] port default vlan 2
    [*Switch-10GE1/0/1] quit
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port default vlan 2
    [*Switch-10GE1/0/2] quit
    [*Switch] commit
    # Configure super-VLAN3 and add sub-VLAN2 to super-VLAN3.
    [~Switch] vlan 3
    [*Switch-vlan3] aggregate-vlan
    [*Switch-vlan3] access-vlan 2
    [*Switch-vlan3] quit
    [*Switch] commit

  2. Create and configure VLANIF3.

    # Create VLANIF3.

    [~Switch] interface vlanif 3

    # Configure an IP address for VLANIF3.

    [*Switch-Vlanif3] ip address 10.10.10.1 24

  3. Enable intra-VLAN proxy ARP on VLANIF3.

    [*Switch-Vlanif3] arp proxy intra-vlan enable
    [*Switch-Vlanif3] commit
    [~Switch-Vlanif3] quit
    [~Switch] quit

  4. Configure servers.

    # Configure IP address 10.10.10.2/24 for ServerA.

    # Configure IP address 10.10.10.3/24 for ServerB.

  5. Verify the configuration.

    # Run the display arp command to check all ARP entries.

    <Switch> display arp
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                                                                             
    EXP: Expire-time
                                                                                                                                        
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE                                                        
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      0018-2000-0083        I         Vlanif3                                                                             
    10.10.10.3      00e0-fc00-0003   20   D/2       10GE1/0/1                                                                           
    10.10.10.2      00e0-fc00-0002   20   D/2       10GE1/0/2                                                                           
    ------------------------------------------------------------------------------                                                      
    Total:3          Dynamic:2       Static:0    Interface:1  

    # ServerA and ServerB can ping through each other.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 3 
#
vlan 3
 aggregate-vlan
 access-vlan 2
#
interface Vlanif3
 ip address 10.10.10.1 255.255.255.0
 arp proxy intra-vlan enable
#
interface 10GE1/0/1
 port default vlan 2
 port-isolate enable group 1
#
interface 10GE1/0/2
 port default vlan 2
 port-isolate enable group 1
#
return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1100039535

Views: 43716

Downloads: 25

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next