No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Static Multicast MAC Address

Example for Configuring a Static Multicast MAC Address

Networking Requirements

As shown in Figure 11-3, the Router connects to a user network through the Switch. There are three receivers on the network: HostA, HostB, and HostC. As service requires, HostA and HostC receive packets with destination address 0x0100-5A0A-0A0A but HostB cannot.

Figure 11-3 Network diagram for configuring a static multicast MAC address

Configuration Roadmap

To meet the preceding requirement, configure static multicast MAC addresses on the Layer 2 Switch. The configuration roadmap is as follows:

  1. Create a VLAN on the Switch and add interfaces to the VLAN.
  2. Configure the static multicast MAC address: 0x0100-5A0A-0A0A on 10GE1/0/1 and 10GE1/0/2.

Procedure

  1. Create a VLAN and add the interface to the VLAN.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 10
    [*Switch-vlan10] quit
    [*Switch] interface 10GE 1/0/1
    [*Switch-10GE1/0/1] port default vlan 10
    [*Switch-10GE1/0/1] quit
    [*Switch] interface 10GE 1/0/2
    [*Switch-10GE1/0/2] port default vlan 10
    [*Switch-10GE1/0/2] quit
    [*Switch] interface 10GE 1/0/3
    [*Switch-10GE1/0/3] port default vlan 10
    [*Switch-10GE1/0/3] quit
    [*Switch] interface 10GE 1/0/4
    [*Switch-10GE1/0/4] port link-type trunk
    [*Switch-10GE1/0/4] port trunk allow-pass vlan 10
    [*Switch-10GE1/0/4] quit
    [*Switch] commit

  2. Configure a static multicast MAC address.

    [~Switch] interface 10GE 1/0/1
    [~Switch-10GE1/0/1] mac-address multicast 0100-5a0a-0a0a vlan 10
    [*Switch-10GE1/0/1] quit
    [*Switch] interface 10GE 1/0/2
    [*Switch-10GE1/0/2] mac-address multicast 0100-5a0a-0a0a vlan 10
    [*Switch-10GE1/0/2] quit
    [*Switch] commit
    

  3. Verify the configuration.

    # Display configured MAC address entries.

    [~Switch] display mac-address multicast 
     --------------------------------------------------------------------            
    MAC Address         VLANID         Out-Interface                                
    --------------------------------------------------------------------            
    0100-5a0a-0a0a      10             10GE1/0/1                                    
                                       10GE1/0/2                                    
                                                2 port(s)                           
    --------------------------------------------------------------------            
     Total Group(s) : 1                                                             
    

    The command output shows that static multicast MAC address entries are configured on 10GE1/0/1 and 10GE1/0/2.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface 10GE1/0/1
     port default vlan 10
     mac-address multicast 0100-5a0a-0a0a vlan 10
    #
    interface 10GE1/0/2
     port default vlan 10
     mac-address multicast 0100-5a0a-0a0a vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100039595

Views: 47264

Downloads: 85

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next