No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast VLAN Replication Based on User VLANs

Example for Configuring Multicast VLAN Replication Based on User VLANs

Networking Requirements

in Figure 12-3, service VLAN 10 is used to transmit multicast data between RouterA and SwitchA. HostA, HostB, and HostC belong to VLAN 100, VLAN 200, and VLAN 300, respectively. All of them want to receive multicast data from Source.

You can configure multicast VLAN replication based on user VLANs, so that RouterA only needs to send multicast data to VLAN 10 in response to the same multicast data request from different user hosts. This reduces bandwidth consumption between RouterA and SwitchA.

Figure 12-3 Configuring multicast VLAN replication based on user VLANs

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable IGMP snooping in the system view.
  2. Create user VLANs and enable IGMP snooping in the user VLANs.
  3. Create a multicast VLAN and enable IGMP snooping in the multicast VLAN.
  4. Bind the user VLANs to the multicast VLAN.
  5. Add the network-side interface and user-side interfaces to the VLANs as access interfaces.

Procedure

  1. Enable IGMP snooping in the system view.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] igmp snooping enable
    [*SwitchA] commit
    

  2. Create user VLANs and enable IGMP snooping in the user VLANs.

    [~SwitchA] vlan 100
    [*SwitchA-vlan100] igmp snooping enable
    [*SwitchA-vlan100] quit
    [*SwitchA] vlan 200
    [*SwitchA-vlan200] igmp snooping enable
    [*SwitchA-vlan200] quit
    [*SwitchA] vlan 300
    [*SwitchA-vlan300] igmp snooping enable
    [*SwitchA-vlan300] commit
    [~SwitchA-vlan300] quit
    

  3. Create a multicast VLAN and enable IGMP snooping in the multicast VLAN.

    [~SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] multicast vlan enable
    [*SwitchA-vlan10] commit
    

  4. Bind user VLANs 100, 200, and 300 to multicast VLAN 10.

    [~SwitchA-vlan10] multicast vlan user-vlan 100 200 300
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  5. Add interfaces to the VLANs.

    # Add 10GE1/0/1 to multicast VLAN 10, and configure 10GE1/0/1 to allow all the user VLANs.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10 100 200 300 
    [*SwitchA-10GE1/0/1] commit 
    [~SwitchA-10GE1/0/1] quit

    # Add 10GE1/0/2, 10GE1/0/3, and 10GE1/0/4 to user VLANs 100, 200, and 300 respectively.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type access 
    [*SwitchA-10GE1/0/2] port default vlan 100
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type access
    [*SwitchA-10GE1/0/3] port default vlan 200
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type access
    [*SwitchA-10GE1/0/4] port default vlan 300
    [*SwitchA-10GE1/0/4] commit
    [~SwitchA-10GE1/0/4] quit
    
    NOTE:

    On RouterA, configure a Layer 3 sub-interface on the interface connected to SwitchA to terminate packets of VLAN 10, VLAN 100, VLAN 200, and VLAN 300.

  6. Verify the configuration. View information about the multicast VLAN and user VLANs on SwitchA.

    [~SwitchA] display multicast vlan mvlan
     Total: 1                                                        
     multicast-vlan     user-vlan number     snooping-state          
     ----------------------------------------------------------------
                 10                   3      IGMP Enable      
    [~SwitchA] display multicast vlan user-vlan 
     Total: 3                                                              
     user-vlan  snooping-state  multicast-vlan  snooping-state
     -----------------------------------------------------------------------------  
           100  IGMP Enable                10   IGMP Enable 
           200  IGMP Enable                10   IGMP Enable 
           300  IGMP Enable                10   IGMP Enable 

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 100 200 300
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast vlan enable
     multicast vlan user-vlan 100 200 300 
    #
    vlan 100
     igmp snooping enable
    #
    vlan 200
     igmp snooping enable
    #
    vlan 300
     igmp snooping enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10 100 200 300
    #
    interface 10GE1/0/2
     port default vlan 100
    #
    interface 10GE1/0/3
     port default vlan 200
    #
    interface 10GE1/0/4
     port default vlan 300
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100039595

Views: 47639

Downloads: 85

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next