No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 8800, 7800, 6800, and 5800 V200R005C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IGMP Snooping Over VXLAN

Example for Configuring IGMP Snooping Over VXLAN

Networking Requirements

After IGMP snooping over VXLAN is deployed, multicast traffic can be replicated and forwarded based on user requirements on VXLAN ingress nodes. This prevents flooding of multicast traffic in a bridge domain (BD) on a VXLAN network.

As shown in Figure 14-22, an enterprise has VMs deployed in multiple data centers. VM 1 on server 1 and VM 1 on server 2 belong to VLAN 10, and VM 1 on server 3 belongs to VLAN 20. VM 1 on server 1 is a multicast source, whereas the VMs on server 2 and server 3 are multicast users. VXLAN and IGMP snooping need to be configured to enable the users in different data centers to receive multicast data from the multicast source (VM 1 on server 1).

Figure 14-22 Networking diagram for IGMP snooping over VXLAN
Table 14-18 Interface IP addresses

Device

Interface

IP Address

Device1

10GE1/0/1

192.168.1.1/24

LoopBack0

1.1.1.1/32

Device2

10GE1/0/1

192.168.2.1/24

LoopBack0

2.2.2.2/32

Device3

10GE1/0/1

192.168.3.1/24

LoopBack0

3.3.3.3/32

Device4

10GE1/0/1

192.168.1.2/24

10GE1/0/2

192.168.2.2/24

10GE1/0/3

192.168.3.2/24

LoopBack0

4.4.4.4/32

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure a routing protocol on Device1, Device2, Device3, and Device4 to ensure Layer 3 connectivity on the network.
  2. Configure a VXLAN service access point on Device1, Device2, and Device3 to distinguish service traffic.
  3. Enable EVPN as the VXLAN control plane on Device1, Device2, Device3, and Device4. Configure Device1, Device2, and Device3 to establish BGP EVPN peer relationships with Device4 and configure Device4 as RR. Configure an EVPN instance and an ingress replication list on Device1, Device2, and Device3, so that Device1 can establish VXLAN tunnels with Device 2 and Device3.
  4. Enable IGMP snooping globally and in the bridge domain on service access points Device1, Device2, and Device3, and enable IGMP snooping proxy in the bridge domain on Device1 connected to the multicast source.

Data Preparation

To complete the configuration, you need the following data.

  • VMs' VLAN ID (10 and 20)
  • IP addresses of interfaces connecting devices (For details, see Table 14-18.)
  • BD ID (10)
  • VNI ID (10)

Procedure

  1. Configure a routing protocol.

    # Configure Device1. Repeat this step for Device2, Device3, and Device4. For configuration details, see Configuration Files in this section.

    <HUAWEI> system-view
    [~HUAWEI] sysname Device1
    [*HUAWEI] commit
    [~Device1] interface loopback 0
    [*Device1-LoopBack0] ip address 1.1.1.1 32
    [*Device1-LoopBack0] quit
    [*Device1] interface 10ge 1/0/1
    [*Device1-10GE1/0/1] undo portswitch
    [*Device1-10GE1/0/1] ip address 192.168.1.1 24
    [*Device1-10GE1/0/1] quit
    [*Device1] bgp 100
    [*Device1-bgp] peer 192.168.1.2 as-number 400
    [*Device1-bgp] network 1.1.1.1 32
    [*Device1-bgp] quit
    [*Device1] commit

  2. Configure the VXLAN tunnel mode and enable the VXLAN ACL extension function. (Perform this step on the CE6870EI and CE6875EI only.)

    # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.

    [~Device1] ip tunnel mode vxlan
    [*Device1] assign forward nvo3 acl extend enable
    [*Device1] commit
    
    NOTE:

    After modifying the VXLAN tunnel mode or enabling the VXLAN ACL extension function, you need to save the configuration and restart the device to make the configuration take effect. You can restart the device immediately or after completing all the configurations.

  3. Configure a service access point on Device1, Device2, and Device3.

    # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.

    [~Device1] bridge-domain 10
    [*Device1-bd10] quit
    [*Device1] interface 10ge 1/0/2.1 mode l2
    [*Device1-10GE1/0/2.1] encapsulation dot1q vid 10
    [*Device1-10GE1/0/2.1] bridge-domain 10
    [*Device1-10GE1/0/2.1] quit
    [*Device1] commit

  4. Establish VXLAN tunnels between the devices.
    1. Configure EVPN as the VXLAN control plane.

      # Configure Device1. Repeat this step for Device2, Device3, and Device4. For configuration details, see Configuration Files in this section.

      [~Device1] evpn-overlay enable
      [*Device1] commit

    2. Specify Device1, Device2, and Device3 as BGP EVPN peers for Device4 and configure them as RR clients.

      # Specify BGP EVPN peers and RR clients for Device4.
      [~Device4] bgp 100 instance evpn1
      [*Device4-bgp-instance-evpn1] peer 1.1.1.1 as-number 100
      [*Device4-bgp-instance-evpn1] peer 1.1.1.1 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] peer 2.2.2.2 as-number 100
      [*Device4-bgp-instance-evpn1] peer 2.2.2.2 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] peer 3.3.3.3 as-number 100
      [*Device4-bgp-instance-evpn1] peer 3.3.3.3 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] l2vpn-family evpn
      [*Device4-bgp-instance-evpn1-af-evpn] peer 1.1.1.1 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 1.1.1.1 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] peer 2.2.2.2 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 2.2.2.2 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] peer 3.3.3.3 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 3.3.3.3 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] undo policy vpn-target
      [*Device4-bgp-instance-evpn1-af-evpn] quit
      [*Device4-bgp-instance-evpn1] quit
      [*Device4] commit

    3. Specify Device4 as a BGP EVPN peer for Device1, Device2, and Device3.

      # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.
      [~Device1] bgp 100 instance evpn1
      [*Device1-bgp-instance-evpn1] peer 4.4.4.4 as-number 100
      [*Device1-bgp-instance-evpn1] peer 4.4.4.4 connect-interface LoopBack0
      [*Device1-bgp-instance-evpn1] l2vpn-family evpn
      [*Device1-bgp-instance-evpn1-af-evpn] peer 4.4.4.4 enable
      [*Device1-bgp-instance-evpn1-af-evpn] quit
      [*Device1-bgp-instance-evpn1] quit
      [*Device1] commit

    4. Configure an EVPN instance on Device1, Device2, and Device3.

      # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.

      [~Device1] bridge-domain 10
      [*Device1-bd10] vxlan vni 10
      [*Device1-bd10] evpn
      [*Device1-bd10-evpn] route-distinguisher 10:1
      [*Device1-bd10-evpn] vpn-target 10:1
      [*Device1-bd10-evpn] vpn-target 11:1 export-extcommunity
      [*Device1-bd10-evpn] quit
      [*Device1-bd10] quit
      [*Device1] commit

    5. Configure an ingress replication list on Device1, Device2, and Device3.

      # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.

      [~Device1] interface nve 1
      [*Device1-Nve1] source 1.1.1.1
      [*Device1-Nve1] mac-address 0000-5e00-0101
      [*Device1-Nve1] vni 10 head-end peer-list protocol bgp
      [*Device1-Nve1] quit
      [*Device1] commit

  5. Configure IGMP snooping over VXLAN.
    1. Enable IGMP snooping globally and in the bridge domain on access points.

      # Configure Device1. Repeat this step for Device2, and Device3. For configuration details, see Configuration Files in this section.

      [~Device1] igmp snooping enable
      [*Device1] bridge-domain 10
      [*Device1-bd10] igmp snooping enable
      [*Device1-bd10] quit
      [*Device1] commit

    2. Enable IGMP snooping proxy in the bridge domain on Device1.

      # Configure Device1.

      [~Device1] bridge-domain 10
      [*Device1-bd10] igmp snooping proxy
      [*Device1-bd10] quit
      [*Device1] commit

  6. Verify the configuration.

    After completing the configurations, run the display vxlan tunnel command on Device1, Device2, and Device3 to check VXLAN tunnel information. The following example shows the command output on Device1.

    [~Device1] display vxlan tunnel
    Number of vxlan tunnel : 2
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  1.1.1.1               2.2.2.2               up     dynamic  00:14:45
    4026531842  1.1.1.1               3.3.3.3               up     dynamic  00:09:42
    

    After the configuration is complete, VMs on server 2 and server 3 can receive multicast traffic from the VM on server 1. This indicates that multicast traffic can be forwarded on demand over the VXLAN network. Run the display igmp snooping port-info command on Device1, Device2, and Device3 to check information multicast member ports. The command output on Device3 is used as an example:

    [~Device3] display igmp snooping port-info bridge-domain 10 verbose 
    The port information of Group 235.1.1.1 on Bridge-domain 10:
      Time of this group has been up : 00:01:34
    
      The port information of (*, 235.1.1.1):
        Time of this source has been up : 00:01:34
        Port Table on this source(*):
        Source flags: IGMP
        List of ports in include mode :
          No.1
            Port name : 10GE1/0/2.1(VID:20)
            Time of this port has been up as a host-port : 00:01:35
            Remain time of port expire as dynamic host-port : --
            Host-port flags : Dynamic
        There are 1 port(s) in include mode.
    

Configuration Files

  • Device1 configuration file (CE6870EI and CE6875EI)

    #
    sysname Device1
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     igmp snooping proxy
     evpn
      route-distinguisher 10:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 192.168.1.2 as-number 400
     #
     ipv4-family unicast
      network 1.1.1.1 255.255.255.255
      peer 192.168.1.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device1 configuration file (switches excluding the CE6870EI and CE6875EI)

    #
    sysname Device1
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     igmp snooping proxy
     evpn
      route-distinguisher 10:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 192.168.1.2 as-number 400
     #
     ipv4-family unicast
      network 1.1.1.1 255.255.255.255
      peer 192.168.1.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device2 configuration file (CE6870EI and CE6875EI)

    #
    sysname Device2
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 40:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0202
    #
    bgp 200
     peer 192.168.2.2 as-number 400
     #
     ipv4-family unicast
      network 2.2.2.2 255.255.255.255
      peer 192.168.2.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device2 configuration file (switches excluding the CE6870EI and CE6875EI)

    #
    sysname Device2
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 40:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0202
    #
    bgp 200
     peer 192.168.2.2 as-number 400
     #
     ipv4-family unicast
      network 2.2.2.2 255.255.255.255
      peer 192.168.2.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device3 configuration file (CE6870EI and CE6875EI)

    #
    sysname Device3
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 20:1
      vpn-target 20:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 20:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.3.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0303
    #
    bgp 300
     peer 192.168.3.2 as-number 400
     #
     ipv4-family unicast
      network 3.3.3.3 255.255.255.255
      peer 192.168.3.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device3 configuration file (switches excluding the CE6870EI and CE6875EI)

    #
    sysname Device3
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 20:1
      vpn-target 20:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 20:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.3.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0303
    #
    bgp 300
     peer 192.168.3.2 as-number 400
     #
     ipv4-family unicast
      network 3.3.3.3 255.255.255.255
      peer 192.168.3.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device4 configuration file

    #
    sysname Device4
    #
    evpn-overlay enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.3.2 255.255.255.0
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 400
     peer 192.168.1.1 as-number 100
     peer 192.168.2.1 as-number 200
     peer 192.168.3.1 as-number 300
     #
     ipv4-family unicast
      network 4.4.4.4 255.255.255.255
      peer 192.168.2.1 enable
      peer 192.168.3.1 enable
      peer 192.168.4.1 enable
    #
    bgp 100 instance evpn1
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 reflect-client
      peer 3.3.3.3 enable
      peer 3.3.3.3 reflect-client
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100039595

Views: 49130

Downloads: 87

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next