TRILL/3/TRILL_AUTHENTICATION_TYPE_FAILURE
Message
TRILL/3/TRILL_AUTHENTICATION_TYPE_FAILURE: The authentication type of received PDU is different from local configuration. (trillSysInstance=[trillSysInstance], trillCircIndex=[trillCircIndex], trillCircIfIndex=[trillCircIfIndex], trillPduFragment=[trillPduFragment], ifIndex=[ifIndex], IfName=[IfName])
Description
The device received a PDU carrying an authentication mode that was different from the local one.
Parameters
Parameter Name | Parameter Meaning |
---|---|
trillSysInstance |
TRILL process ID |
trillCircIndex |
TRILL interface index |
trillCircIfIndex |
Interface index obtained from the interface management module |
trillPduFragment |
64-byte PDU fragment |
ifIndex |
Interface index defined by the interface management module |
IfName |
Interface name |
Possible Causes
Cause 1: TRILL authentication was configured for the local interface or process. The authentication mode configured on the remote device was different from that configured on the local device.
Cause 2: TRILL authentication was configured for the local interface or process, but not for the remote interface or process.
Procedure
- Check the TRILL process ID from the trillSysInstance field in the trap information.
- Identify the PDU type based on the second byte of the trillPduFragment field.
- 14: Hello packet. Go to Step 3.
- 1B: LSP. Go to Step 5.
- 11: SNP. Go to Step 6.
- Run the display trill peer command on the source switch to check the interface that sent the PDU and run the display this command in the interface view to check whether the configured
authentication mode is the same as that configured on the destination switch.
If the two authentication modes are the same, go to Step 8.
If the two authentication modes are different, go to Step 4.
- Run the trill authentication-mode command in the interface view of the source switch to change the authentication mode to the one configured on the destination switch, ensure that the passwords configured on both sides are the same,
and then check whether the trap is cleared.
If the trap is cleared, go to Step 8.
If the trap persists, go to Step 7.
- Run the display current-configuration configuration trill command on the source switch to check whether an authentication mode is configured in the TRILL
process and whether the authentication mode is the same as that configured
on the destination switch. Ensure that the passwords configured on both sides are the same.
If an authentication mode is configured in the TRILL process and the two authentication modes are the same, go to Step 8.
If no authentication mode is configured in the TRILL process or the two authentication modes are different, go to Step 7.
- Run the area-authentication-mode command in the TRILL view of the source switch to change the authentication mode to the one configured on the destination switch and then check whether the trap is cleared.
If the trap is cleared, go to Step 8.
If the trap persists, go to Step 7.
- Collect log information and configuration information, and then contact technical support personnel.
- End.