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Log Reference

CloudEngine 8800, 7800, 6800, and 5800 V200R005C00

This document provides the explanations, causes, and recommended actions of logs on the product.
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OPENFLOW/2/hwOFPSessionDown_active

OPENFLOW/2/hwOFPSessionDown_active

Message

OPENFLOW/2/hwOFPSessionDown_active: Openflow connection is down. (IP Type=[OpenflowIpType], Local IP=[OpenflowLocalIp], Remote IP=[OpenflowRemoteIp], VrfName=[VrfName], DatapathId=[DatapathId], AuxiliaryId=[AuxiliaryId], SubReason=[SubReason], Reason=[Reason])

Description

The OpenFlow connection was interrupted.

Parameters

Parameter Name Parameter Meaning

IP Type

Type of an IP address

Local IP

IP address of a forwarder of an OpenFlow connection

Remote IP

IP address of a controller of an OpenFlow connection

VrfName

Index of a VRF instance in which an OpenFlow connection is established

DatapathId

ID of an OpenFlow forwarder

AuxiliaryId

Auxiliary connection ID

SubReason

Reason why an OpenFlow connection was interrupted

Reason

Reason why an OpenFlow session went Down

Possible Causes

Cause 1: A TCP connection became abnormal.

Cause 2: OpenFlow heartbeat packets timed out.

Cause 3: A forwarder received invalid packets sent by the controller of an OpenFlow session or incorrectly processed received packets.

Procedure

  • Cause 1: A TCP connection became abnormal.
    1. Check whether the OpenFlow configuration on the controller is modified or deleted.

      • If the configuration is changed, correct the configuration on the remote device.
      • If the configuration is not changed, go to Step 2.

    2. Run the ping command on both ends of the OpenFlow connection to monitor link connectivity.

      • If the ping is successful, go to Step 3.
      • If the ping fails, rectify the connectivity fault. Then go to Step 3.

    3. Run the display sdn openflow session command to view the OpenFlow session status.

      • If the OpenFlow session status is not "REGISTERED", go to Step 4.
      • If the OpenFlow session status is "REGISTERED", go to Step 5.

    4. Collect trap, log, and configuration information, and contact technical support personnel.
    5. End.
  • Cause 2: OpenFlow heartbeat packets timed out.
    1. Run the ping command on both ends of the OpenFlow connection to monitor link connectivity.

      • If the ping is successful, go to Step 2.
      • If the ping fails, rectify the connectivity fault. Then go to Step 2.

    2. Run the display sdn openflow session command to view the OpenFlow session status.

      • If the OpenFlow session status is not "REGISTERED", go to Step 3.
      • If the OpenFlow session status is not "REGISTERED", go to Step 4.

    3. Collect trap, log, and configuration information, and contact technical support personnel.
    4. End.
  • Cause 3: A forwarder received invalid packets sent by the controller of an OpenFlow session or incorrectly processed received packets.
    1. Collect trap, log, and configuration information, and contact technical support personnel.
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Updated: 2019-04-20

Document ID: EDOC1100039602

Views: 124464

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