No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the BFD Echo Function

Example for Configuring the BFD Echo Function

Networking Requirements

In Figure 2-30, SwitchA connects to SwitchB through a direct link. SwitchA supports BFD, whereas SwitchB does not support BFD. Faults on the link between SwitchA and SwitchB need to be quickly detected.

Figure 2-30 Networking diagram for configuring the BFD echo function

Configuration Roadmap

The configuration roadmap is as follows:

Configure the BFD echo function on SwitchA to detect faults on the link between SwitchA and SwitchB.

Procedure

  1. On SwitchA and SwitchB, create VLANs, and configure 10GE1/0/1 interfaces as trunk interfaces and add the interfaces to VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 13
    [*SwitchA-vlan13] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 13 
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] commit

    # Configure SwitchB.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan 13
    [*SwitchB-vlan13] quit
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 13 
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] commit

  2. Set IP addresses of VLANIF interfaces so that SwitchA can communicate with SwitchB at Layer 3.

    # Configure SwitchA.

    [~SwitchA] interface vlanif13
    [*SwitchA-Vlanif13] ip address 10.1.1.5 24
    [*SwitchA-Vlanif13] quit
    [*SwitchA] commit

    # Configure SwitchB.

    [~SwitchB] interface vlanif13
    [*SwitchB-Vlanif13] ip address 10.1.1.6 24
    [*SwitchB-Vlanif13] quit
    [*SwitchB] commit

  3. Configure a BFD session supporting the BFD echo function.

    # Configure SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atob bind peer-ip 10.1.1.6 interface vlanif13 source-ip 10.1.1.5 one-arm-echo
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit

  4. Verify the configuration.

    Run the display bfd session all verbose command on SwitchA. You can see that a single-hop BFD session is set up and is in Up state.

    [~SwitchA] display bfd session all verbose
    (w): State in WTR                                                                                                                   
    (*): State is invalid                                                                                                               
    Total UP/DOWN Session Number : 1/0 
    --------------------------------------------------------------------------------                                                    
      Name : atob                  (Single Hops)   State : Up                                                                           
    --------------------------------------------------------------------------------                                                    
      Local Discriminator    : 1                Remote Discriminator   : -                                                              
      Session Detect Mode    : Asynchronous One-arm-echo Mode                                                                           
      BFD Bind Type          : Interface(Vlanif13)                                                                                      
      Bind Session Type      : Static                                                                                                   
      Bind Peer IP Address   : 10.1.1.6                                                                                             
      Bind Interface         : Vlanif13                                                                                                 
      Bind Source IP Address : 10.1.1.5
      FSM Board ID           : 1                ToS-EXP                : 7                                                              
      Echo Rx Interval (ms)  : 1000                                                                                                     
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000                                                           
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000                                                           
      Local Detect Multi     : 3                Active Multi           : 3                                                              
      Destination Port       : 3784             TTL                    : 255                                                            
      Process PST            : Disable          Config PST             : Disable                                                        
      Last Local Diagnostic  : No Diagnostic                                                                                            
      Bind Application       : No Application Bind                                                                                      
      Session Description    : -                                                                                                        
    -------------------------------------------------------------------------------- 

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 13
    #
    bfd
    #
    interface Vlanif13
     ip address 10.1.1.5 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 13
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif13 source-ip 10.1.1.5 one-arm-echo
     discriminator local 1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 13
    #
    interface Vlanif13
     ip address 10.1.1.6 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 13
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100040245

Views: 35931

Downloads: 118

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next