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eSight V300R010C00 Operation Guide 07

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Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
FAQ and Troubleshooting Typical Configuration Examples

FAQ and Troubleshooting Typical Configuration Examples

This topic describes how to resolve issues that may occur during server management by using eSight.

Failed to Upload Software Due to the Automatic Logout of the Client During an Attempt to Add a Software Source on eSight

Symptom

When a user attempts to add a software source on eSight, software uploading fails because the client logs out automatically.

Possible Causes

The function for logout upon timeout is enabled on eSight and the value of Idle time (min) is less than the time required for uploading software.

Procedure
  1. On the menu bar, choose System > User Management > My Settings.
  2. Configure the function for logout upon timeout.

    • Select Enable auto logout and increase the value of Idle Time. It is recommended that you set the idle duration to 1 hour.
    • Deselect Enable auto logout to disable the function.

  3. Click Apply.

Failed to Install the SLES OS Due to Error Partitioning Format

Symptom

The SLES OS installation fails and the system displays "Error while configuring partitions. Try again".

Possible Causes

The SLES OS to be installed does not support the partitioning format.

Fault Diagnosis
  1. When the message in the following figure is displayed, press Ctrl+Alt+F2 to enter the CLI.

  2. Enter fdisk –l and press Enter. The following alarm information is displayed.

    The SLES OS does not support the GUID partition table (GPT) format. Convert the disk format to the master boot record (MBR) format.

Procedure
  1. Press Ctrl+Alt+F2 to switch to a terminal screen.
  2. Run the fdisk –l command to view disk information. Perform boot partition on the disk where the OS is installed, that is, convert the GPT format to the MBR format.
  3. Run the parted –s /dev/sda mklabel msdos command to install the OS in the disk partition.
  4. Reinstall the SLES OS.

What Do I Do If eSight Fails to Deploy Windows

Symptom

Copying file fails.

Possible Causes

The server where eSight is installed and the managed server are not in the same work group.

Fault Diagnosis

The attempt to access the shared directory of the server where eSight is installed fails.

You may not have the permission to use the network resource. Contact the server administrator to check whether you have the permission.

Multiple connections between the server or shared resource and one user using more than one user name are not allowed. Disconnect these connections and access the shared resource or the server again.

Procedure
  1. Log in to the server where eSight is installed.
  2. On the Start menu, right-click Computer and choose Properties from the shortcut menu.
  3. In the Computer name, domain, and workgroup settings area, check whether the server where eSight is installed and the managed server are in the same work group.

    Method for changing the work group as follows:

    1. Click Change settings.
    2. In the System Properties window, click Computer Name.
    3. Click Change.
    4. In the Computer Name/Domain Changes window, select Workgroup and enter the new work group name in the Workgroup text box.
    5. Click OK.

  4. Remotely access the shared directory of the server where eSight is installed.

    If the access is successful, you can deploy Windows.

How to Resolve Configuration Deployment, Firmware Upgrade, or Stateless Computing Failures After Default VMM Port Change

Symptom

After the default VMM port is changed, BIOS/RAID/HBA/CNA configuration deployment, firmware upgrade, or stateless computing fails.

Possible Causes

The default VMM port of the server must be used when eSight executes firmware upgrade, stateless computing, and BIOS/HBA/CNA deployment. If the default VMM port is changed, the connection to the virtual media fails, and the preceding tasks fail.

Procedure
  • Log in to the server WebUI.
  • Go to the VMM port configuration page.
  • Restore the default configuration.

What Can I Do If a Message Is Displayed, Indicating that the ServiceCD Software Does Not Exist or the File Name Is Incorrect During Operating System Deployment

Symptom

When eSight is used to deploy an operating system for a V3 server, a message is displayed, indicating that the ServiceCD software does not exist or the file name is incorrect.

Possible Causes
  • The eSight installation path does not contain the ServiceCD software.
  • The name of the ServiceCD folder in the eSight installation path is incorrect.
Procedure
  1. Visit http://support.huawei.com/enterprise to download the ServiceCD software.

    NOTE:

    The ServiceCD file that supports iBMA integration is FusionServer Tools-ServiceCD2.0-V131.zip or a later version, and the integrated iBMA version is V1.30 or a later version.

  2. Decompress the downloaded software package.
  3. Change the name of the file with the suffix .iso to FusionServer Tools-ServiceCD2.0-V110.iso.
  4. Copy FusionServer Tools-ServiceCD2.0-V110.iso to eSight installation directory\AppBase\var\iemp\data\ftp\.
  5. Check the read permission of the ossuser user on the FusionServer Tools-ServiceCD2.0-V110.iso file.

    1. Log in to the eSight server as the ossuser user.
    2. Run the following commands to check permission on the FusionServer Tools-ServiceCD2.0-V110.iso file:

      cd eSight installation directory\AppBase\var\iemp\data\ftp

      ll

  6. (Optional) Run the following command to change the owner of the FusionServer Tools-ServiceCD2.0-V110.iso file to ossuser:

    chown ossuser:ossgroup FusionServer Tools-ServiceCD2.0-V110.iso

What Can I Do If a Message Is Displayed, Indicating that the Smart Provisioning Software Does Not Exist or the File Name Is Incorrect During Operating System Deployment

Symptom

When eSight is used to deploy an operating system for a V5 server, a message is displayed, indicating that the Smart Provisioning software does not exist or the file name is incorrect.

Possible Causes
  • The eSight installation path does not contain the Smart Provisioning software.
  • The name of the Smart Provisioning folder in the eSight installation path is incorrect.
Procedure
  1. Visit http://support.huawei.com/enterprise to download the Smart Provisioning software.

    NOTE:

    The Smart Provisioning file that supports iBMA integration is SmartProvisioning-V112.zip or a later version, and the integrated iBMA version is V1.30 or a later version.

  2. Decompress the downloaded software package.
  3. Change the name of the file with the suffix .iso to SmartProvisioning.iso.
  4. Copy SmartProvisioning.iso to eSight installation directory\AppBase\var\iemp\data\ftp\.
  5. Check the read permission of the ossuser user on the SmartProvisioning.iso file.

    1. Log in to the eSight server as the ossuser user.
    2. Run the following commands to check permission on the SmartProvisioning.iso file:

      cd eSight installation directory\AppBase\var\iemp\data\ftp

      ll

  6. (Optional) Run the following command to change the owner of the SmartProvisioning.iso file to ossuser:

    chown ossuser:ossgroup SmartProvisioning.iso

How Do I View the Configuration Information of the Configuration and Deployment Module

Question

How to view the configuration information of the configuration and deployment module?

Answer
  1. Log in to the KVM.

    Log in to the server WebUI. Choose Remote Control in the navigation tree, and click Remote Virtual Console.

  2. Go to the fully out-of-band deployment directory (/home/outband/eSightCfg) to view configuration information.

    • The result.XML file details the configuration results.
    • The profile.XML file details the profiles created by a user.
    • The MegaSAS.log file details RAID controller card loading results.
    • The cfg_and_export_run.log_CNA_X.log file details configuration results of all CNAs.
    NOTE:

    The number of files varies depending on the server configurations.

    The following figure is for reference only.

What Can I Do If the BIOS/CNA/RAID of E9000 Blades Fails to Be Configured or the CNA/RAID of E9000 Blades Fails to Be Upgraded on eSight

Symptom
  • When the BIOS, CNA, or RAID configuration is delivered to E9000 blades, the virtual media connection failed.
  • When the CNA or RAID of E9000 blades is upgraded, the virtual media connection failed.
Possible Causes
  • The HMM user does not have the KVM permission.
  • The communication between eSight and the managed server is abnormal.
Procedure
  1. Access the HMM web page of the blade server.
  2. Check whether the HMM users (including the root user) have permission on the KVM interface.

    • If yes, no further action is required.
    • If no, perform 3~5.

  3. Connect the HMM910 serial port and the PC using a serial cable.
  4. Use PuTTY and the IP address of the HMM910 serial port to log in to the port as an HMM user from the PC.
  5. Run the following command to add the KVM interface permission:

    smmset [ -l smm ] -d userintfauth -v root privilege

    NOTE:
    • This command can be run only through the HMM910 serial port.
    • In the preceding command, privilege indicates the interface permission. You can set it as required. For details, see the MM910 Management Module Command Reference.

What Can I Do If the Hard Disk Slots Do Not Match During RAID Configuration

Symptom

When configurations are delivered to servers through a RAID template, the system displays a message indicating that the hard disk slots do not match.

Possible Causes

The iBMC page of a server displays the physical slot numbers of the hard disks. When multiple RAID controller cards are inserted, if you select hard disk slots based on the physical slots, eSight may fail to identify the hard disks.

Solution

If the hard disk backplane of the server has no expander, select the slot numbers as follows:

  • For a RAID controller card with two ports, the hard disk numbers of each RAID controller card should range from 0 to 7. The RAID controller card types include LSI SAS2308, LSI SAS2208, LSI SAS3008, LSI SAS3108, Avago SAS3408iMR, and Avago SAS3508.
  • For a RAID controller card with four ports, the hard disk numbers of each RAID controller card should range from 0 to 15. The RAID controller card types include Avago SAS3416iMR and Avago SAS3516.

When creating a RAID template, select slots based on the hard disk slot numbers of the RAID controller card.

For example, as shown in Figure 9-12, during the RAID controller card configuration for the PCIe Card 4, PCIe Card 6, or PCIe Card 8 slot, the hard disk slots selected for the Avago SAS3508 RAID controller card are physical slots. During the configuration on eSight, the slots selected should start from slot 0 of the RAID controller card, as shown in Figure Figure 9-13.

Figure 9-12 Storage information about a server
Figure 9-13 RAID controller card slot configuration on eSight

How Do I Obtain the Silent File of the Operating System

Question

How Do I Obtain the Silent File of the Operating System?

Answer
  1. Log in to the server on which the current operating system is running as the root user.
  2. Copy the silent installation file to the local PC.

    Do as follows to obtain the silent file:

    • SUSE Linux

      Obtain the autoyast.xml file in the /usr/share/doc/packages/yast2-xml directory.

    • Red Hat and CentOS

      Obtain the anaconda-ks.cfg file in the /root directory.

  3. You can modify and save the configuration file autoyast.xml or anaconda-ks.cfg as required.
  4. Click Import to import the autoyast.xml or anaconda-ks.cfg configuration file.

    NOTE:

    The following are examples of the formats of the system language, time zone, and disk partitioning in the anaconda-ks.cfg file:

    • System language: lang en_US.UTF-8
    • Time zone: timezone Asia/Shanghai
    • Disk partitioning (unit: MB):

      #Disk partitioning information

      part / --fstype=ext3 --ondisk=sda --size=14091

      part swap --fstype=swap --ondisk=sda --size=1024

How Do I Do If the Upload Button Does Not Respond When the Size of the To-Be-Uploaded Software Source File Exceeds 4 GB

Symptom

On the software source file management page, the upload button does not respond when the size of the to-be-uploaded software source file exceeds 4 GB.

Procedure
  1. If Internet Explorer is used, use other browsers to upload the software source file.
  2. If the fault persists, log in to the eSight server as the ossuser user and use SFTP to upload the file to the following path:

    • Windows operating system: eSight installation directory\AppBase\var\iemp\data\ftp\osdeploy\sources
    • Linux operating system: eSight installation directory\AppBase\var\iemp\data\ftp

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Updated: 2019-06-30

Document ID: EDOC1100044378

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