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eSight V300R010C00SPC200, 300, and 500 Self-Service Integration Guide 10

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After the eSight IP Address Is Changed, the Northbound SNMP Service Fails to Be Started

After the eSight IP Address Is Changed, the Northbound SNMP Service Fails to Be Started

Symptom

After the eSight IP address is changed, the northbound SNMP service fails to be started.

Possible Causes

Agent_IP configured in <Installation directory>/AppBase/etc/nbi/snmp/snmpagent.xml is the original IP address (for example, 10.137.63.1). Start eSight after its IP address is changed, for example, to 10.137.63.55. During the startup, eSight will check the IP address. If the IP address configured in snmpagent.xml is different from the new IP address, the northbound SNMP service bundle will fail to be started.

Procedure

  1. Access the <eSight installation directory>/AppBase/etc/nbi/snmp directory, open the snmpagent.xml file, change Agent_IP to the new IP address (for example, 10.137.63.55), and save the configuration file.

    Run the netstat -an command to check the service ports opened by the system.

    Run the following commands on the Linux OS:

    cd <eSight installation directory>/AppBase/etc/nbi/snmp

    vi snmpagent.xml

    Type i to enter the editing mode.

    Change the value of Agent_IP.

    Press Esc to exit the editing mode and type :wq to save and exit the configuration file.

  2. Restart eSight.
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Updated: 2019-10-30

Document ID: EDOC1100044386

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